FORUMS

Sunday Debate: Which Factors Caused HTC’s Woes?

Join us in a fun Sunday Debate on HTC’s situation. Come with your … more

HTC’s New Ad Campaign And What It Really Means

HTC has just released three new blind test adverts comparing app loading … more

XDA Picks: Best Apps of the Week (June 27 – July 4)

Apps are at the front and center of any smartphone experience, and with over a … more

HTC One M9 Developer Edition Android 5.1 OTA

The Developer Edition of the HTC One M9 is receiving an over-the-air update to Android 5.1. … more

Device Encryption and Root

19 posts
Thanks Meter: 15
 
By bruzzy, Junior Member on 22nd June 2014, 09:51 PM
Post Reply Subscribe to Thread Email Thread
10th November 2014, 05:17 PM |#11  
Junior Member
Flag Brasília
Thanks Meter: 5
 
More
To be on the safe side, I always unencrypt my device before a FW update with ODIN or Kies or OTA, because I root again after the update.

If you use OTA or Kies you can do the update with the device encrypted, BUT, as you are going to root again, when you install CFAutoroot your device won´t boot, because of the difference in kernel. This is the reason that I unencrypt before FW updates and proceed with encryption again after I check that everything is working as expected.
The Following User Says Thank You to Nickfreedom For This Useful Post: [ View ]
 
 
10th November 2014, 05:20 PM |#12  
SamuriHL's Avatar
Senior Member
Thanks Meter: 1,869
 
More
I may just fully unroot it temporarily, install the update, and then root after with custom recovery. We shall see. I suspect since we're still on 4.4.2 on the Note 10.1 2014 I got quite some time before I have to worry about it. LOL

P.S. I asked because 5.0 is going to turn encryption on by default, so decrypting may not be an option going forward.
24th December 2014, 06:46 AM |#13  
Junior Member
Thanks Meter: 0
 
More
Thumbs up
After hours of trying to get encryption an root at the same time for my Galaxy Note 10.1 (2014), temporary disabling SuperSU just worked. Thanks! (I even could skip the part with copying the su binary, probably chainfire has fixed the bug. Just tried enabling SuperSU did it perfectly.)
24th January 2015, 01:19 PM |#14  
Member
Thanks Meter: 1
 
More
Hi there

I'm facing a similar problem like you on my Samsung Galaxy Tab S 10.5 LTE.

I have my device:
- rooted
- twrp recovery installed
- run custom ROM

However even when I disable SuperSU and reboot the device and then start encrypting. I only see the Android Logo and no progress. AFter a while (10 minutes or so), it reboots the tab and I end ab at screen lock login and devices is not encrypted. Any ideas?
28th June 2015, 04:04 PM |#15  
papperlapapp's Avatar
Senior Member
Thanks Meter: 5
 
More
Thank you for your great effort to help!

But, none of the methods, including the alternative from Nickfreedom did not help me...

I have a Sony Xperia Z1 with rooted Lollipop and SuperSU.

I tried to kill daemonsu with ADB before encrypting, I tried to disable the SuperSU app and I always booted into safe mode before starting encryption.

Nothing helped.

In previous times I had Xposed framework on my device, but as far as I can see, Xposed framework is no longer on my device, I installed a fresh, clean Sony ROM from scratch, I think this has erased Xposed.

Does anyone has a hint?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes