FORUMS

How to Lock and Protect Your Apps – XDA Xposed Tuesday

The smartphone revolution has passed. Everybody has mobile apps. Some of … more

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

WiFi NVRAM WARNING: ERR 0x10 Problem Fixed

15 posts
Thanks Meter: 109
 
Post Reply Subscribe to Thread Email Thread
14th April 2015, 01:00 AM |#61  
Junior Member
Thanks Meter: 0
 
More
Alternately (MTK6582)
Thanks for the solution, but for me it's not completely worked. My phone Timmy E86, MTK6582
I downloaded the Wifi_Fix_Files.rar is, unpacked, but Root Explorer sent me copying the error message.
The solution for me: TWRP 2.8.1.0 -> Mount menu -> check everywhere (except SD-EXT)
then back home -> File Manager -> EMMC folder -> Download folder (or wherever you packed out) -> Wifi Fix Files folder -> WiFi takes hold -> Copy
up to level -> data ... -> the other in the same way as above. I'll repeat this again in another file as well. Reboot and it works.

Sorry for my English, I am using Google Translate.

Thank You!
 
 
11th May 2015, 02:11 PM |#62  
Junior Member
Thanks Meter: 0
 
More
Which Part of the WIFI file to edit?
Am I guessing right, that I have to change the numbers "B33F7D95B020" in the "WIFI" Hex-opened File with my (intended) MAC-Address?
At least in my hex-editor, the "B" in the above number has the values "Line 1, Column 4".
Last edited by io2345; 11th May 2015 at 03:43 PM.
13th May 2015, 08:07 PM |#63  
Junior Member
Thanks Meter: 0
 
More
I can confirm that it works that way on Lenovo Yoga 10 (B8000).
The sad thing: It only works until the next reboot, then the old settings are active again (MAC starting with 00:08:22...)

Is there are cure for it?
21st May 2015, 09:37 PM |#64  
Junior Member
Thanks Meter: 0
 
More
Thumbs up many thanks.. it worked ..thanks a lot
Quote:
Originally Posted by Nilendu

Many MTK device's users are facing the WiFi NVRAM WARNING err 0x10 Problem by formatting the whole flash by SP Flash Tool.
After a long time I Found a Solution for mtk Users to solve the problem.

This method is easy as any other methods..

What you need to perform the methods..??
1. A Rooted MTK device
2. Root Explorer.apk
3. Wifi Error Fix.rar

How to do this?

On Your Rooted device go to root Explorer
And navigate to File system root/
data/nvram/APCFG/APRDEB
There you will found to files named 1) WIFI , 2) WIFI_CUSTOM just simply delete these files

Now extract the files from the WiFi fix.rar
and move the extracted files to the previous (root/
data/nvram/APCFG/APRDEB) folder.

After this process complete You need to just reboot your device. Now go to the wifi adapter setting and you will find the message of NVRAM Error Warning is gone...

I tested this on my Micromax A89 Ninja(Mt6577).



If I helped you all just say thanks by hit the Thanks Button...

30th May 2015, 12:14 AM |#65  
Senior Member
Flag Gothenburg
Thanks Meter: 22
 
More
Quote:
Originally Posted by io2345

Am I guessing right, that I have to change the numbers "B33F7D95B020" in the "WIFI" Hex-opened File with my (intended) MAC-Address?
At least in my hex-editor, the "B" in the above number has the values "Line 1, Column 4".

The MAC address in the fixed file is D0:B3:3F:7D:95:B0. You have written the values in column 5 to A. The numbering starts with 0, not 1.

But, when I change to my original MAC in a HEX editor I get the NVRAM error back again, so I'm stuck with the MAC address in the file that @Nilendu posted.
Never mind, the chance that I will ever be on the same wifi as someone els who has used the same fix is probably one in a billion. The annoying NVRAM error is gone, which is the main thing for me.
8th June 2015, 03:12 PM |#66  
Junior Member
Thanks Meter: 0
 
More
Thumbs up Salutes
Thanks a lot for helping us without any charges. Hats to you.
Thanks
16th June 2015, 07:00 PM |#67  
faisaldeus's Avatar
Member
Flag mumbai
Thanks Meter: 14
 
Donate to Me
More
Thumbs up
Awesome did not even need to reboot!!
29th June 2015, 10:40 AM |#68  
hackerpower's Avatar
Senior Member
Flag Lisbon
Thanks Meter: 111
 
Donate to Me
More
Working for me on my Lenovo K3 Note
1st July 2015, 07:34 PM |#69  
Senior Member
Thanks Meter: 33
 
More
Work on my Cubot One MTK6589T
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes