FORUMS

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

Sunday Debate: How Can We Get a No-Compromise Phone?

Join us in a fun Sunday Debate on Compromises. Come with your opinions and … more

PSA: You Can Optimize Your Note 4’s Recents Menu & RAM

The Note 4 never had the fastest Recents Menu, and despite its 3GB of RAM, … more

Half-Life 2 (portal) playable on non-tegra devices [How to]

3 posts
Thanks Meter: 13
 
By Marchelino, Junior Member on 2nd June 2014, 09:18 AM
Post Reply Subscribe to Thread Email Thread
2nd July 2015, 03:44 AM |#121  
Junior Member
Flag Manhattan
Thanks Meter: 2
 
More
Try different settings in GLTools
Quote:
Originally Posted by puppetman

Has anyone tried to get Half Life 2 to work on the Galaxy Note 4?

My attempt got me to the title screen but only a quarter of the size of the screen with black artifacts and sound.

Can anyone help? please.

Right now i'm using these settings:
MANDATORY
Enable custom settings for this app
Optimize GLSL shaders
Use fake GPU info
Use a template: Tegra 4 (SHEILD)
Simple MapBuffer emulation
Software VBO emulation
Use packed stencil buffer

OPTIONAL
Half-float texture hack
Fix FBO attachment sizes
Ignore SIGTRAP

I'm about half way through and it looks and runs pretty good.
If those settings don't help try the settings in post #115
I'm on a Note 3 with a custom ROM, so it's hard to say what may be wrong.

Good Luck
The Following 2 Users Say Thank You to ItsTabulous For This Useful Post: [ View ]
 
 
21st July 2015, 01:05 PM |#122  
Senior Member
Flag Porto
Thanks Meter: 95
 
More
Talking
Confirmed fully working with above settings on a Xiaomi Mi3 running MIUI v6 developer (Android 4.4.4)
Using Half-Life 2 v44, GLTools XDA version 129 and IPega 9025 bluetooth gamepad.
Game runs on an average of 25fps, slows down on larger areas but nothing unplayable. Only crashed once, accessing the main menu after pausing, seems to be a random crash.
"Decode sRGB" works and changes some textures and shaders but the fps seems to drop down a bit if using it.
"Use lower render resolution" and "force 16bit rendering" work as well but do nothing to improve fps, so don't bother.
I really reccomend shutting down any and all apps running on background, as the game is pretty demanding on resources and eats about 1% of battery for every minute playing :P

UPDATE: Tried settings of post #115 after i saw the video that the user linked and the average fps increased to about 30, it's very very good now!
Last edited by JBolho; 21st July 2015 at 02:59 PM. Reason: Updated Info
21st July 2015, 05:48 PM |#123  
Xelasarg's Avatar
Member
Thanks Meter: 51
 
More
I've got a weird issue: I can sort of load the game when (and only when) I check "Decode sRGB", but the start menu is completely messed up, see attached screenshot. I'm on Note 4 (910F, Snapdragon 805, Lollipop 5.0.1). Any ideas what I'm doing wrong? Or is that an issue with my phone's large screen resolution?

Edit: HL2 (obviously) seems to start up in 1280x720 resolution, hence the quarter screen. Now how do I make it run at full 2560x1440 and look less glitchy...?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2015-07-21-18-01-35.jpg
Views:	158
Size:	121.2 KB
ID:	3413814  
Last edited by Xelasarg; 23rd July 2015 at 08:58 AM.
Post Reply Subscribe to Thread

Tags
gltools, half-life 2, how to, non-tegra, portal
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes