FORUMS

CloudPlayer: DIY HiFi Music Streaming Solution

In our Helpful Guide to Music Streaming Services, we mentioned several different services … more

Optimize Battery Life with This Useful App

Battery life is an important aspect of your smartphone, especially if you use it for more … more

The OnePlus 2 & The Year of Smartphone Compromises

We are very close to entering the last third of 2015, and we have now seen many of … more

OnePlus 2 Teardown, Major Android Vulnerability – XDA TV

The OnePlus 2 has been officially released. That and much more news is … more

[COMMIT] [AOSP] [LOLLIPOP] JustArchi's ArchiDroid Optimizations - Unleash the power!

8,408 posts
Thanks Meter: 35,376
 
By JustArchi, Recognized Contributor / Recognized Developer on 18th May 2014, 02:38 AM
Post Reply Subscribe to Thread Email Thread
29th July 2015, 04:14 PM |#1331  
sparksco's Avatar
Recognized Developer
Thanks Meter: 8,537
 
Donate to Me
More
Quote:
Originally Posted by balint933

Hello!
I'm getting the following error : http://pastebin.com/FAikLneJ with these optimizations, bot only since I installed Ubuntu 15.04 dualboot with windows, It worked in windows+virtualbox, I tried the change -march flag, and deleting -march=native, but this error always coems back. Without the optimization build works.
CM12.1 for titan
Intel® Core™ i7-4700MQ CPU
Please help me. thanks

Those optimizations aren't related to this thread. SaberMod does not use march=native
 
 
29th July 2015, 04:21 PM |#1332  
Senior Member
Thanks Meter: 26
 
More
Quote:
Originally Posted by sparksco

Those optimizations aren't related to this thread. SaberMod does not use march=native

if you check the commit, it adds "-march=native" to HOST-linux files. what -march flag should i use?
The commit changes core/combo/HOST_linux-x86.mk file from -march=prescott to -march=native what is the difference?
29th July 2015, 10:38 PM |#1333  
Member
Thanks Meter: 116
 
More
I've succefully build CM11 for gt-i9515 with sabermod's gcc 4.8 and these optimizations but i have strange issue - extSdcard is accessible but i can see only some folders and files (yes - it's formatted with exFAT; yes - i checked it on PC and rest of folders and files are there and they aren't damaged). I did built with exFAT fixes (-Os flag in few places) but problem persist. any ideas how to fix this?

Edit: Problem solved
I've applied these commits + addeed -Os flag to the system/vold/Android.mk:
https://github.com/CyanogenMod/andro...bce5f30331b4c0
https://github.com/CyanogenMod/andro...56c4e8d4f05030
https://github.com/CyanogenMod/andro...1bad4969016066
https://github.com/CyanogenMod/andro...74dbf91354844a
Last edited by sombree; 30th July 2015 at 10:18 PM. Reason: Problem solved
Post Reply Subscribe to Thread

Tags
justarchi archidroid optimizations linaro hack
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes