FORUMS

3G Not working in Russia

1 posts
Thanks Meter: 0
 
By ivanvoronin, Junior Member on 29th May 2014, 05:20 PM
Post Reply Subscribe to Thread Email Thread
sorry for my bad English, i use a translator

Bought yesterday on the phone and it worked 3g HSDPA, after flashed on Viper ROM only works in GSM!!! Help please (((
 
 
1st June 2014, 07:36 AM |#2  
Member
Flag Bangalore
Thanks Meter: 14
 
More
Try changing the network mode to WCDMA only, Type *#*#4636#*#* in the dialer. Select phone information and scroll down to network type and then select WCDMA only.

You might also want to check your APN settings, If your network provider has different APNs for 2G and 3G, you will have to select the 3G one.
Last edited by indy1811; 1st June 2014 at 07:39 AM.
17th August 2015, 05:40 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Unhappy
Quote:
Originally Posted by indy1811

Try changing the network mode to WCDMA only, Type *#*#4636#*#* in the dialer. Select phone information and scroll down to network type and then select WCDMA only.

You might also want to check your APN settings, If your network provider has different APNs for 2G and 3G, you will have to select the 3G one.

I have a sprint htc one m7
hboot 1.57 with S-On
FLashed to stock (Guru reset 3) and OTA updated to lollipop...

I am having the same problem, data network always stays on gsm .. tried everything from booting in safe mode to toggle airplane mode...
From dialing the code *#4636 blah blah and selecting the network mode...
Resetting APN settings for several times and several times of hard reset .. nothing solved the problem at all ..

Couldn't get anything to help me see H,H+ or 3G beside my network signal sign on my phone again ..... it always shows gsm and that's it...

It all happened after i flashed my phone to stock rom by using guru reset 3.x
I was using 3g successfully on bad boyz rom 5.x..
Now i even have got the OTA update for lollipop but my 3g doesn't seem to work at all .....

Please help !!!!
Last edited by perfectduffer; 17th August 2015 at 05:42 AM. Reason: forgot to add something
17th August 2015, 06:29 PM |#4  
Member
Flag Bangalore
Thanks Meter: 14
 
More
Couple of things:

1. The icons have probably changed. To get back the H and E symbols you'll have to edit the default.xml file. Navigate to system > customize > ACC > default.xml. I'd recommend downloading Root Browser to do this. Open the default.xml file using RB Note Editor and scroll all the way down. Around 20-25 lines from the bottom, you'll see the line

<Item type = "integer" name="sku_id">xx</item>

The xx will be a numeric value like 98 or something. Change this value to 42 if you're from Europe or 33 if you're from Asia. You can also change it to 0 which is the default HTC value. The line should now be:

<Item type = "integer" name="sku_id">42</item>

Make sure you save it before exiting. Reboot your phone and you should now see the E, 3G, and H symbols indicating your network connection.

2. Did you do a speedtest? What speeds are you getting?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes