FORUMS

Top Forum Discussions

[Tool] SP Flash Tool New Version v5.1352.01

85 posts
Thanks Meter: 152
 
Post Reply Subscribe to Thread Email Thread
17th August 2015, 03:30 AM |#41  
mi-425's Avatar
Senior Member
Thanks Meter: 23
 
More


Sent from my iball4.5d Quadro using XDA Free mobile app
 
 
25th August 2015, 09:02 AM |#42  
Junior Member
Thanks Meter: 0
 
More
trying to flash my lenovo p780 8gb
I do everything according the tutorial, but my device connects just temporarily for few seconds on ttyACM0 and then its disconnected. here is the log

Connecting to BROM...
Scanning USB port...
Search usb, timeout set as 3600000 ms
add@/devices/pci0000:00/0000:00:1d.7/usb1/1-8

add@/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8:1.0

add@/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8:1.1

add@/devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8:1.1/tty/ttyACM0

vid is 0e8d

device vid = 0e8d

pid is 2000

device pid = 2000

com portName is: /dev/ttyACM0

Total wait time = -1440487243.000000
USB port is obtained. path name(/dev/ttyACM0), port name(/dev/ttyACM0)
USB port detected: /dev/ttyACM0
BROM connected
Downloading & Connecting to DA...
COM port is open. Trying to sync with the target...
DA Connected
Disconnect!
App Exception! (Unrecognized ROM detected.)((fw_throw_error,../../../flashtool/Flow/ErrString.cpp,24))
comboTimeout index(3) saved.

what can I do with that?
26th August 2015, 06:20 AM |#43  
Member
Thanks Meter: 38
 
More
The error message hints to a wrong firmware. Are you certain that you chose a ROM compatible with your device?
26th August 2015, 05:04 PM |#44  
Junior Member
Thanks Meter: 0
 
More
of course. I had flashed this custom rom (s226 life xvibe 0.5) a year ago under win7 with FT, now I tried it again - the same rom and another one later version - s226 life xvibe 1.2

p.s. just flashed on win7 , and its working, but under linux FT still doesn't want to flash ((

p.s.2 I've downloaded off firmware P780_8G_ROW_S124_140403 and I've tried to flash it. When scatter was chosen, location path of "PRELOAD" section was empty. I clicked it and chosen preload.img in target_bin. Then I clicked Download and get "PMT changed for the ROM; it must be downloaded" message. If I try again and don't touch "PRELOAD" section, the error still is "Unrecognized ROM detected".
Maybe its all about that my lenovo p780 has integrated battery (which I cannot pull out to prevent loading device, when it connected to PC) and PC system cannot catch the moment of the device loading, because its disconnecting after a few seconds and ttyACM0 is disappearing (see the log)?
Last edited by jinxted; 27th August 2015 at 09:30 AM.
27th August 2015, 02:54 PM |#45  
Member
Thanks Meter: 38
 
More
If you are 100 % certain that the firmware and preloader.bin are correct, you can try to flash it as Firmware Upgrade. As far as I know the partitioning format has changed some time before the linux tool became available.
I don't think that the battery causes the error...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes