FORUMS

Analysis & Opinion

Lg phones apn type grayed out

4 posts
Thanks Meter: 5
 
By Firebourne, Junior Member on 23rd May 2014, 08:09 PM
Post Reply Subscribe to Thread Email Thread
17th March 2015, 05:25 AM |#51  
Junior Member
Thanks Meter: 0
 
More
Additional Option, may be needed for some phones
Just a heads up for other users, there are apparently some sort of settings that will require a variation to this method. My wife and I each have the LG Optimus G Pro and my phone worked with this method but hers would not. A little research found the same basic process but different settings, if the below method doesn't work go here and try the att.mvno settings.

http :// smartphonematters.com / help/ help-setting-up-straight-talk-data-and-mms-on-the-lg-optimus-g-pro-e980-running-android-4-1-2 / #comment-95185
Take the spaces out, user restrictions require them.

Quote:
Originally Posted by brodood

It is possible to change the APN type without SQLite or root. The guys at my work figured this out. It is kind of a tricky workaround, but this is tested and working on LG Optimus G Pro, G Flex, and G2 with the MMS issues.

1. Go to the APN Settings and reset them to default. After that you should only see the AT&T APN
2. With the SIM card in the phone open Mobile Networks (get to the screen where you can click on Access Point names.)
3. DO NOT POWER OFF THE PHONE FOR THIS PART! On that screen and with the phone still on, slide the SIM out. You should get a prompt asking to reset the phone. DO NOT RESET THE PHONE.
4. After the prompt click on Access Point Names. There should be no APNs here. If the AT&T APN is still here go back to step 1.
5. Now you need to create a new APN whit the SIM is removed. The APN should be as follows:
Name: Straight Talk MMS
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: 66.209.11.33
mmsport: 80
mmsc: http: // mms-tf. net - This is spaced for Junior User restrictions. Should be no spaces.
authtype:none
type: mms
THE APN TYPE SHOULD ONLY BE FOR MMS. DO NOT PUT ANYTHING ELSE IN THE "TYPE" FIELD
6. Now with everything typed in DOUBLE CHECK EVERYTHING. If it is correct you can save this APN. Once it is saved there will still be no APNs on the APN page.
7. Pull the battery and put the SIM back in the phone.
8. Go back to the APN settings and DO NOT open the APN you just created or it will reset the entire process!!!!! If you did everything right the Straight Talk MMS APN you just made should not have the selection bubble. If you have a selection bubble on the Straight Talk MMS, go back to Step 1.
9. Make another new APN as Follows:
Name: Straight Talk
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: (blank)
mmsport: (blank)
mmsc: (blank)
Mcc: 310
Mnc : 410
type: default
10. Save this APN and select it. You should get LTE shortly after that.

That's it! If you want MMS without root this is the only other workaround I know of! This was tested on multiple Optimus G Pro, G Flex, and G2 and is working! Hope it Helps.

 
 
20th July 2015, 11:48 PM |#52  
Junior Member
Thanks Meter: 1
 
More
SQLite Editor
Quote:
Originally Posted by Firebourne

I have an at&t e980 and im on straight talk updated to 4.4.2 kitkat. When i went to put my APN settings back in the APN Type was grayed out and i couldnt send MMS. I found the solution on the Androud Forum site but cant find the link it was under the g2 forum. Basically you have to be rooted and install SQLite Editor and go to data/data/com.android.providers.telephony/databases then click on telephony.db and then carriers. Delete all of the APNs but the one listed as LGE DEFAULT and then the Straight Talk one change the apn type line from "default" to "default,mms,supl" and then make everything else match what the other says as far as the values that you didnt input yourself then save and reboot and it will be changed and editable from then on. I dont know if anyone else will need this and my instuctions may not be clear, but i figured an answer is better then no answer. any questions just ask ill do what i can to help

Just an FYI to anyone having issues getting the telephony.db saved with the new changes. Using the free SQLite Editor wasted a LOT of my time. I finally broke down and paid $2.99 to the SQLite Editor by SPEED SOFTWARE. It offers a "save" setting and it took immediately. To reaffirm what another poster said, you don't need to delete anything. Just change the Straight Talk APN settings for type = default,mms,supl and usercreate = 0. I did those two things and it worked immediately.

Thanks for the thread!
The Following User Says Thank You to Hannibal_32 For This Useful Post: [ View ]
21st July 2015, 08:17 PM |#53  
Dvoraak's Avatar
Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by Hannibal_32

usercreate = 0.

I've been banging my head on this problem for hours now but that one thing fixed it.

Thanks!
The Following User Says Thank You to Dvoraak For This Useful Post: [ View ]
30th August 2015, 03:07 PM |#54  
ThaHawk's Avatar
Member
Flag Philadelphia
Thanks Meter: 1
 
More
Quote:
Originally Posted by brodood

It is possible to change the APN type without SQLite or root. The guys at my work figured this out. It is kind of a tricky workaround, but this is tested and working on LG Optimus G Pro, G Flex, and G2 with the MMS issues.

1. Go to the APN Settings and reset them to default. After that you should only see the AT&T APN
2. With the SIM card in the phone open Mobile Networks (get to the screen where you can click on Access Point names.)
3. DO NOT POWER OFF THE PHONE FOR THIS PART! On that screen and with the phone still on, slide the SIM out. You should get a prompt asking to reset the phone. DO NOT RESET THE PHONE.
4. After the prompt click on Access Point Names. There should be no APNs here. If the AT&T APN is still here go back to step 1.
5. Now you need to create a new APN whit the SIM is removed. The APN should be as follows:
Name: Straight Talk MMS
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: 66.209.11.33
mmsport: 80
mmsc: http: // mms-tf. net - This is spaced for Junior User restrictions. Should be no spaces.
authtype:none
type: mms
THE APN TYPE SHOULD ONLY BE FOR MMS. DO NOT PUT ANYTHING ELSE IN THE "TYPE" FIELD
6. Now with everything typed in DOUBLE CHECK EVERYTHING. If it is correct you can save this APN. Once it is saved there will still be no APNs on the APN page.
7. Pull the battery and put the SIM back in the phone.
8. Go back to the APN settings and DO NOT open the APN you just created or it will reset the entire process!!!!! If you did everything right the Straight Talk MMS APN you just made should not have the selection bubble. If you have a selection bubble on the Straight Talk MMS, go back to Step 1.
9. Make another new APN as Follows:
Name: Straight Talk
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: (blank)
mmsport: (blank)
mmsc: (blank)
Mcc: 310
Mnc : 410
type: default
10. Save this APN and select it. You should get LTE shortly after that.

That's it! If you want MMS without root this is the only other workaround I know of! This was tested on multiple Optimus G Pro, G Flex, and G2 and is working! Hope it Helps.

@brodood thanks for the simple solution!
Yesterday, 08:18 PM |#55  
ThaHawk's Avatar
Member
Flag Philadelphia
Thanks Meter: 1
 
More
A good video
http://m.youtube.com/watch?v=S3SC7Sc1-Rs

Sent from my LG-E980 using XDA Free mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes