Watch This Now!

Device Encryption and Root

19 posts
Thanks Meter: 16
By bruzzy, Junior Member on 22nd June 2014, 09:51 PM
Post Reply Subscribe to Thread Email Thread
10th November 2014, 05:17 PM |#11  
Junior Member
Flag Brasília
Thanks Meter: 5
To be on the safe side, I always unencrypt my device before a FW update with ODIN or Kies or OTA, because I root again after the update.

If you use OTA or Kies you can do the update with the device encrypted, BUT, as you are going to root again, when you install CFAutoroot your device won´t boot, because of the difference in kernel. This is the reason that I unencrypt before FW updates and proceed with encryption again after I check that everything is working as expected.
The Following User Says Thank You to Nickfreedom For This Useful Post: [ View ]
10th November 2014, 05:20 PM |#12  
SamuriHL's Avatar
Senior Member
Thanks Meter: 1,941
I may just fully unroot it temporarily, install the update, and then root after with custom recovery. We shall see. I suspect since we're still on 4.4.2 on the Note 10.1 2014 I got quite some time before I have to worry about it. LOL

P.S. I asked because 5.0 is going to turn encryption on by default, so decrypting may not be an option going forward.
24th December 2014, 06:46 AM |#13  
Junior Member
Thanks Meter: 0
Thumbs up
After hours of trying to get encryption an root at the same time for my Galaxy Note 10.1 (2014), temporary disabling SuperSU just worked. Thanks! (I even could skip the part with copying the su binary, probably chainfire has fixed the bug. Just tried enabling SuperSU did it perfectly.)
24th January 2015, 01:19 PM |#14  
Thanks Meter: 1
Hi there

I'm facing a similar problem like you on my Samsung Galaxy Tab S 10.5 LTE.

I have my device:
- rooted
- twrp recovery installed
- run custom ROM

However even when I disable SuperSU and reboot the device and then start encrypting. I only see the Android Logo and no progress. AFter a while (10 minutes or so), it reboots the tab and I end ab at screen lock login and devices is not encrypted. Any ideas?
28th June 2015, 04:04 PM |#15  
papperlapapp's Avatar
Senior Member
Thanks Meter: 5
Thank you for your great effort to help!

But, none of the methods, including the alternative from Nickfreedom did not help me...

I have a Sony Xperia Z1 with rooted Lollipop and SuperSU.

I tried to kill daemonsu with ADB before encrypting, I tried to disable the SuperSU app and I always booted into safe mode before starting encryption.

Nothing helped.

In previous times I had Xposed framework on my device, but as far as I can see, Xposed framework is no longer on my device, I installed a fresh, clean Sony ROM from scratch, I think this has erased Xposed.

Does anyone has a hint?
28th July 2015, 08:46 PM |#16  
Junior Member
Thanks Meter: 1
Thanks to everyone for the posts on this topic. I too have struggled to get my Sprint Note 4 to encrypt after rooting. I was able to encrypt with the stock unrooted ROM but I flashed the Noterized ROM and was not able to get encryption to work. I have verified the following:

1) Busybox is installed and is the latest version
2) SuperSU is deactivated. I tried this through terminal emulator and also the process defined in this thread within the SuperSU app itself. I also verified through Root Checker that SU was not active.
3) Tried in normal and safe mode with the same result

I am getting the Android screen for a few minutes and then the phone reboots. Each time I was hoping to see the encryption start but it just reboots the phone and never works. I am at a total loss for what could be causing this as the reason is beyond my capability. If anyone has ideas let me know because I am willing to try anything.

As a longshot I tried to flash back to stock ROM and encrypt which worked fine. I then tried to flash the Noterized ROM back on the phone and that didn't work. I froze on the Sprint yellow screen of death for over 6 hours.
9th September 2015, 06:12 PM |#17  
Junior Member
Thanks Meter: 2
Tutorial Simplified steps for rooting &encrypting your device.
Thanks Bruzzy, I took your instructions and applied them to the Note 4. I also simplified them. I will make a universal instructions set for pretty much ALL DEVICES! Will let you guys know here when i take the time to do that.


Originally Posted by bruzzy

Solution approach:

  1. Device is not rooted and not encypted (if already rooted, scip 2; if already encrypted, decrypt or do a factory-reset - don't try CF-Auto-Root on an encrypted device, it'll soft-brick)
  2. Root the device (e.g. using Auto-Root-CF by Chainfire (it'll trigger the Knox-counter)
  3. Temporarily un-root the device (when using SuperSU: go to Settings and remove the tick at the option "Activate Superuser")
  4. Reboot
  5. Activate the device encryption (the battery must be at least at 80% and the device must be plugged in the wall charger)
  6. The device will restart after a short period of time and start the encryption (this will take some time, but you should see a progress bar indicating how far it is)
  7. After the encryption is finished the device will reboot and ask for the password, just log in
  8. If not yet done, flash a custom recovery where you have a console access or can use ADB as root (I used TWRP)
  9. Boot into recovery
  10. Mount /system (it's not mounted automatically, at least not in the version I used - TWRP
  11. Open the console or ADB shell
  12. Copy the su binary (if you use SuperSU: cp /system/xbin/daemonsu /system/xbin/su)
  13. Execute the installation (if you use SuperSU: /system/xbin/su --install)
  14. Reboot
  15. You should be done

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes