FORUMS
Remove All Ads from XDA

[Linux] [IMG] [Dev] [WIP] *Ubuntu images for Rootbind [TF101 / TF101G]

166 posts
Thanks Meter: 151
 
By DjDill, Senior Member on 15th February 2014, 04:34 AM
Post Reply Subscribe to Thread Email Thread
22nd May 2015, 11:34 AM |#421  
Kingzak34's Avatar
Senior Member
Flag South
Thanks Meter: 1,495
 
Donate to Me
More
Quote:
Originally Posted by BlackSoil

I've no idea why, but for some reason this still doesn't work...

Update about i2c issue:
Apparently the driver in the Android tree is different: it's older and has some wakelock mods.
I tried to use i2c-tegra.c from Android tree with minimal modification, but it doesn't boot due to a kernel panic. Perhaps it's worth to invest time figuring out the panic.

It's nice to see that there is still interest in this TF101. I'm afraid I can't help you with that, but I wish you the best luck to sort this out.
 
 
22nd May 2015, 02:40 PM |#422  
Senior Member
Thanks Meter: 283
 
More
Quote:
Originally Posted by BlackSoil

I've no idea why, but for some reason this still doesn't work...

Update about i2c issue:
Apparently the driver in the Android tree is different: it's older and has some wakelock mods.
I tried to use i2c-tegra.c from Android tree with minimal modification, but it doesn't boot due to a kernel panic. Perhaps it's worth to invest time figuring out the panic.

The Android kernel is ver 2.6.39.4 whicle the Linux kernels are ver 3.1.10. There are bound to be quite a few differences in the tegra board files. Unfortunately my C skills are not good enough to help out here...
20th July 2015, 08:29 PM |#423  
Member
Thanks Meter: 1
 
More
Keyboard and Mouse
Looking through this thread, I've seen some mentions of the keyboard/trackpad becoming unresponsive when the dock battery is low, but I'm experiencing this issue with a fully charged dock (the tablet itself is ~80%). It happens fairly quickly, too - I have to unplug the dock and reattach it every 30 seconds or so to maintain KB/TP functionality.

Has anyone else experienced this using the following?

DJDill's tf101-14.04-Lubuntu-Tegra-armaf.tar.gz
jrohwer's Ubuntu-3.1.10-10-rootbind-1.0GHz.zip

I followed the instructions from KingZack's rootbind thread:

busybox mount -o remount,rw /
mkdir /data/linuxroot
chmod 755 /data/linuxroot
cd /data/linuxroot
tar -pxvzf /storage/sdcard0/yourubuntufilename.tar.gz
busybox mount -o remount,ro /

My android version is KatKiss Lollipop
21st July 2015, 12:22 PM |#424  
Kingzak34's Avatar
Senior Member
Flag South
Thanks Meter: 1,495
 
Donate to Me
More
Quote:
Originally Posted by Harrson

Looking through this thread, I've seen some mentions of the keyboard/trackpad becoming unresponsive when the dock battery is low, but I'm experiencing this issue with a fully charged dock (the tablet itself is ~80%). It happens fairly quickly, too - I have to unplug the dock and reattach it every 30 seconds or so to maintain KB/TP functionality.

Has anyone else experienced this using the following?

DJDill's tf101-14.04-Lubuntu-Tegra-armaf.tar.gz
jrohwer's Ubuntu-3.1.10-10-rootbind-1.0GHz.zip

I followed the instructions from KingZack's rootbind thread:

busybox mount -o remount,rw /
mkdir /data/linuxroot
chmod 755 /data/linuxroot
cd /data/linuxroot
tar -pxvzf /storage/sdcard0/yourubuntufilename.tar.gz
busybox mount -o remount,ro /

My android version is KatKiss Lollipop

Dont connect dock at start until you got on login screen, maybe the problem ?
And check if your dock is really charged.
7th October 2015, 03:33 PM |#425  
Member
Flag Geneseo IL
Thanks Meter: 11
 
Donate to Me
More
I've been running this for a couple days with limited problems, big thanks to the devs! I've got a problem with cpufrequtils script not running at boot (posted in that thread) but the reason I've come here is to ask about an icon issue. I did the wifi red icon fix, rebooted and all my icons were good. Over the course of subsequent reboots my battery indicator icons in task tray suddenly changed to icons that look like text document icons. I thought I could change icon or widget them and get them back but that only cause more icons to dissappear, Pidgin/Audacious/Remmina/image viewer/gnumeric/vlc/onboard/and about half of the system tools menu are now all gear icons. I can find /usr/share/applications and could edit with gedit to change the icons manually but where do i point them to other than /usr/share/icons? If I change my widget and icon themes back to Lubuntu default and reboot I still have the same generic gear icons for everything and the two document icons for my batteries in the task tray. How can I get my icons back? Thanks!!

Edit: I'm running DJDill 14.04, sorry. I found after posting this that if I changed widget theme back to Lubuntu and icon theme to Lubuntu-default and rebooted that my icons all came back as they should be. Maybe the theme/icon packs that I tried to use didn't contain the necessary icons in the correct size?
Last edited by NewMC; 7th October 2015 at 08:50 PM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes