FORUMS
Remove All Ads from XDA

Lg phones apn type grayed out

9 posts
Thanks Meter: 6
 
By Firebourne, Junior Member on 23rd May 2014, 08:09 PM
Post Reply Email Thread
15th October 2015, 03:57 PM |#61  
Junior Member
Flag Savannah
Thanks Meter: 0
 
More
Still doesn't work
Quote:
Originally Posted by ThaHawk

@RavingMiniac go to post #55 for visual

Followed the video to the exact detail, rooted phone using all the items he used, edited file with SQLite editor just like he did, and every single time the AT&T APN keeps reappearing and the phone still won't send photos, won't connect to 4G or LTE, drops calls when dialing and the best signal I can get outside of WiFi is "E" with one or two bars.

POS paperweight that lights up is all this thing is. Thanks for the advice though.
 
 
15th October 2015, 09:13 PM |#62  
ThaHawk's Avatar
Senior Member
Flag Brick City
Thanks Meter: 9
 
More
Quote:
Originally Posted by RavingMiniac

Followed the video to the exact detail, rooted phone using all the items he used, edited file with SQLite editor just like he did, and every single time the AT&T APN keeps reappearing and the phone still won't send photos, won't connect to 4G or LTE, drops calls when dialing and the best signal I can get outside of WiFi is "E" with one or two bars.

POS paperweight that lights up is all this thing is. Thanks for the advice though.

Ok go back to your APN settings hit the menu button then click reset to default
Then put whatever apn you want to put there in and hit save.
then go to your root explorer, data, then data again, com.android.providers.telephony
databases,telephony.db that should open the sqlite editor
hit carriers then go to the apn that you've created and change the following
type: default,mms,supl
defaultsetting: 0
usercreatesetting: 0
save and reboot
you should then be able to go back to the APN that you created and nothing should be greyed out
Also you should be able to send and receive pixs Amigo
16th October 2015, 08:26 PM |#63  
Junior Member
Flag Savannah
Thanks Meter: 0
 
More
Still nothing
Quote:
Originally Posted by ThaHawk

Ok go back to your APN settings hit the menu button then click reset to default
Then put whatever apn you want to put there in and hit save.
then go to your root explorer, data, then data again, com.android.providers.telephony
databases,telephony.db that should open the sqlite editor
hit carriers then go to the apn that you've created and change the following
type: default,mms,supl
defaultsetting: 0
usercreatesetting: 0
save and reboot
you should then be able to go back to the APN that you created and nothing should be greyed out
Also you should be able to send and receive pixs Amigo

Tried your advice step by step and nothing same results. A friend suggested that my software being out of date current version (E98020h) and it should be (E98020i) may have something to do with the phone being so defiant.

I called LG and was told basically that AT&T owns the update even though it's LG's software. Called AT&T who stated based on my IMEI info, my phone was purchased from a member who walked away from a contract they would not provide any assistance with the phone updates. This phone is locked to AT&T and basically useless, even though I own it now, until that amount is paid off to AT&T they will not allow it to be used.

I tried to use TWRP and CWM to conduct a ROM installation thinking I could bypass the whole thing. Got the phone rooted successfully already, but when I tried to install a ROM it appears that AT&T locked access to the recovery menu because the phone just shuts down and sits on the LG logo without booting until you pull the battery and start again. So off to the firing range next week to see what it feels like to empty a magazine in my worthless LG paperweight.
17th October 2015, 04:25 AM |#64  
ThaHawk's Avatar
Senior Member
Flag Brick City
Thanks Meter: 9
 
More
Quote:
Originally Posted by RavingMiniac

Tried your advice step by step and nothing same results. A friend suggested that my software being out of date current version (E98020h) and it should be (E98020i) may have something to do with the phone being so defiant.

I called LG and was told basically that AT&T owns the update even though it's LG's software. Called AT&T who stated based on my IMEI info, my phone was purchased from a member who walked away from a contract they would not provide any assistance with the phone updates. This phone is locked to AT&T and basically useless, even though I own it now, until that amount is paid off to AT&T they will not allow it to be used.

I tried to use TWRP and CWM to conduct a ROM installation thinking I could bypass the whole thing. Got the phone rooted successfully already, but when I tried to install a ROM it appears that AT&T locked access to the recovery menu because the phone just shuts down and sits on the LG logo without booting until you pull the battery and start again. So off to the firing range next week to see what it feels like to empty a magazine in my worthless LG paperweight.

What does it say when you try to update the software?

---------- Post added at 11:25 PM ---------- Previous post was at 11:22 PM ----------

@RavingMiniac and BTW it has nothing to do with you being on 20h
28th May 2016, 03:18 AM |#65  
zapjb's Avatar
Senior Member
Flag RingPlus $15 UTnT 50MB
Thanks Meter: 9
 
More
@brodood post #13 worked for my LG G Flex D950 on Airvoice. Just substituted the Airvoice APN info.

TY TY TY
28th May 2016, 05:18 PM |#66  
zapjb's Avatar
Senior Member
Flag RingPlus $15 UTnT 50MB
Thanks Meter: 9
 
More
Quote:
Originally Posted by brodood

It is possible to change the APN type without SQLite or root. The guys at my work figured this out. It is kind of a tricky workaround, but this is tested and working on LG Optimus G Pro, G Flex, and G2 with the MMS issues.

1. Go to the APN Settings and reset them to default. After that you should only see the AT&T APN
2. With the SIM card in the phone open Mobile Networks (get to the screen where you can click on Access Point names.)
3. DO NOT POWER OFF THE PHONE FOR THIS PART! On that screen and with the phone still on, slide the SIM out. You should get a prompt asking to reset the phone. DO NOT RESET THE PHONE.
4. After the prompt click on Access Point Names. There should be no APNs here. If the AT&T APN is still here go back to step 1.
5. Now you need to create a new APN whit the SIM is removed. The APN should be as follows:
Name: Straight Talk MMS
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: 66.209.11.33
mmsport: 80
mmsc: http: // mms-tf. net - This is spaced for Junior User restrictions. Should be no spaces.
authtype:none
type: mms
THE APN TYPE SHOULD ONLY BE FOR MMS. DO NOT PUT ANYTHING ELSE IN THE "TYPE" FIELD
6. Now with everything typed in DOUBLE CHECK EVERYTHING. If it is correct you can save this APN. Once it is saved there will still be no APNs on the APN page.
7. Pull the battery and put the SIM back in the phone.
8. Go back to the APN settings and DO NOT open the APN you just created or it will reset the entire process!!!!! If you did everything right the Straight Talk MMS APN you just made should not have the selection bubble. If you have a selection bubble on the Straight Talk MMS, go back to Step 1.
9. Make another new APN as Follows:
Name: Straight Talk
apn: tfdata
user: (blank)
server: (blank)
password: (blank)
proxy: (blank)
port: (blank)
mmsproxy: (blank)
mmsport: (blank)
mmsc: (blank)
Mcc: 310
Mnc : 410
type: default
10. Save this APN and select it. You should get LTE shortly after that.

That's it! If you want MMS without root this is the only other workaround I know of! This was tested on multiple Optimus G Pro, G Flex, and G2 and is working! Hope it Helps.

Very much appreciated. Took your guide & gave you credit. After all this is your work. I tweaked it for Airvoice Wireless & posted it at Hofo in the LG & Airvoice forums. Here are the modified instructions.

FIRST this is not my work. Props to brodood

http://forum.xda-developers.com/show...7&postcount=13
http://forum.xda-developers.com/show....php?t=2761126

I tweaked it for Airvoice. Original is for Tracphone.
On certain LG phones APN Type is grayed out so MMS is impossible through ordinary ways.

AGAIN the following is NOT my work. Neither is the origin story I just switched out the specific TF settings for the AV settings & order.

Airvoice LG MMS apn Type grayed out. Fix WITHOUT ROOT.

It is possible to change the APN type without SQLite or root. The guys at my work figured this out. It is kind of a tricky workaround, but this is tested and working on LG Optimus G Pro, G Flex, and G2 with the MMS issues.

1. Go to the APN Settings and reset them to default. After that you should only see the AT&T APN
2. With the SIM card in the phone open Mobile Networks (get to the screen where you can click on Access Point names.)
3. DO NOT POWER OFF THE PHONE FOR THIS PART! On that screen and with the phone still on, slide the SIM out. You should get a prompt asking to reset the phone. DO NOT RESET THE PHONE.
4. After the prompt click on Access Point Names. There should be no APNs here. If the AT&T APN is still here go back to step 1.
5. Now you need to create a new APN with the SIM is removed. The APN should be as follows:

Name: Mobile MMS
APN: att.mvno
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
MMSC: http://mmsc.cingular.com
MMS proxy: 66.209.11.33
MMS port: 80
MCC: 310
MNC: 410
If available, for the Authentication Type: PAP
APN Type: mms
authtype: none

THE APN TYPE SHOULD ONLY BE FOR MMS. DO NOT PUT ANYTHING ELSE IN THE "TYPE" FIELD
6. Now with everything typed in DOUBLE CHECK EVERYTHING. If it is correct you can save this APN. Once it is saved there will still be no APNs on the APN page.
7. Pull the battery and put the SIM back in the phone.
8. Go back to the APN settings and DO NOT open the APN you just created or it will reset the entire process!!!!! If you did everything right the Airvoice MMS APN you just made should not have the selection bubble. If you have a selection bubble on the Airvoice MMS, go back to
Step 1.

9. Make another new APN as Follows:

Name: Mobile Web
APN: att.mvno
Proxy: 66.209.11.33
Port: 80
Username: Not set
Password: Not set
MMSC: Not set
MMS proxy: Not set
MMS port: Not set
MCC: 310
MNC: 410
If available, for the Authentication Type: PAP
APN Type: default (or select INTERNET if available
authtype: none

10. Save this APN and select it. You should get Data & MMS now.


Me again. The above worked for Tracphone & I got it to work on Airvoice. So other AT&T MVNO's should or might work. I suggest using your specific MVNO's APN settings. Let me know if this works on T-Mobile & their MVNO's. Oh if you're thankful & appreciative go to the XDA link & give thanks, I did.
27th July 2016, 07:40 PM |#67  
Junior Member
Thanks Meter: 0
 
More
If you use a sqlite editor once you create the apn make this update query and it works alot easier UPDATE 'carriers' SET 'type' = 'default,mms' WHERE _id='your new apn id number' that way it doesnt keet turning your carrier enabled to a true or false.
On mine if i used supl it jacked my gps and i didnt have to delete any fields.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes