FORUMS
Remove All Ads from XDA

**How to activate full 3G coverage in US (t-mobile/att)

5,193 posts
Thanks Meter: 1,693
 
By avetny, Senior Member on 11th January 2014, 06:48 PM
Post Reply Email Thread
I got F340K (F340L also tested) unit from Korea. Which is supposed to work everywhere on 3G in US T-Mobile (and on AT&T I guess)
but I faced with problem when the phone almost everywhere stuck on 2G. The problem located not in APN settings. We just need to manually enable write bands

How to fix it:

1) Type in dialer: 5457#*340#
2) Click on: Band selection.
3) Mark on: LTE B1 (2100), LTE B3 (1800), LTE B8(900). Do not touch other marks.
4) Press: Save

Phone will reboot. Now you got full 3G coverage everywhere you go.
The Following User Says Thank You to avetny For This Useful Post: [ View ] Gift avetny Ad-Free
 
 
13th January 2014, 01:29 AM |#2  
barondebxl's Avatar
Senior Member
Flag San Diego, CA
Thanks Meter: 1,998
 
More
Awesome! This is good to know

Sent from my LG-D800 using Tapatalk
17th January 2014, 05:15 PM |#3  
Junior Member
Thanks Meter: 4
 
More
Hi guy's !!
What's the USSD code for D958 please..?
When i type : 5457#*958# the phone say "code USSD not valid" ???!!!!
Thanks
The Following User Says Thank You to Jaba04 For This Useful Post: [ View ] Gift Jaba04 Ad-Free
30th January 2014, 10:48 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Help--urgent with my LG G FLEX
Quote:
Originally Posted by avetny

I got F340K (F340L also tested) unit from Korea. Which is supposed to work everywhere on 3G in US T-Mobile (and on AT&T I guess)
but I faced with problem when the phone almost everywhere stuck on 2G. The problem located not in APN settings. We just need to manually enable write bands

How to fix it:

1) Type in dialer: 5457#*340#
2) Click on: Band selection.
3) Mark on: LTE B1 (2100), LTE B3 (1800), LTE B8(900). Do not touch other marks.
4) Press: Save

Phone will reboot. Now you got full 3G coverage everywhere you go.


I'm so sorry..I'm really new to this and I think I had the same problem as above when I purchased an unlocked LG G Flex phone from Hong KOng and try to use it on ATT when I return to U.S. and that the speed is really slow when I had my apn on HSPA+ with the following info

APN: phone
mssc: UNABLE TO SHOW
mms proxy: proxy.mobile.att.net
mms port: 80
mcc: 310
mnc: 410
apn type: default, supl,mms,hipri
apn protocol: ipv4

The question is what is a "dialer" and where I put it on the phone? Or other things I need to know to fix my problem please?

Thanks!

larry
11th November 2015, 06:59 AM |#5  
Junior Member
Thanks Meter: 0
 
More
What about g flex l23? Any solutions or codes ussd or mmi? I type that code and says invalid code.
11th November 2015, 07:28 AM |#6  
Murshad007's Avatar
Senior Member
Flag Lahore
Thanks Meter: 120
 
More
Quote:
Originally Posted by avetny

I got F340K (F340L also tested) unit from Korea. Which is supposed to work everywhere on 3G in US T-Mobile (and on AT&T I guess)
but I faced with problem when the phone almost everywhere stuck on 2G. The problem located not in APN settings. We just need to manually enable write bands

How to fix it:

1) Type in dialer: 5457#*340#
2) Click on: Band selection.
3) Mark on: LTE B1 (2100), LTE B3 (1800), LTE B8(900). Do not touch other marks.
4) Press: Save

Phone will reboot. Now you got full 3G coverage everywhere you go.

You can click on automatic and all bands will work..
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes