FORUMS
Remove All Ads from XDA

[APP][4.0+][v1.11 - 20150221] OpenConnect - SSL VPN client for Cisco AnyConnect

186 posts
Thanks Meter: 413
 
By cernekee, Senior Member on 18th January 2014, 10:15 PM
Post Reply Subscribe to Thread Email Thread
2nd September 2014, 07:12 PM |#51  
OP Senior Member
Thanks Meter: 413
 
More
Quote:
Originally Posted by Ray-Out

I found a problem with the current version:

Since commit 4d4c10 certificate files in the cache folder that get used by the lib are no more updated with the ones for the connection.

Seems path never gets changed as only srcPath is assigned.

Oops, looks like I forgot to return srcPath for the !isExecutable case (no temp file). Thanks for catching that.

I'll make a v1.02 with the fix.
The Following User Says Thank You to cernekee For This Useful Post: [ View ] Gift cernekee Ad-Free
 
 
2nd September 2014, 07:17 PM |#52  
Junior Member
Thanks Meter: 2
 
More
Wink
Quote:
Originally Posted by cernekee

Oops, looks like I forgot to return srcPath for the !isExecutable case (no temp file). Thanks for catching that.

I'll make a v1.02 with the fix.

Thanks, and sorry for being too lazy to send a patch
13th January 2015, 02:50 PM |#53  
Junior Member
Thanks Meter: 0
 
More
Is it possible to connect to a "default" connection upon launching?
3rd May 2015, 08:42 PM |#54  
Junior Member
Thanks Meter: 13
 
More
Hello
I connected to a Cisco ASA server with a P12 file certification. But I can't select user group, while I can chose it by AnyConnect app.
Need for help, Thank you.
12th October 2015, 07:09 AM |#55  
Junior Member
Thanks Meter: 2
 
More
When the mtu is less than 1280, the ipv6 should be disabled
Hi, thanks for this great app. But I got a problem regarding MTU setting:
Because the lame HUAWEI phone has an MTU of 1400 for both wireless and mobile data interface, the resulted MTU is 1269. And the app fallback to 1280, I think it's for the IPV6? In this case, I think the IPV6 should be disabled instead of fallback? I believe the recent version of ocserv is doing this. I also filed an issue on GitHub. Could you please have a look on this?

Thanks.
3rd November 2015, 09:30 PM |#56  
batvan's Avatar
Senior Member
Flag Toronto
Thanks Meter: 4
 
More
Split Tunelling
Hello

Can someone help me set up split tunelling? I want to be able to access my local home printer while on my work VPN .

I tried using both options and inputted my home subnet;

192.168.0.0/24

Doesn't seem to be working .
5th November 2015, 09:19 PM |#57  
Member
Thanks Meter: 3
 
More
The split tunnel is specified to include the ip address range you want Openconnect to route to on your Work VPN side. Any other ip address that is not in this range will be routed through your normal local network route. So, put your work VPN internal ip address range in that split tunnel range, then everything else will not be routed through VPN.

Lyre
The Following User Says Thank You to lyrelai For This Useful Post: [ View ] Gift lyrelai Ad-Free
6th November 2015, 08:49 AM |#58  
batvan's Avatar
Senior Member
Flag Toronto
Thanks Meter: 4
 
More
Thanks. I got it working using 10.0.0.0/8
13th November 2015, 12:19 AM |#59  
Junior Member
Thanks Meter: 1
 
More
seems like the TOTP token isn't working for me.

I set software token to TOTP and entered my token string and when i connect, it still asks me for my 2 step passcode. It isn't prefilled with anything

The log tab mentions

CALLBACK: onProcessAuthForm
AUTH: message 'somestringblahblah'
AUTH form result is 1

Running Android 6 if relevant, AOSP stock. Typing in the code manually succeeds with connection.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes