FORUMS

[Q] MHL 1080p output

21 posts
Thanks Meter: 8
 
By nOrbX187, Junior Member on 24th April 2014, 10:23 PM
Post Reply Subscribe to Thread Email Thread
3rd August 2015, 04:18 PM |#11  
Junior Member
Thanks Meter: 1
 
More
I know this is old, but is there an option to save the MHL-Setting in the Service menu permanently? After each reboot, the screen resolution is scaled to the default settings again.

Everybody who has problems with screen resolution can simply set the resolution and fps in the service menu under "second screen" .. For that type *#*#7378423#*#* in the phone dialer
 
 
26th November 2015, 09:41 AM |#12  
Senior Member
Thanks Meter: 39
 
More
For me its not even switching to 1080p when I select it in the service menu. It says reconnect but then again its set to 720p. Xperia Z and Z2 only outputing 720p. Are they even capable of 1080p MHL?

Is it possible the MHL cable is just crap?
Last edited by nurps; 26th November 2015 at 10:00 AM.
27th November 2015, 02:18 AM |#13  
Senior Member
Thanks Meter: 99
 
More
Quote:
Originally Posted by nurps

For me its not even switching to 1080p when I select it in the service menu. It says reconnect but then again its set to 720p. Xperia Z and Z2 only outputing 720p. Are they even capable of 1080p MHL?

Is it possible the MHL cable is just crap?

The Z Ultra has MHL 1.0 or most likely 2.0 since 2.0 requires 900mA and therefore an external power source is needed (which my cable has) while 1.0 only requires 500mA, which is provided through a regular USB/HDMI. Both 1.0 and 2.0 support uncompressed 1080p and Dolby 7.1. MHL 3.0 was released just a month before the Ultra hit the market, so it doesn't have 3.0, which supports 4K and some other stuff.

The Z2 and beyond have MHL 3.0, and yes, it could be your cable. Be sure that it's 3.0 for the Z2 and 1.0/2.0 for the Z.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes