Does the Samsung LAN/USB Hub ET-UP900 work?

31 posts
Thanks Meter: 3
By burningstep, Member on 19th May 2014, 02:55 PM
Post Reply Subscribe to Thread Email Thread
21st April 2015, 02:13 AM |#21  
Senior Member
Thanks Meter: 220
So anyone's managed to have this accessory charge the tablet as well as providing it with OTG capabilities at the same time?

For some weird reason my Linux Setup on framebuffer lags whenever I'm not charging the tablet at the same time, 'till now I was using bluetooth peripherals so tis was not a problem but I'm thinking of trying the tablet's OTG capabilities while on Linux, but that's out (at least for me) if I cannot manage to charge my tablet at the same time, the lag is unbearable (again, to me at least ...)
Yesterday, 03:57 AM |#22  
Junior Member
Thanks Meter: 0
What is ist exposed framework and the module hack connectivity
Originally Posted by atonal

Ok, guys.....i think, you mean the adapter for Note pro? I got it, and it works. .... first, i bought this, cause it was the only USB adapter, that charge and using usb at the same time with p600........... and then i try to get Ethernet work. ...... the thing is, you have to know some things about ip4 connections, this is a kind different to wifi connections. ...... but i can offer you good news, the adapter works. The thing is, the firmware of p600/605 isn't modified to say the apps, they can connect to Internet with ethernet. ..
With the Adapter, the connection works, if you look to your router, you will find your device in Lan network. ......
What you need, are two things. ..... first, the app "ethernet" from play store (need root), that gives your device the right ip address, subnet mask and the gateway. .... (you don't have to do anything, just start the app, and press "enable")...... and the second one ist xposed framework and the module "hack connectivity", this little tool will say all apps to listen also to Ethernet Routing, not only wifi....... for me, this ,works like a charm, if i come to office, i plug the adapter in, with a wireless keyboard usb plug, Lan connected and also a cable to charge my note 3........ than i just enable the ethernet app, and change keyboard to my own for external keys (external keyboard helper), and that's all, so i have Lan Internet (4 times faster than wifi), have connection to my pc, and a external keyboard and mouse. ..... that's perfect. ....
If I'm finished, i plug the adapter off, and disable ethernet app, it changes automatically to wifi. ........

For generally information : Android already have ethernet drivers enabled from source, also in Samsung firmware, eth0 is working, the thing is, the apps are just programmed to listen to Wifi only. ....... don't know why, cause it's just one simple parser line to get this working.....
OK, on a mobile, it's not so interesting to havea Lan connection, but on a tablet, this will really good and fast. ....
Try this and habe fun. ... but i don't understand, why Samsung have the pins of the 10.1 204 so stupid organized, that all docking stations and usb adapters don't work with charging and usb at same time. .... the note 3 Multimedia Dock will not be detected as a dock. ....... that's so stupid. ....... shame on Samsung. ... if this was my company, i will fire the engineers at the same day if they make such a ****..........

Gesendet von meinem SM-P600 mit Tapatalk

Hey buddy im new to this stuff, clarify as to how you would get ist exposed framework and the module hack connectivity.
Yesterday, 07:58 AM |#23  
atonal's Avatar
Senior Member
Thanks Meter: 107
Hey Guys, you have to be carefully.......the adapter works only with the Wifi Version of the Note 10.1 2014. (P600). On the P605, that have a complete different hardware.....(Exynos Chipset). On the P605 (LTE), it doesn`t work anyway.......It seems , that different chipsets have different configurations on the usb port. Meanwhile, i get a Tab S2 SM-T 815 (Amazing device, by the way), there works all adapters with charge, ethernet and usb at the same time.......also the ET-UP900.......

By the way, i also bought the Lavalink Adapter from Netherlands. They promise, that it works on "Glaxy Note 10.1 2014", but thats not true. I`m sure it works on the P600 , but on the P605, i test it, and there it doesn`t work .......

Gesendet von meinem SM-T815 mit Tapatalk
Last edited by atonal; Today at 07:01 AM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes