FORUMS
Remove All Ads from XDA

[Q] Straight Talk (ATT sim) APN for HTC ONE M8

78 posts
Thanks Meter: 9
 
By cheno1115, Member on 5th April 2014, 07:37 PM
Post Reply Email Thread
12th June 2014, 05:39 AM |#31  
OP Member
Flag Eau Claire, WI
Thanks Meter: 9
 
More
Quote:
Originally Posted by mnotestone

Are you still having this issue? If so I had the same issue, I have at&t and I am using straight talk as my cairrer . I tried every APN that was out there and could not get it to work. So I decided to root my device. I rooted it and stock root would still not allow me to receive picture message with straight talks APN. Then I installed venoms viper one Rom and went to straight talks website got the same APN I had been using and entered it into my phone. Restarted my phone and tried to send myself a photo and it sent and I received it. That's what I did and not only is viper one Rom sweet my mms is working properly!!!! Hope this helps

Yeah, Viper is the rom I am using too at the moment. I love it. But... I had MMS working on the stock rom too after 4 days of activating my service too, so I'm not exactly sure if using a custom rom has much to do with it.
 
 
12th June 2014, 05:44 AM |#32  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by cheno1115

Yeah, Viper is the rom I am using too at the moment. I love it. But... I had MMS working on the stock rom too after 4 days of activating my service too, so I'm not exactly sure if using a custom rom has much to do with it.

I'm was still in the middle of my activation so it didn't 're up. I just noticed when I was rooted that I could receive mms. And when I wasn't I could not receive mms .
16th June 2014, 06:07 PM |#33  
Junior Member
Flag Rochester NY
Thanks Meter: 0
 
More
I gave in and just rooted and installed Viper ROM, it started working instantly.
28th August 2014, 09:43 PM |#34  
Junior Member
Thanks Meter: 1
 
More
To confirm after 5 months of waiting update 4.4.3 had resolved my mms issue

Sent from my HTC One_M8 using XDA Free mobile app
30th January 2015, 06:08 AM |#35  
Junior Member
Thanks Meter: 0
 
More
Thank You
Quote:
Originally Posted by Oneluckybullet

Use these settings. If you can't do the APN type and authentication you will need to root. From what I understand att and other carriers slipped in a coding with kit Kat to block mms on phones not on carrier contract. I'm rooted running Viper, but when I was running factory I used these and no problems.

Sent from my HTC One_M8 using XDA Premium 4 mobile app


I have tried fixing this for a while tonight, i guess i missed the APN type setting but just adding the default,supl,mms,hipri,tfda fixed it.
2nd December 2015, 09:10 PM |#36  
Junior Member
Thanks Meter: 0
 
More
i saw this one a forum but its for htc one m7 bit it worked for me
Phone: Verizon HTC One (HTC6500LVW)
Android version: 4.4.3
HTC Sense version: 6.0
Current SIM card and wireless provider: FYVE (online-only partner of Vodafone in Germany)

When I navigate to Settings > Wireless & Networks > Mobile Data (Network Settings) > GSM/UMTS Options > Access Point Names, I was originally just shown ONE access point. The three-dot menu option in the top right, which was allegedly supposed to allow me to add a new APN, contained only the option "Reset to default". Selecting this option would delete the only APN on the list with no option to add it back.

However, I found that navigating to Settings > Wireless & Networks > Mobile Data (Network Settings) > Preferred Network and switching from "GSM / UMTS" to "LTE / CDMA" and back again restores the single APN that you just removed.

Now, this single APN doesn't seem particularly useful. Selecting it brings up a whole bunch of fields (Name, Proxy, Port, Username, Password, Server, etc) that are all greyed out and uneditable. The only editable field is "APN", which I changed to "web.vodafone.de" (minus the quotes, of course -- this was given to me by my provider and should be available online for your provider as well).

However, this did NOT fix it.

What DID work, oddly enough, is switching BACK to LTE / CDMA mode and also changing the APN for this mode (in Settings > Wireless & Networks > Mobile Data (Network Settings) > LTE / CDMA Options > Access Point Names) to "web.vodafone.de". Then I switched BACK to GSM / UMTS mode...and it miraculously worked! I now have HSDPA connectivity.

I can't begin to explain why this worked. My hunch is that maybe the GSM / UMTS settings aren't writing anything to the APN field, but the LTE / CDMA settings are (since Verizon built the phone for its own LTE / CDMA network, it doesn't surprise me that this is the working part of their phone). But I am not a developer.

Maybe this will work for you, maybe not. It's obviously a poor implementation on either Verizon or HTC's part. Your mileage may vary. Good luck.
Post Reply Subscribe to Thread

Tags
apn, htc, htc one (m8), straight talk, straight talk apn

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes