FORUMS

[Help Thread] Google play errors Explained (with fixes) [Updated 23 Aug 2014]

1,087 posts
Thanks Meter: 615
 
Post Reply Subscribe to Thread Email Thread
25th October 2015, 07:59 PM |#131  
TXJim's Avatar
Junior Member
Flag San Antonio
Thanks Meter: 3
 
More
error code -505?
I'm unable to update one app, Layers Manager, and can't find a fix anywhere. (other aps install/update fine).
I've already tried clearing the Play store data & cache, and also manually installed the latest version of the Play Store apk. If anyone has any other suggestions I'd really appreciate it.
Nexus 9 running Pure Nexus Project 5.1.1, if that matters.
 
 
28th October 2015, 05:26 PM |#132  
TXJim's Avatar
Junior Member
Flag San Antonio
Thanks Meter: 3
 
More
anyone?
Anyone ever get a 505 error?
6th November 2015, 01:54 PM |#133  
Primokorn's Avatar
XDA: ASSIST
Recognized Contributor / Themer
Thanks Meter: 5,155
 
Donate to Me
More
I wasn't able to update my apps due to the error 920.
This can be caused by a Google Play Services update underway. Simply wait the end of this update then update your apps.
11th November 2015, 05:03 PM |#134  
mbirth's Avatar
Senior Member
Flag Berlin
Thanks Meter: 113
 
More
Quote:
Originally Posted by AUserCAAP

I would like to add my case. I had the message unknown error -504. Tried all the above methods about clearing cache and data but nothing seems to fix it; in my case I had link2sd which seems to be involved or in the problem and the solution. To fix this I had to clear the dalvik cache with the link2sd menu tools, after doing that the apps install seems to work again. Note that this error let me download the app but it was failing at the moment of installing. Confirming final result = apps install without error.

According to a comment here, the error ID -504 is INSTALL_FAILED_UID_CHANGED. And this points to some mixed up permissions on the app's files.
25th November 2015, 12:08 PM |#135  
mohamedrashad's Avatar
OP Senior Member
Flag ismailia
Thanks Meter: 615
 
More
Quote:
Originally Posted by mbirth

According to a comment here, the error ID -504 is INSTALL_FAILED_UID_CHANGED. And this points to some mixed up permissions on the app's files.

I'm updating the thread after my midterms with your solutions + more, wait for me & thanks for keeping it alive
10th December 2015, 10:59 AM |#136  
nd25's Avatar
Junior Member
Trogir
Thanks Meter: 9
 
More
[B] Unknown error code during application installation "-504"

Galaxy s4 i9505 lollipop 5.01
Went through all of this pages and read tons of pages, without success...

My intention was to find solution, without flashing rom again, it is really annoying to set up all
of your app settings again...

So I did dirty flash over previous rom to keep all of my data and settings,
No success, same error again, so I did next step:

Well I know that something is wrong with system, so I done next:
1. In recovery mode (Phil'z), I delete cache, dalvik cache and formatted system
2. Flashed rom without deleting data

Again: Unknown error code during application installation "-504"

So I did clean install, now everithing is OK.
Only thing that I didn't try is try dirty flash with deleted google account.

Sometimes seams only solution is to do factory reset and flash rom again
10th December 2015, 05:13 PM |#137  
tjbb80's Avatar
Junior Member
Thanks Meter: 1
 
More
What worked for me was to go to /data/data and delete the offending app. In my case it was google play music and imdb. HOWEVER that was not enough. Also had to go to /data/dalvik-cache/*several subs* and look for the related odx files and delete them. I think those had gotten left behind by apps2sd, or link2sd. Once I deledted thos odx files I was good to go. I had been getting error 504. I previously had other apps I couldn't install, with error code 506, and deleting the folders from /data/data was enough to fix those, they must not have had the dalvik-cache file issue for those particular apps. Of course, yo need to be rooted to do this. But you needed to be rooted in order to use apps2sd in the first place, which is what I think caused the problem.
10th January 2016, 03:30 AM |#138  
dbareis's Avatar
Senior Member
Thanks Meter: 12
 
Donate to Me
More
On two apps out of hundreds on my Nexus 6P (Android 6.01 and 6.0) I get a "-504" (not "504"), any ideas?

I've tried clearing play caches and rebooting, disabling (reverting updates) to Google pay and rebooting and numerous other things.
22nd January 2016, 01:55 PM |#139  
Senior Member
Flag Paris
Thanks Meter: 42
 
More
Hello,
I write from France and sorry for my bad english.
I have read the 14 pages but not found my error -18.
Explanations:
My wife plays with "My talking angela" for a long time and has paid also to obtain 2 x pieces on games.
But the last update don't update and she is furious because she likes to play with this game.
When the update start, it is a bit long (76 Mo to upload) and after the installation begins, the error "Instalaltion failed, error -18" appears.
Configuration in use:
Samsung galaxy Tab 4 with 8 Go RAM and 8 Go SD Card.
Android 4.4.2
RAM free 2.4 Go
SD Card free 5.1 Go
I install this game on my Nexus 5 and with "Save and Restore" I get an APK that I transfer by Bluetooth to the Galaxy Tab.
I install manually the APK (76.67 Mo) but same error, so I think it is not an error from Google Play, but I am not an expert.
What do you think about that ?
I don't know what to do to update this soft...
I have write to the developer but answer is that it is Google Play error. But direct install fails also...
Can you help me (and my wife ) ?
Thks
EDIT : I have of course uninstall this soft before all my tests and all other softs and games update correctly in Play Store.

EDIT 2 : I have found the answer (Thks to Titi66200 ) :
If the file "smdl2tmp1.asec" exists in directory "/.android_secure/" delete it and retry install or update.
If all works stop here otherwise :
If this file don't exists unmount SD Card, install or update soft and remount SD Card.
This second option works for me because I don't find the file "smdl2tmp1.asec"
Last edited by db77; 24th January 2016 at 09:57 AM. Reason: What to do
The Following 2 Users Say Thank You to db77 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes