FORUMS

Tutorial: Fix Xperia C softbrick with red led and no Sony logo

3,286 posts
Thanks Meter: 2,403
 
By GethPrime, Recognized Contributor on 1st February 2014, 12:40 AM
Post Reply Subscribe to Thread Email Thread
4th September 2015, 01:49 PM |#41  
Junior Member
Thanks Meter: 0
 
More
Unhappy
my sony xperia c 2305 is not turning on after cwm recovery please help me
 
 
27th October 2015, 08:46 AM |#42  
Junior Member
Thanks Meter: 0
 
More
I was installing the custom rom on my sony xperia c and it get bricked
I was installing the custom rom on my sony xperia c2305 via cwm recovery with a zip file,and this was the second time I was installing the rom and I bricked my phone. When I connect it to my pc only red light lits and my pc does not recognise it.
And I have tried everything sony pc companion, flash tool and odin everything but just only lits the red led .Please can anyone help me,I just only want to know how to lit the green light on my and then I know everything what to do.And one more thing I have also tried holding the volume + button plus the power button and everything.
27th October 2015, 06:18 PM |#43  
iSiddharth's Avatar
Senior Member
Flag Indore
Thanks Meter: 638
 
Donate to Me
More
Quote:
Originally Posted by Nazeerullahusen

my sony xperia c 2305 is not turning on after cwm recovery please help me

Quote:
Originally Posted by lakshay the brainaic

I was installing the custom rom on my sony xperia c2305 via cwm recovery with a zip file,and this was the second time I was installing the rom and I bricked my phone. When I connect it to my pc only red light lits and my pc does not recognise it.
And I have tried everything sony pc companion, flash tool and odin everything but just only lits the red led .Please can anyone help me,I just only want to know how to lit the green light on my and then I know everything what to do.And one more thing I have also tried holding the volume + button plus the power button and everything.

Visit this thread, this will help you
http://forum.xda-developers.com/show...1&postcount=13
The Following User Says Thank You to iSiddharth For This Useful Post: [ View ]
9th December 2015, 02:32 PM |#44  
Junior Member
Thanks Meter: 0
 
More
i'm also facing this problem.
Tried everything and just red led that's all.
Can I repair it at service station?
9th December 2015, 02:56 PM |#45  
Senior Member
Flag Kuching
Thanks Meter: 221
 
More
Quote:
Originally Posted by Bhagirath13

i'm also facing this problem.
Tried everything and just red led that's all.
Can I repair it at service station?

Did you try the link up there? ^
14th December 2015, 05:20 PM |#46  
Junior Member
Thanks Meter: 0
 
More
helo frnds,,
mmy xperia c is not getting on jusst stucking in sony symbol, please help
8th February 2016, 06:49 PM |#47  
Junior Member
Thanks Meter: 0
 
More
faced same issue today..........tried many things........and after 3-4 hours came to green light , but still pc is still not showing any connection of smartphone to it.
Then tried the same with other USB wire........and Hell Yeah!!!!!!!!!!! i got it in one try...............

Use Power + Volume Up and then connect USB to mobile to access "Red " light and after some time say 20-30 sec "Green" light will appear.

for further pm me...........always happy to help
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes