FORUMS
Remove All Ads from XDA

Tutorial: Fix Xperia C softbrick with red led and no Sony logo

3,303 posts
Thanks Meter: 2,415
 
By GethPrime, Recognized Contributor on 31st January 2014, 11:40 PM
Post Reply Subscribe to Thread Email Thread
4th September 2015, 12:49 PM |#41  
Junior Member
Thanks Meter: 0
 
More
Unhappy
my sony xperia c 2305 is not turning on after cwm recovery please help me
 
 
27th October 2015, 07:46 AM |#42  
Junior Member
Thanks Meter: 0
 
More
I was installing the custom rom on my sony xperia c and it get bricked
I was installing the custom rom on my sony xperia c2305 via cwm recovery with a zip file,and this was the second time I was installing the rom and I bricked my phone. When I connect it to my pc only red light lits and my pc does not recognise it.
And I have tried everything sony pc companion, flash tool and odin everything but just only lits the red led .Please can anyone help me,I just only want to know how to lit the green light on my and then I know everything what to do.And one more thing I have also tried holding the volume + button plus the power button and everything.
27th October 2015, 05:18 PM |#43  
iSiddharth's Avatar
Senior Member
Flag Indore
Thanks Meter: 650
 
Donate to Me
More
Quote:
Originally Posted by Nazeerullahusen

my sony xperia c 2305 is not turning on after cwm recovery please help me

Quote:
Originally Posted by lakshay the brainaic

I was installing the custom rom on my sony xperia c2305 via cwm recovery with a zip file,and this was the second time I was installing the rom and I bricked my phone. When I connect it to my pc only red light lits and my pc does not recognise it.
And I have tried everything sony pc companion, flash tool and odin everything but just only lits the red led .Please can anyone help me,I just only want to know how to lit the green light on my and then I know everything what to do.And one more thing I have also tried holding the volume + button plus the power button and everything.

Visit this thread, this will help you
http://forum.xda-developers.com/show...1&postcount=13
The Following User Says Thank You to iSiddharth For This Useful Post: [ View ] Gift iSiddharth Ad-Free
9th December 2015, 01:32 PM |#44  
Junior Member
Thanks Meter: 0
 
More
i'm also facing this problem.
Tried everything and just red led that's all.
Can I repair it at service station?
9th December 2015, 01:56 PM |#45  
AutumQueen92's Avatar
Senior Member
Flag Kuching
Thanks Meter: 291
 
More
Quote:
Originally Posted by Bhagirath13

i'm also facing this problem.
Tried everything and just red led that's all.
Can I repair it at service station?

Did you try the link up there? ^
14th December 2015, 04:20 PM |#46  
Junior Member
Thanks Meter: 0
 
More
helo frnds,,
mmy xperia c is not getting on jusst stucking in sony symbol, please help
8th February 2016, 05:49 PM |#47  
Junior Member
Thanks Meter: 0
 
More
faced same issue today..........tried many things........and after 3-4 hours came to green light , but still pc is still not showing any connection of smartphone to it.
Then tried the same with other USB wire........and Hell Yeah!!!!!!!!!!! i got it in one try...............

Use Power + Volume Up and then connect USB to mobile to access "Red " light and after some time say 20-30 sec "Green" light will appear.

for further pm me...........always happy to help
27th February 2016, 08:54 AM |#48  
Junior Member
Thanks Meter: 5
 
More
Bricked Xperia C2305 connects & disconnects
Quote:
Originally Posted by zergmac023

Im in the same scenario.. I tried all the procedures here but i failed.. I noticed that when i connect it, it disconnects after a while along with blinking of led light then reconnect again. And my PC detects it as unknown device.. I tried to install ADB driver but it also fails. Please help me.. Thanks. Sorry about my English

Exactly same happens with me. Neither Sony PC companion nor WMSHUA is able to carry on with driver installation. I have tried all different key combinations but all failed. It gets detected, WMSHUA starts installing drivers but after approx 10 seconds red light blinks and it gets disconnected and within a second gets connected again. However, driver installation does not proceed.

I have been searching for it's solution but have found NONE.

PLEASE someone help.
19th April 2016, 01:35 PM |#49  
Junior Member
Thanks Meter: 0
 
More
xperia c bricked with red led
hello everybody m using xperia c... just giving instructions to solve xperia c bricked issue your fone dead becz you may doing custom recovery or any other customized thing so first u install sony pc companion to pc then follow steps first connect usb cable at the same time u do one thing press volume down key same time when u plug in usb cable then green light blinked then do further steps it have guide info at top it requried wifi connection for 3rd step (updation) LAN probably have less speed so it might be failed occurs during updating process so after update then finish last step on it then unplug usb nd press power key button its surely turn on...all the best !!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes