FORUMS
Remove All Ads from XDA

FlashTool loader.sin error

105 posts
Thanks Meter: 16
 
By notes1, Senior Member on 23rd April 2014, 01:31 PM
Post Reply Email Thread
Flashtool recognises my device and will chat to it via ADB, and sees it in both flashmode and fastboot, but every time I try to flash either a full ftf or a kernel.sin I get the error message:
Quote:

24/026/2014 00:26:09 - INFO - Checking header
24/026/2014 00:26:09 - ERROR - Processing of loader.sin finished with errors.
24/026/2014 00:26:09 - INFO - Ending flash session
24/026/2014 00:26:09 - ERROR - S1 Header checksum Error
24/026/2014 00:26:09 - ERROR - Error flashing. Aborted

I have an unlocked bootloader, I've updated my drivers and the phone works and is rooted. I have NOT got CWM.

Phone is stuck on .96 ROM (my stock) but .211 stock kernel.

I've read dozens of threads, sorry if it's something simple I've missed. To make matters more difficult I'm working off a linux laptop with no access to Windows, so I've had to translate commands etc to try flash through a terminal rather than through flashtool.

Cheers.
 
 
1st July 2014, 03:57 AM |#2  
evilc1's Avatar
Senior Member
Flag somewhere in this world
Thanks Meter: 9
 
More
Hi, Did you find out how to fix it? I am now getting the same problem. I am using the latest flashtool-0.9.16.1 and trying to install C6903_14.3.A.0.757_Generic AU_1277-0078.ftf on my xperia z1.
4th July 2014, 01:20 AM |#3  
DiDA™'s Avatar
Senior Member
Thanks Meter: 35
 
More
Try using another .ftf file and install ALL/MOST of the drivers in the Fastboot > Drivers. It now says flasing on my SP but it might be the same for other too hopefully.
6th July 2014, 01:26 AM |#4  
notes1's Avatar
OP Senior Member
Flag Auckland
Thanks Meter: 16
 
More
I can't remember exactly what step fixed this, but I basically did everything again.

I downloaded the flashtool drivers and ftf's / kernels again, and tried different methods; both using full ftf's and kernel only .sin's, and tried to install a recovery alone and using both fastboot and flashmode.

Eventually something worked. Also, at one point my phone said it wasn't rooted but it was. Dunno if that part of the problem or just a symptom.

I'll update if I remember anything more useful.
7th July 2014, 03:45 PM |#5  
Junior Member
Thanks Meter: 2
 
More
I had the same problem. My fault was, that i started the flashmode on the phone and opend than the ftf file on my pc and started to flash.

But it works if i open the ftf file and hit the flash button and follow the instructions to start the phone in flashmode.
The Following 2 Users Say Thank You to Tobi.777 For This Useful Post: [ View ] Gift Tobi.777 Ad-Free
27th November 2014, 07:23 PM |#6  
Junior Member
Thanks Meter: 0
 
More
thank you very much
Quote:
Originally Posted by Tobi.777

I had the same problem. My fault was, that i started the flashmode on the phone and opend than the ftf file on my pc and started to flash.

But it works if i open the ftf file and hit the flash button and follow the instructions to start the phone in flashmode.

Thank you all for your help finally it worked
13th September 2015, 11:12 PM |#7  
Junior Member
Thanks Meter: 1
 
More
Strange indeed, setting the Acro S in Flashmode prior to starting the flashing via Flashtool gives me this error.
Setting the Acro S in Flashmode when promted by Flashtool to do so, allows me to flash anything...
The Following User Says Thank You to Franz_TNT For This Useful Post: [ View ] Gift Franz_TNT Ad-Free
25th December 2015, 07:21 PM |#8  
gemer45a's Avatar
Senior Member
Flag XDA-CITY
Thanks Meter: 250
 
More
I got an xperia arc s from someone with mcafee security lock on it. I can't get into the phone and I'm not able to perform a hard reset as the key combination isn't working so the only option I think I have now is to flash the phone but I'm getting this "loader.sin" error whether I set the device in flashmode or I'm prompted by the flashtool. I've already tried 2 firmware files, does anyone know a way I can fix this device?

EDIT: I downloaded a different firmware and an earlier version of the flashtool and it worked
14th February 2016, 09:17 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by gemer45a

I got an xperia arc s from someone with mcafee security lock on it. I can't get into the phone and I'm not able to perform a hard reset as the key combination isn't working so the only option I think I have now is to flash the phone but I'm getting this "loader.sin" error whether I set the device in flashmode or I'm prompted by the flashtool. I've already tried 2 firmware files, does anyone know a way I can fix this device?

EDIT: I downloaded a different firmware and an earlier version of the flashtool and it worked

Which firmware and version of flashtool did you use? I'm trying to flash ICS on my Xperia Arc and so far it doesn't work. Though I still can restart the phone normally.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes