FORUMS
Remove All Ads from XDA

[Q] Linux Deploy Installation Problem?

37 posts
Thanks Meter: 0
 
Post Reply Email Thread
10th February 2016, 02:23 AM |#11  
Junior Member
Thanks Meter: 0
 
More
(Sorry for the late reply) Although I did not post it, I was able to get it working on that same day. I continued to Google around for solutions and found a discussion that said to do what you have stated. Thank you for replying Shubham Singla ☺ Hope CodemasterRob was able to fix his problem too.
 
 
17th March 2016, 05:31 PM |#12  
Junior Member
Thanks Meter: 0
 
More
linux deply -installion problem
When I tried to install debian-lxde with linux deploy, the first command is returned back :
08:26:22 Update configuration file ..... done
08:26:23 >>> install
08:26:23 <<<< install
Can anybody suggest a way out to overcome this problem ? linux deploy version 1.5.6.191 was use.d.
naga
14th May 2016, 06:23 PM |#13  
Junior Member
Thanks Meter: 0
 
More
thanks very much that's solve my PROBLEM !!!!! tks again!
Quote:
Originally Posted by Shubham Singla

i too had same problem. Solved it via uninstalling previous busybox and installing busybox from https: //github.com/meefik/busybox/releases (Please delete space b/w https: and //)

then changing busybox directory in linuxdeplot-->seetings-->busybox directory to "/data/data/ru.meefik.busybox/files/bin "

then settings--> update env



thanks very much that's solve my PROBLEM !!!!! tks again!
19th May 2016, 07:03 PM |#14  
Junior Member
Thanks Meter: 0
 
More
Please help me guys!
Quote:
Originally Posted by thska

thanks very much that's solve my PROBLEM !!!!! tks again!

its great to hear that your problem has been solved.

could you kindly explain to me about this "then changing busybox directory in linuxdeplot-->seetings-->busybox directory to "/data/data/ru.meefik.busybox/files/bin"

maybe with a some pictures. Thank you
2nd July 2016, 05:33 AM |#15  
Junior Member
Thanks Meter: 3
 
More
busy box installation path
Hi u said to change the busy box directory to data/data.....on linux deploy,but in busy box setting the installation path is set to "system/xbin". Will this creat problem?? Because i saw that there r many files in xbin compared to ru.meefik.busybox/files/bin. Plz reply
2nd July 2016, 08:27 PM |#16  
Junior Member
Flag anantapur
Thanks Meter: 0
 
More
deploy linux on moto e
I have moto e xt1022 running cm13 rom
I have formatted my 16gb external sdcard to use as internal storage. Can i use linux deploy. Ie i dont have enough storage in device storage.
Is there any way to use chroot environment on external sd card and install kali linux using deploy linux?.
2nd July 2016, 09:39 PM |#17  
Junior Member
Thanks Meter: 3
 
More
Hi guys, I have a great solution for installing kali linux though linux deploy via usb otg.
1. No need to use internal storage. 2. No need to use unnecessary space in extsdcard. 3. Its easy
Prerequisites: usb otg, sd card( 16 gig/32 gig better n class 10 for read and write speed) and card reader to connect it via otg.
STEPS :
1. Install linux deploy,terminal emulator n meefik busybox,vnc viewer from google play store.
2. Start linux deploy n check status,points to be view
-loop devise: yes, SELinux -yes, supported FS-ext2/3/4, vfat,exfat etc
3. Now creat partition on ur sd card by aparted app from store or by mini partition tool wizard in pc. 2nd partition should be > 10gigs or atlst 8 gig, type ext2/4
4. Now connect the sd card via otg.
5. Open linux deploy n check status, at the last of it u should see -"dev/block/sda1 and dev/block/sda2 _mb (linux). This sda2 is ur 2nd partition and u have to install it here.
6. Now open properties in deploy select distribution -kali, Architecture - armhf, Distribution suite -sana, Installation type - partition, Installation path - string from status(dev/block/sda2 ,mine sda6). Additional component -NEVER CHOOSE KALI COMPONENTS,but select othrs. Change gui graphics according to ur phn,dextop env ect.
7. Now go to settings in deploy n change the busy box directory to "/data/data/ru.meefik.busybox/files/bin". But there is a trick, open terminal emulator and type -" ln -s /system/bin/mksh sh" and then "ln -s /system/xbin/busyboxchroot". Done.
8. Now in deploy go to settings and update ENV.
9. Now ur are all set, hit install n wait. With good internet speed it will take minimum. 30-45min, atlast u will see "<<<install".
10. Now hit start on deploy it show u various thing with " new local host desktop 'x'....log local host 0". Its mean u r ready to connect vnc server.
11. If u now check status it will show that "Mounted system - kali linus 2.0 sana", or if u open terminal from linux deploy it will show " root@localhost#~".
12. But u r not done yet. In terminal emulator type - "sudo apt-get update" it will take few min to update. Thn u have to install kali linux full if u want to use pretty tools of kali. U hv to install meta packages.
Now type "apt-get install kali-linux-full". It will show various warning do y to all n wait. Its a huge file. U can choose " kali-linux-all" or othr meta packages according to ur need.
HOPE THIS WILL HELP.
N.B - I face some prob during downloading ,such as it showed "can't retrieve package redline or inssev/etc". It is the prob of mirror server. Stop the process n go to settings n remove the ENV and disconnect the otg. Connect it again and the update ENV and start again. Don't loose patience. ALL THE BEST
2nd October 2016, 12:20 PM |#18  
Junior Member
Thanks Meter: 0
 
More
Still not working!
Post Reply Subscribe to Thread

Tags
install, linux, linux deploy, nexus 5, storage

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes