FORUMS

XeroAsh Theme for CM12

This theme by XDA Senior Member balrajs99 features a black and slate gray UI that gives your phone a … more

Samsung Galaxy S6 To Receive Major Camera Update

When the Samsung Galaxy S6 and S6 Edge were launched, they became the prime focus for … more

Tactile: An Addicting Game with Beautiful Material Design

The game industry has been around for decades, catering to a wide … more

Android’s Consistency and The User Experience

This is a site of power users, and it is fair to say that most of us are more … more
Post Reply Subscribe to Thread Email Thread

Blocks LWP (V1.0) RC1

20th October 2010, 02:05 AM |#1  
jug6ernaut's Avatar
OP Retired Moderator / Recognized Developer
Flag San Antonio, Tx
Thanks Meter: 473
 
More
Blocks Live Wallpaper has gone RC1! There is now a free and paid version, i hope i split the features up enough to keep everyone happy .

Here is my list of what i am working on adding in the future, tho not in this order.
Code:
To-Do List
:Fix Any Current Errors
:Support all Screen Resolutions [Done as of V0.7.50]
:Save game state on screen of, load save state on screen on
:Better debug system
:Custom AI values
:Level Progression
:Custom text output, lines, fps ect
Change Log
Code:
1.0    - ALOT of stuff, just check it out ;)
.8.01 - Settings will now stick over a soft reset, default speed set to 100;
.8.00 - Fixed endless "Loading Wallpaper" bug;
.7.50 - All Resolutions supported, bug fixes;


Please note this is a BETA, any and all advice is greatly appreciated

Previous downloads: 1327dls

You may continue to download from here but if you wish you may download it from the Marketplace also for active updates.
MarketPlace Link Free: Free
MarketPlace Link Pro: Pro

If you like the app please support it by clicking on a few ads in the setting screen
Attached Thumbnails
Click image for larger version

Name:	snap20101023_073616.png
Views:	3785
Size:	16.5 KB
ID:	425603   Click image for larger version

Name:	snap20101023_073557.jpg
Views:	3717
Size:	47.0 KB
ID:	425604   Click image for larger version

Name:	details-id=jug6ernaut.lwp.tetris.png
Views:	494
Size:	389 Bytes
ID:	428299   Click image for larger version

Name:	device7.png
Views:	5883
Size:	41.7 KB
ID:	466115   Click image for larger version

Name:	snap20101102_103236.jpg
Views:	5861
Size:	88.6 KB
ID:	466116  
Last edited by jug6ernaut; 7th August 2013 at 02:22 PM.
The Following User Says Thank You to jug6ernaut For This Useful Post: [ View ]
 
 
20th October 2010, 03:47 PM |#2  
matthewjulian's Avatar
Senior Member
Flag Arlington
Thanks Meter: 1
 
More
Downloaded, going to test later and report back
20th October 2010, 03:53 PM |#3  
egzthunder1's Avatar
Moderator Committee Lead / Member Advocate Admin - Spirit of XDA
Flag At The Good End Of My Hammer, Likes: My Family & XDA, Dislikes: Incompetence
Thanks Meter: 6,185
 
More
Quote:
Originally Posted by jug6ernaut

I am using this thread as a Public Beta for my program Tetris LiveWallpaper.

Anyone can use this software, thought it is meant for WVGA phones, i can not attest to how it will work on any other res phone. My only plea is that if you download my software that you leave a small comment in this thread with your thoughts, problem you might have, stuff you would like to see, ect.

I reserve the right to sell in the future. Right now i plan to ether make it adware or have a free and pay for versions. Though this is not set in stone.

Here is my list of what i am working on adding in the future, tho not in this order.
*Will add soon*

Please not this is a BETA,

to set this lwp go to where you set wallpapers, select live wallpapers, then select Tetris LWP, there you can also change any settings as you need.

Hey jug,

Nice one. I will test it in my EVO. Care to post a few screenies so that I can make an article about it?
20th October 2010, 04:53 PM |#4  
hoovnick's Avatar
Senior Member
Thanks Meter: 62
 
More
Downloaded and installed just fine. Just hangs on "Loading wallpaper" when I choose it. Doesn't freeze or anything, just sits there like its loading, but never loads.

Oh, using an Eris running KaosFroyo v37.
20th October 2010, 05:03 PM |#5  
jug6ernaut's Avatar
OP Retired Moderator / Recognized Developer
Flag San Antonio, Tx
Thanks Meter: 473
 
More
Quote:
Originally Posted by egzthunder1

Hey jug,

Nice one. I will test it in my EVO. Care to post a few screenies so that I can make an article about it?

Sure i will do that later when i when i have time . Though you might want to wait till i get around to releasing V1.0, of course that is your choice though.

Quote:
Originally Posted by hoovnick

Downloaded and installed just fine. Just hangs on "Loading wallpaper" when I choose it. Doesn't freeze or anything, just sits there like its loading, but never loads.

Oh, using an Eris running KaosFroyo v37.

Yes does do that, im pretty sure i know why also. But after applied it should work fine. Is it not for you?
Last edited by jug6ernaut; 20th October 2010 at 05:05 PM.
20th October 2010, 05:09 PM |#6  
hoovnick's Avatar
Senior Member
Thanks Meter: 62
 
More
Quote:
Originally Posted by jug6ernaut

Yes does do that, im pretty sure i know why also. But after applied it should work fine. Is it not for you?

Nope, I let it go into standby while waiting for it to apply. Then I told it to set wallpaper anyway, just goes back to my current wallpaper.
20th October 2010, 05:28 PM |#7  
jug6ernaut's Avatar
OP Retired Moderator / Recognized Developer
Flag San Antonio, Tx
Thanks Meter: 473
 
More
Quote:
Originally Posted by hoovnick

Nope, I let it go into standby while waiting for it to apply. Then I told it to set wallpaper anyway, just goes back to my current wallpaper.

interesting, ill have to add some debug code to it to try and see whats happening, do you in by any chance have alogcat installed? if so, do a see if a crash report comes up when you try and set it, if not do a filter for DroidTris.


My next act will be making this debug process easier and automated xD.

Also your screen is hvga, where this app is meant for wvga, i was under the impression that it should still run...I will have to do more testing .
Last edited by jug6ernaut; 20th October 2010 at 05:32 PM.
20th October 2010, 07:22 PM |#8  
hoovnick's Avatar
Senior Member
Thanks Meter: 62
 
More
Quote:
Originally Posted by jug6ernaut

interesting, ill have to add some debug code to it to try and see whats happening, do you in by any chance have alogcat installed? if so, do a see if a crash report comes up when you try and set it, if not do a filter for DroidTris.


My next act will be making this debug process easier and automated xD.

Also your screen is hvga, where this app is meant for wvga, i was under the impression that it should still run...I will have to do more testing .

D/DroidTris(23715): Failed to receive path from java
W/LivewallpaperPreview(23706): Wallpaper service gone:
CompositeInfo{jug6ernaut.lwp.tetris/jug6ernaut.lwp.tetris.
TetrisWallpaperService}

Hope that's what you need.
20th October 2010, 08:19 PM |#9  
egzthunder1's Avatar
Moderator Committee Lead / Member Advocate Admin - Spirit of XDA
Flag At The Good End Of My Hammer, Likes: My Family & XDA, Dislikes: Incompetence
Thanks Meter: 6,185
 
More
Quote:
Originally Posted by hoovnick

Nope, I let it go into standby while waiting for it to apply. Then I told it to set wallpaper anyway, just goes back to my current wallpaper.

Same issue here. Also, if you try to modify settings, it will go back to the preview screen by itself randomly. Lastly, there is no icon for when you want to choose the LWP.

Hope this helps you a bit

Tried it on my EVO.
20th October 2010, 10:00 PM |#10  
jug6ernaut's Avatar
OP Retired Moderator / Recognized Developer
Flag San Antonio, Tx
Thanks Meter: 473
 
More
Quote:
Originally Posted by hoovnick

D/DroidTris(23715): Failed to receive path from java
W/LivewallpaperPreview(23706): Wallpaper service gone:
CompositeInfo{jug6ernaut.lwp.tetris/jug6ernaut.lwp.tetris.
TetrisWallpaperService}

Hope that's what you need.

Quote:
Originally Posted by egzthunder1

Same issue here. Also, if you try to modify settings, it will go back to the preview screen by itself randomly. Lastly, there is no icon for when you want to choose the LWP.

Hope this helps you a bit

Tried it on my EVO.

Interesting, i had another person test it out and he is having the same problem. Idky it is happening but ill figure out. In the mean time i might release a version that does not use the system that is failing, tho this is why im doing public testing bc this problem isnt happening to the small group of ppl i had for private testing xD. Thanks for the info btw, ill post when i have an update .
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes