Android Lollipop Lands for the Sony Xperia Z Ultra

The undisputed king of the beasts–at least in Sony’s current stable,is the … more

Android 5.0 Lollipop in 3D–EVO 3D, That Is!

It is that time of the year once again. Flowers bloom (or snow falls, depending on which … more

Gaming Console with Lollipop? Ouya Gets an Android TV Port

Android is a very flexible platform, and it can be used on a large variety of … more

Android App Review: Manage Your Connections Automagically – XDA TV

Material Design is all the buzz in the Android world right now. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Changing APN settings - not saving

OP ThomasHW

23rd July 2010, 07:07 PM   |  #21  
NFHimself's Avatar
Senior Member
Flag Mount Pearl
Thanks Meter: 467
 
810 posts
Join Date:Joined: Mar 2008
Donate to Me
More
Quote:
Originally Posted by Millence

The reason for disappearing APNs is 'fix for payed applications' in whatever build you running. You have 2 options:

1 Remove 'fix for payed applications' from system.rc (you live in Canada and I guess that you don't need it anyway).

2 Make your APN and don't change MNC and MCC values(save). Make your APN default. Edit APN again and change MNC and MCC(save).
APN will disappear but after reboot data will work!!!

I hope this will help

I've used the replacement lib from rls3 and I have tried to do step 2. The replacement lib gives me generic "android" as APN, and step 2 works if having android still be default in the settings means it's working on bell's network. Is system.rc in the nbh?

I also tried editing the conf file apns-conf.xml it has this:

Code:
  <apn carrier="Bell Internet"
      mcc="302"
      mnc="610"
      apn="pda.bell.ca"
      mmsc="ht tp://mms.bell.ca/mms/wapenc"
      type="default,supl,mms"
  />
I was trying this:

Code:
  <apn carrier="Bell Internet"
      mcc="302"
      mnc="610"
      apn="pda.bell.ca"
      proxy="web.wireless.bell.ca"
      port="80"
      mmsc="ht tp://mms.bell.ca/mms/wapenc"
      mmsproxy="web.wireless.bell.ca"
      mmsport="80"
      type="default,supl,mms"
  />
*space in http to allow this message to post.
22nd August 2010, 06:58 PM   |  #22  
Senior Member
Thanks Meter: 2
 
103 posts
Join Date:Joined: Jun 2010
More
I was having this problem with my SGS. I just deleted the apns-conf.xml located in /etc/system

This requires root+terminal+busybox. Then just use a command 'busybox rm /etc/system/apns-conf.xml Just replied to note...
The Following User Says Thank You to rkantos For This Useful Post: [ View ]
23rd September 2010, 10:13 AM   |  #23  
Senior Member
Thanks Meter: 8
 
155 posts
Join Date:Joined: Feb 2010
More
Quote:
Originally Posted by rkantos

I was having this problem with my SGS. I just deleted the apns-conf.xml located in /etc/system

This requires root+terminal+busybox. Then just use a command 'busybox rm /etc/system/apns-conf.xml Just replied to note...

exactly my issues (WAS) on SGS but i tried succesfuly another solution

enter your APN settings, save it -> it would appear that it's not saved

reboot

go into your APN settings -> none there

create new one, enter settings , SAVE and voila ! it's there.

tap the circle to turn it on (green) and you are set to go.
25th October 2010, 10:06 PM   |  #24  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Feb 2010
Quote:
Originally Posted by g0c

exactly my issues (WAS) on SGS but i tried succesfuly another solution

enter your APN settings, save it -> it would appear that it's not saved

reboot

go into your APN settings -> none there

create new one, enter settings , SAVE and voila ! it's there.

tap the circle to turn it on (green) and you are set to go.

This does not seem to be working when I change the MMC and MNC. I think I have tried about every variation of this and that and I still can't get this stupid APNs to save my settings after I change the MMC and MNC. Any suggestions?
25th October 2010, 10:47 PM   |  #25  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Feb 2010
Quote:
Originally Posted by Millence

The reason for disappearing APNs is 'fix for payed applications' in whatever build you running. You have 2 options:

1 Remove 'fix for payed applications' from system.rc (you live in Canada and I guess that you don't need it anyway).

2 Make your APN and don't change MNC and MCC values(save). Make your APN default. Edit APN again and change MNC and MCC(save).
APN will disappear but after reboot data will work!!!

I hope this will help

Millence,

Can you elaborate on how your Remove 'fix for payed applications' from system.rc? I have been working with a few people that have CDMA Motorola Milestones and we are having the same issue with the APN settings and trying to add in our local carrier after we flash a custom ROM. Any help would be awesome.
27th October 2010, 02:27 AM   |  #26  
nathsgames's Avatar
Senior Member
Flag Gold Coast
Thanks Meter: 76
 
851 posts
Join Date:Joined: Oct 2010
Donate to Me
More
HI was there ever a resolution to this thread as I have this issue on my Froyo'd Samsung Galaxy S.

These are my carrier APN's but if I set the MNC to 02, they do not save, thanks.

Obviously if I leave the MNC at 029 it saves but doesn't work?

Name: Virgin Internet
APN: VirginInternet
Proxy:
Port:
Username:
Password:
Server:
MMSC:
MMS proxy:
MMS port:
MCC: 505
MNC: 02
APN type: default

These are the details for the MMS one:

Name: Virgin MMS
APN: VirginMMS
Proxy:
Port:
Username:
Password:
Server:
MMSC: had to remove this to get the post through
MMS proxy: 202.139.83.152
MMS port: 8070
MCC: 505
MNC: 02
APN type: mms
31st October 2010, 09:15 AM   |  #27  
Senior Member
Flag Mumbai
Thanks Meter: 26
 
554 posts
Join Date:Joined: Oct 2010
More
Same problem here. I'm yet to try the solutions mentioned above. Will report once I'm with them....
31st October 2010, 10:31 AM   |  #28  
Senior Member
Flag Mumbai
Thanks Meter: 26
 
554 posts
Join Date:Joined: Oct 2010
More
Doesn't work. Someone please tell me how to remove system.rc
1st November 2010, 12:42 AM   |  #29  
nathsgames's Avatar
Senior Member
Flag Gold Coast
Thanks Meter: 76
 
851 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by pramathesh

Same problem here. I'm yet to try the solutions mentioned above. Will report once I'm with them....

Well what I found was there was something wrong with my phone.

I wiped it and restored factory settings via the recovery menu, re-entered the APN details, not touching the MNC (leaving it at 029) and they saved and worked.
1st April 2011, 04:29 PM   |  #30  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Apr 2011
APN Settings not saving
Using Sony Ericsson X10 I had same problem after replacing a defective SIM card from Bell Mobility. Solution was to use Sony Ericsson PC Companion | Support Zone | Software Update | Repair

This resets the phone's OS so make sure (as warned in the procedure) you use Backup feature in the phone to save your contacts and settings.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes