[Q] I can't turn it on, but I can access bootloader, flash ROMs, and Hard Reset!

7 posts
Thanks Meter: 1
By lonefoxking, Junior Member on 17th March 2012, 07:45 PM
Thread Deleted Subscribe to Thread Email Thread

I can't manage to make my polaris boot, When I plug it in the charger it does not show that it is charging, however, I removed the battery, plugged the charger and tested the contacts with the voltmeter and it showed that there is power reaching the battery.

I can enter the bootloader & MicroSD flash mode normally, I even flashed a new Hard SPL, default radio, and the official ROM, but nothing, it does not start!

I tried the hard reset (IE icon + gps & restart) it successfully did the hard reset, but failed to boot.

I assume & summarize with the following:
1. If the battery was failing, it wont be able to go to bootloader and flash the ROM.
2. if the USB contacts are not good, power will not be able to reach all the way to the battery contacts.
3. If it is a software problem, I have did the Hard SPL, New/Default Radio & Default/cooked ROM.

Can anyone please tell me what is the problem and how can I fix it?

Thank you in advance...
The Following User Says Thank You to lonefoxking For This Useful Post: [ View ]
17th March 2012, 09:57 PM |#2  
husam666's Avatar
Senior Member
Flag Planet Omicron Persei 8
Thanks Meter: 1,101
Last edited by husam666; 9th April 2012 at 05:40 PM.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes