5,600,571 Members 33,176 Now Online
XDA Developers Android and Mobile Development Forum

[APP][1.6+] SD Maid - System cleaning tool

Tip us?
 
Dark3n
Old
#891  
Dark3n's Avatar
Recognized Developer - OP
Thanks Meter 1830
Posts: 1,891
Join Date: Sep 2007
There is now a beta with JellyBean 4.2 support available HERE.

Most functions don't work across multiple user profiles yet, i.e. the app cleaner will only clean your cache, not the other users app caches.
If you don't use multiple user accounts on 4.2, you don't have to worry about this anyways.

I'm probably going to add a setting on rooted devices that allows to choose between "All Users/UserA/UserB", will have to look into that .
The Following 3 Users Say Thank You to Dark3n For This Useful Post: [ Click to Expand ]
 
wuppiwuppi
Old
#892  
Junior Member
Thanks Meter 4
Posts: 15
Join Date: Jul 2012
Quote:
Originally Posted by pele78 View Post
everyone push darken to add scheduling cleaning options!!!!!!!!!!!!!
hey hoo, keep your blood pressure down!
it is his tool and ppl can decide for themselves who to push or not !

sorry for not quoting your font size ...
 
scarmon25
Old
#893  
scarmon25's Avatar
Senior Member
Thanks Meter 2160
Posts: 5,519
Join Date: Feb 2011
Location: Knoxville, TN

 
DONATE TO ME
After talking to Darken I think that was a joke. I really hope so anyway.
 
Sef_
Old
#894  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2012
Location: São Paulo
First of all, great app!
But after last updade, when I try to uninstall something with APPCONTROL (Using "Remove the app and its data" option), the message "Working..." stays there for ever. (It only disappears when I press the Xperia's Search button or when I close SD Maid using other app). The app that I was trying to uninstall is normally uninstalled by the way.
 
Dark3n
Old
#895  
Dark3n's Avatar
Recognized Developer - OP
Thanks Meter 1830
Posts: 1,891
Join Date: Sep 2007
Quote:
Originally Posted by Sef_ View Post
First of all, great app!
But after last updade, when I try to uninstall something with APPCONTROL (Using "Remove the app and its data" option), the message "Working..." stays there for ever. (It only disappears when I press the Xperia's Search button or when I close SD Maid using other app). The app that I was trying to uninstall is normally uninstalled by the way.
Which version are you on now, and which version were you on before?
 
Sef_
Old
(Last edited by Sef_; 21st November 2012 at 10:50 AM.)
#896  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2012
Location: São Paulo
Quote:
Originally Posted by Dark3n View Post
Which version are you on now, and which version were you on before?
Now = 2.0.2.1 RC2
Before = Don't remember. I downloaded from the market last month. I guess 2.0.2.0
 
Bacardi_Drinker
Old
#897  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jun 2009
Quote:
Originally Posted by Buleste View Post
I have an Orange UK Barcelona otherwise known as a Huawei U8350 running Android 2.2 . I have SD Maid Pro but whenever I run System Cleaner, Searcher or Optimize DBs the phone brings up the pop up and does nothing. I've even tried leaving the phone on overnight to see if it was just a time thing but nothing seems to happen. I've tried uninstalling and reinstalling BusyBox (I have 1.20.2 installed via BusyBox Pro although the startup screen on SD Maid Pro say 1.19.3-sdm55) I've tried fixing permissions but all to no avail. I've put the app into debug mode but cannot find any log for it. Can anyone help please?
Quote:
Originally Posted by Dark3n View Post
You can not update the busybox, the version displayed is of the busybox SD Maid brings along, not your system one.
I have heard of issues running the find command on some devices.
It starts never finishes.
You could open the console, and do a search for everything as super user.
i.e. Open terminal emulator, type "su", type "find /" which should use your system busybox, then try to type "/data/data/eu.thedarken.sdm/files/busybox find /" which should use SD Maids busybox.
Does one of the commands finish?
Hello Dark3n,
i have a similar problem as Buleste with your great app.

My phone is a Huawei Honor U8860 with Stock2.3.6, rootet with Superuser.
Things i have done:
- First installed your app and run it
- allowed root without remember at statup
- refresh SYSTEMCLEANER -> asked for root -> allowed
- app hangs up on searching

- reboot the phone
- run your app again with root allowed without remember
- refresh SYSTEMCLEANER -> asked for root -> denied
- app runs on non rootet directories perfect

I tested the 2 searches in a terminal, both finished.

any recommendation ?
 
Sef_
Old
#898  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2012
Location: São Paulo
Quote:
Originally Posted by Sef_ View Post
Now = 2.0.2.1 RC2
Before = Don't remember. I downloaded from the market last month. I guess 2.0.2.0
Can't play why, but it's working again now.
Even before, when I was using stock firmware/ROM/etc isn't working.
And I didn't installed anything unusual
 
g.d.legion
Old
#899  
Junior Member
Thanks Meter 0
Posts: 26
Join Date: Jun 2012
Location: Bekasi
Good Job!!

Sent from my GT-S5830 using xda premium
 
Dark3n
Old
#900  
Dark3n's Avatar
Recognized Developer - OP
Thanks Meter 1830
Posts: 1,891
Join Date: Sep 2007
Quote:
Originally Posted by Bacardi_Drinker View Post
Hello Dark3n,
i have a similar problem as Buleste with your great app.

My phone is a Huawei Honor U8860 with Stock2.3.6, rootet with Superuser.
Things i have done:
- First installed your app and run it
- allowed root without remember at statup
- refresh SYSTEMCLEANER -> asked for root -> allowed
- app hangs up on searching

- reboot the phone
- run your app again with root allowed without remember
- refresh SYSTEMCLEANER -> asked for root -> denied
- app runs on non rootet directories perfect

I tested the 2 searches in a terminal, both finished.

any recommendation ?
Sorry, i know about that problem, i already tried fixing it once (obviously didnt work), i will look at it again, just got alot going on at the moment.

For some reason the console/shell doesn't exit correctly on some huawei devices, so SD Maid waits endlessly for the operation to finish, which already finished, but doesn't exit.

Does it also hang if you start SD Maid and deny root from the start? Changing the root granting while SD Maid is already started is not good and can lead to unpredictable behavior.

Tags
sdcard;tidy;junk;free space;memory
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes