Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,642 Members 44,491 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Lost IMEI after upgrade

Tip us?
 
NoKeR
Old
(Last edited by NoKeR; 18th April 2011 at 09:39 AM.)
#1  
Junior Member - OP
Thanks Meter 5
Posts: 25
Join Date: Dec 2007
Location: Trondheim
Default [Q] Lost IMEI after upgrade

Hi all!

I were in the process to upgrade to 10b on my phone, but during the upgrade the phone stopped responding on upgrading S/W. Please wait. And after some time on that screen, I removed the battery and cable, and tried the different solutions provided by the LG B2C Support Tool.

After that I tried to flash the phone with smartflash and the latest software. And that worked perfectly, but now the phone has no IMEI. Have tried to install the backup I had via CWM but still no IMEI.

I was looking forward to use the 2x this easter, but if noone has a good solution in getting the IMEI back, the phone needs to go on a easter holiday to the service centre.
 
Zanr Zij
Old
(Last edited by Zanr Zij; 19th April 2011 at 03:18 AM.)
#2  
Zanr Zij's Avatar
Senior Member
Thanks Meter 510
Posts: 958
Join Date: Nov 2010
Location: Halong Bay
You did the same thing with me. When using smartflash, DO NOT check option "Erase CAL data" but I did. My SU660 now has serial number = 0000000. P990 will lost IMEI.

Sent from my LG-SU660 using XDA Premium App
Pass: Bold 9700, 9000, IP 3GS, Milestone, Milestone XT720, i9000, Captivate, X10i, Nook Color, Galaxy S i9000, Atrix 4G, Optimus 2X, Arc S, IP4, S2, Note 1, S3
 
popshansen
Old
#3  
Junior Member
Thanks Meter 3
Posts: 20
Join Date: Jul 2009
I had the same problem, you need to flash the baseband firmware as it is gone.
I think that it was during updating the baseband as part of the V10b mine stopped flashing.
Look here: http://forum.xda-developers.com/show....php?t=1008070

It worked with mine o2x.
 
NoKeR
Old
#4  
Junior Member - OP
Thanks Meter 5
Posts: 25
Join Date: Dec 2007
Location: Trondheim
I managed to solve the situation.

I applied the 10b firmware using nvflash. And then flashed the 10a fw with smartflash, checked that the IMEI were back in business. And then did a new update using smartflash to 10b and now everything is back as normal
 
mohicanrat
Old
#5  
mohicanrat's Avatar
Senior Member
Thanks Meter 99
Posts: 143
Join Date: Jul 2010
Default restore IMEI (From Modaco)

1. Connect phone by USB
2. Enter 1809#*990# in dialer
3. Select Port Settings -> Select CP USB
4. Start hyperterminal, in COM settings select same port like in devide manager -> LGE mobile USB Serial Port, 115200
5. Type AT if response is not OK, change port number
6. Type at%imei, it should display your current IMEI
7. Type at%imei=x,x,x,x,x,x,x,x,x,x,x,x,x,x,x , where x,x,x... is your orginal IMEI number
8. Reset
Founder Fan Page Bengkel Android
The Following 12 Users Say Thank You to mohicanrat For This Useful Post: [ Click to Expand ]
 
teju85
Old
#6  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jun 2011
Hi mohicanrat,
I tried to set 'Port Setting' -> 'CP USB', but in the device manager (i'm using win7), this device then shows up as 'Other Devices' -> 'Unknown device'.
What should I do now? Where can I get the device driver for this?
 
ollivier54
Old
#7  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Jul 2007
hello,

please where i go to "Start hyperterminal, in COM settings"
 
Rusty!
Old
#8  
Rusty!'s Avatar
Recognized Contributor
Thanks Meter 1,751
Posts: 7,918
Join Date: Jan 2010
Location: Portsmouth
HyperTerminal was binned after Windows XP, if you have Vista onwards you'll need to download an equivalent.
Google Nexus 5 on Three UK
The Following User Says Thank You to Rusty! For This Useful Post: [ Click to Expand ]
 
seattleboy1st
Old
#9  
Member
Thanks Meter 0
Posts: 46
Join Date: May 2011
Location: Chongqing
Quote:
Originally Posted by mohicanrat View Post
1. Connect phone by usb
2. Enter 1809#*990# in dialer
3. Select port settings -> select cp usb
4. Start hyperterminal, in com settings select same port like in devide manager -> lge mobile usb serial port, 115200
5. Type at if response is not ok, change port number
6. Type at%imei, it should display your current imei
7. Type at%imei=x,x,x,x,x,x,x,x,x,x,x,x,x,x,x , where x,x,x... Is your orginal imei number
8. Reset
thank you very much. I did as you said and finally got my imei back
thank you a million.
 
CDMAAA
Old
(Last edited by CDMAAA; 26th November 2011 at 09:40 AM.)
#10  
CDMAAA's Avatar
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2011
Quote:
Originally Posted by mohicanrat View Post
1. Connect phone by USB
2. Enter 1809#*990# in dialer
3. Select Port Settings -> Select CP USB
4. Start hyperterminal, in COM settings select same port like in devide manager -> LGE mobile USB Serial Port, 115200
5. Type AT if response is not OK, change port number
6. Type at%imei, it should display your current IMEI
7. Type at%imei=x,x,x,x,x,x,x,x,x,x,x,x,x,x,x , where x,x,x... is your orginal IMEI number
8. Reset
It gives error on running at%imei, might it be because phone driver not installed on windows?
at%imei
ERROR

I instaled driver from LG site LGUnitedMobileDriver_S498MA22_WHQL_ML_Ver_2.2.exe
when i type ATI4 for instance it shows same info as from log.

Here's log from modem i removed my IMEI though.
PHP Code:
11-26-2011 01:29:11.420 FileC:\Windows\system32\tapisrv.dllVersion 6.1.7600   
11
-26-2011 01:29:11.420 FileC:\Windows\system32\unimdm.tspVersion 6.1.7600   
11
-26-2011 01:29:11.421 FileC:\Windows\system32\unimdmat.dllVersion 6.1.7600   
11
-26-2011 01:29:11.421 FileC:\Windows\system32\uniplat.dllVersion 6.1.7600   
11
-26-2011 01:29:11.430 FileC:\Windows\system32\drivers\modem.sysVersion 6.1.7600   
11
-26-2011 01:29:11.430 FileC:\Windows\system32\modemui.dllVersion 6.1.7600   
11
-26-2011 01:29:11.438 FileC:\Windows\system32\mdminst.dllVersion 6.1.7600   
11
-26-2011 01:29:11.439 Modem typeLGE Mobile USB Modem
11
-26-2011 01:29:11.439 Modem inf pathoem29.inf
11
-26-2011 01:29:11.439 Modem inf sectionLGSI.Install
11
-26-2011 01:29:11.439 Matching hardware IDusb\vid_1004&pid_6000_modeminterface
11
-26-2011 01:29:11.470 460800,8,N,1ctsfl=0rtsctl=1
11
-26-2011 01:29:11.488 Initializing modem.
11-26-2011 01:29:11.488 CD is high while initializing modem.
11-26-2011 01:29:11.498 SendAT<cr>
11-26-2011 01:29:11.504 Recv: <cr><lf>OK<cr><lf>
11-26-2011 01:29:11.504 Interpreted responseOK
11
-26-2011 01:29:11.514 SendATE0V1&D2&C1S0=0<cr>
11-26-2011 01:29:11.526 Recv: <cr><lf>ERROR<cr><lf>
11-26-2011 01:29:11.526 Interpreted responseError
11
-26-2011 01:29:11.527 Session Statistics:
11-26-2011 01:29:11.527 -                Reads 15 bytes
11
-26-2011 01:29:11.527 -                Writes20 bytes
ATQ0V1E0 
OK
AT
+GMM 0
AT
+FCLASS=? - +FCLASS: (0-1)
AT#CLS=? - COMMAND NOT SUPPORTED
AT+GCI? - COMMAND NOT SUPPORTED
AT
+GCI=? - COMMAND NOT SUPPORTED
ATI1 
ManufacturerQUALCOMM INCORPORATED
       Model
0
       Revision
M6600A-SCAUTNZ-2.0.9720T  1  [JUL 15 2011 10:00:00MP:TRULGE_08.09.02R_MDM
       IMEI
: < removed >
       +
GCAP: +CGSM,+DS,+ES
ATI2 
ManufacturerQUALCOMM INCORPORATED
       Model
0
       Revision
M6600A-SCAUTNZ-2.0.9720T  1  [JUL 15 2011 10:00:00MP:TRULGE_08.09.02R_MDM
       IMEI
: < removed >
       +
GCAP: +CGSM,+DS,+ES
ATI3 
ManufacturerQUALCOMM INCORPORATED
       Model
0
       Revision
M6600A-SCAUTNZ-2.0.9720T  1  [JUL 15 2011 10:00:00MP:TRULGE_08.09.02R_MDM
       IMEI
: < removed >
       +
GCAP: +CGSM,+DS,+ES
ATI4 
ManufacturerQUALCOMM INCORPORATED
       Model
0
       Revision
M6600A-SCAUTNZ-2.0.9720T  1  [JUL 15 2011 10:00:00MP:TRULGE_08.09.02R_MDM
       IMEI
: < removed >
       +
GCAP: +CGSM,+DS,+ES
ATI5 
ManufacturerQUALCOMM INCORPORATED
       Model
0
       Revision
M6600A-SCAUTNZ-2.0.9720T  1  [JUL 15 2011 10:00:00MP:TRULGE_08.09.02R_MDM
       IMEI
: < removed >
       +
GCAP: +CGSM,+DS,+ES
ATI6 
ManufacturerQUALCOMM INCORPORATED
       Model
0
       Revision
M6600A-SCAUTNZ-2.0.9720T  1  [JUL 15 2011 10:00:00MP:TRULGE_08.09.02R_MDM
       IMEI
: < removed >
       +
GCAP: +CGSM,+DS,+ES
ATI7 
ManufacturerQUALCOMM INCORPORATED
       Model
0
       Revision
M6600A-SCAUTNZ-2.0.9720T  1  [JUL 15 2011 10:00:00MP:TRULGE_08.09.02R_MDM
       IMEI
: < removed >
       +
GCAP: +CGSM,+DS,+ES 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes