Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,770,363 Members 47,394 Now Online
XDA Developers Android and Mobile Development Forum

Setting Go dialer as default dialer?

Tip us?
 
typhoonikan
Old
#1  
typhoonikan's Avatar
Senior Member - OP
Thanks Meter 105
Posts: 637
Join Date: Nov 2010
Question Setting Go dialer as default dialer?

I hope that I am posting this in the correct sub-forum...

I installed go dialer on my rooted evo and set it on my launcher pro dock. Though it seems when I receive a phone call, it comes through myn's warmm 2.2 dialer instead of go dialer. When I go to settings>apps>manage>dialer, the clear defaults button is grayed out.

I was not asked to set the default dialer when i opened go dialer, and do not see any options in go dialer's settings to fix this.

What do?
Thanks.
 
jeffm922
Old
(Last edited by jeffm922; 25th April 2011 at 05:47 PM.)
#2  
Senior Member
Thanks Meter 27
Posts: 138
Join Date: Mar 2011
Location: Colorado
try this... goto menu-settings-applications-all applications then find the stock dialer, click it, and then if you can, click on the "clear defaults" button, that should stop the phone from thinking that the stock dialer is the default one, and prompt you on which dialer you want to use when u hit the phone button


EDIT: sorry re-read the post... and see that u have already tried that....so if you go to ur app list... and click godialer. it doesn't ask you if you want the default. are you sure that your shortcut is pointed to go dialer?
 
awesomeindeed
Old
#3  
Senior Member
Thanks Meter 10
Posts: 335
Join Date: Apr 2008
Location: Chicago Suburbs
The "incoming call" feature is a part of the sense dialer. It won't go away. You only use Go Dialer to make outgoing calls and look through your call history pretty much. If you're referring to after a phone call it drops you back into the sense dialer, that's unavoidable at this point as far as I know with Go Dialer.
Devices:
Samsung Galaxy S II Epic 4G Touch - Stock
HP Touchpad 16GB - 1.7GHz
HTC Evo 3D - Rooted - Stock
Google Nexus S 4G - Rooted - Stock
HTC Evo 4G - Rooted - Stock
HTC Touch Diamond - Sprint - Custom WM6.5 build - retired
 
thegregbradley
Old
#4  
Senior Member
Thanks Meter 57
Posts: 444
Join Date: Aug 2010
Quote:
Originally Posted by awesomeindeed View Post
If you're referring to after a phone call it drops you back into the sense dialer, that's unavoidable at this point as far as I know with Go Dialer.
I don't have any experience with go dialer and sense, but in Salvage-Mod it drops me back to Go Dialer after a call (it asked me once and I set it to the default).

But otherwise, in call, my screen is the AOSP gingerbread dialer, I don't think Go Dialer even has an in-call screen.
 
typhoonikan
Old
#5  
typhoonikan's Avatar
Senior Member - OP
Thanks Meter 105
Posts: 637
Join Date: Nov 2010
Yes, I believe this is not fixable as its the Sense dialer taking control.
boo.
 
donalgodon
Old
#6  
donalgodon's Avatar
Senior Member
Thanks Meter 653
Posts: 3,788
Join Date: Jan 2010
I fixed it by using the paid version of "Not Call Log" and Go Dialer.

Nothing else worked. I tried all the free versions of the 'fixes' and they all stopped working or only had partial success.

Man, the stock Streak dialer is one UGLY beast. Bleh!

It was worth $1.00 to me.
PHONE: Samsung Galaxy Note 3 (SM-N900)
ROM: [KitKat][4.4.2] Stock N900UBUDND1 APR 17, 2014 CF-Auto-Root
RADIO: N900UBUDNC1
KERNEL: Stock
RECOVERY: CWM 6.0.4.7
WARRANTY BIT: 1

TABLET: Kindle Fire HD 8.9 Stock

STATUS: Flashing Addict!





Quote:
“He who answers a matter before he hears it, It is folly and shame to him.” Proverbs 18:13
The Following User Says Thank You to donalgodon For This Useful Post: [ Click to Expand ]
 
DrELM
Old
#7  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: May 2009
Location: Baki
Select "Contacts" instead of "Dialer" in Settings > Applications > All
Clcik "Clear defaults" then go home and press dial button.
 
petersteier
Old
#8  
Junior Member
Thanks Meter 6
Posts: 29
Join Date: Aug 2010
Quote:
Originally Posted by DrELM View Post
Select "Contacts" instead of "Dialer" in Settings > Applications > All
Clcik "Clear defaults" then go home and press dial button.
I fear this is wrong; the "Clear defaults" button is dimmed here also on my 2.3.6 Samsung Galaxy Note. Did you try it out? Additionally, it sound like it would only apply to outgoing calls, not to incoming calls!
 
jclake
Old
#9  
Junior Member
Thanks Meter 1
Posts: 7
Join Date: Jan 2011
Default Thanks your suggestion worked.

Quote:
Originally Posted by DrELM View Post
Select "Contacts" instead of "Dialer" in Settings > Applications > All
Clcik "Clear defaults" then go home and press dial button.
This worked for me. Galaxy Nexus with ICS.
 
pvaldeben
Old
#10  
pvaldeben's Avatar
Senior Member
Thanks Meter 46
Posts: 256
Join Date: Feb 2011
Location: E. Rockaway
Quote:
Originally Posted by typhoonikan View Post
I hope that I am posting this in the correct sub-forum...

I installed go dialer on my rooted evo and set it on my launcher pro dock. Though it seems when I receive a phone call, it comes through myn's warmm 2.2 dialer instead of go dialer. When I go to settings>apps>manage>dialer, the clear defaults button is grayed out.

I was not asked to set the default dialer when i opened go dialer, and do not see any options in go dialer's settings to fix this.

What do?
Thanks.
I have the same problem so I ended going back to MikMik 3.11 rom flashed inverted theme and then installed ADW Launcher with ICS theme and then V6 supercharge, my Evo 4G is super responsive and fast.

Also I think since I'm using ADW Launcher as default the Sence framework does not load so you cannot get many of their widgets. I get similar widgets I use HD widgets, Pro Widget.

ICS roms are becoming much more stable now but the camera issue and no 4G are always the reason I go back to MikMik 3.11/Anthrax kernel. All I need from ISC rom is the email widget but have not been able to find any similar ones in the market.

So try MikMik 3.11 then use a different launcher.
If this help click Thank you button, I only have 1 so far.

OK Later.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


LifeStats Automatic Journal Keeps Tabs of Your Day

Most of us live very active lives. This is after all why we’re fans of mobile … more

Android App Review: Hide Your Files with Androignito – XDA Developer TV

Stop right now, look at your phone, and see how many pictures, … more

BrightNotes Makes Cloud Notes Simple and Easy

There are literally thousands of note taking apps available on Android, with practically every … more

Google Glass XE20.1 Update Brings Improved Contacts, Head Nudge, New Cards and Commands

Ever since Google unveiled Android Wear earlier this … more