5,593,793 Members 46,981 Now Online
XDA Developers Android and Mobile Development Forum

Huawei Ideos U8150 Recovery Guide

Tip us?
 
Xynche
Old
(Last edited by Xynche; 29th May 2011 at 04:24 AM.)
#11  
Member
Thanks Meter 9
Posts: 30
Join Date: May 2011
I'm having a bit of trouble.

I was trying method 2 and clicked the wrong phone model. I went to change it but found that "Huawei IDEOS U8150" is not listed. Now I cannot access my recovery menu, and cannot install clockwork recovery. How would I fix this? I've been searching for hours and only found ways to remove it via the recovery menu.

Everything is functioning fine so it's not a big problem, I just can't get to the recovery menu/boot loader.

Also, I attempted method 1 because it doesn't involve the use of the recovery menu. It says, "flash_image: not found" when I type the command.

Nevermind, put about another hour into searching. Thank you so much for this guide it helped me alot.
 
mShoaib
Old
#12  
mShoaib's Avatar
Member
Thanks Meter 7
Posts: 91
Join Date: Apr 2011
I installed ROM Manager and pressed "Flash ClockworkMod Recovery".
It downloaded some files and flashed the Mod.
(I have my u8150 rooted using SuperOneClick)

Now it shows that my ClockworkMod Recovery version is 3.0.2.4
BUT the problem is that:

1>If I press reboot into recovery, the phone reboots and I end up staring at the IDEOS logo for ... like ever.

2>I pressed Backup Current ROM and after giving it a name (Stock ROM), I pressed OK and again the same result.

3> I found on the internet that to go into the recovery mode I need to press the SEND (green button) and the Volume UP together and then press Power.
I did it, even held the three buttons in the next try... but sadly every time the phone got stuck and I ended up looking at the IDEOS logo.

and the only way to get the phone working again was to take out the battery and press Power. (the phone itself is running fine)

PLz kindly help me out on this.. am I missing something??
Thnx
 
wachw
Old
#13  
Senior Member - OP
Thanks Meter 42
Posts: 182
Join Date: Feb 2011
Location: Nairobi
That means the recovery didn't flash correctly. Are u sure u selected the right phone from the rom manager list. Try flash recovery again. But first u need to delete everything in the clockworkmod/download directory on the sd card. Or if you know how to, just delete the recovery image in that folder.
The Following User Says Thank You to wachw For This Useful Post: [ Click to Expand ]
 
mShoaib
Old
(Last edited by mShoaib; 8th June 2011 at 05:42 PM.)
#14  
mShoaib's Avatar
Member
Thanks Meter 7
Posts: 91
Join Date: Apr 2011
yes I selected the corret phone i.e. Huawei u8150 Ideos
i deleted everything in the clockworkmod/download directory on the sd card

re-flashed..
still the same problem

btw.. during flashing, twice I got a pop-up asking me to either "force close" or "wait" and I pressed "wait" both times.

P.S. I just noticed after removing the battery that it says the model of my phone is U8150-D. I wonder what the "D" stands for?
 
wachw
Old
#15  
Senior Member - OP
Thanks Meter 42
Posts: 182
Join Date: Feb 2011
Location: Nairobi
It shuld not be force closing. Maybe rom manager has a problem. Try reinstalling it. If that doesn't work I suggest trying one of the other methods to flash the recovery.
The Following User Says Thank You to wachw For This Useful Post: [ Click to Expand ]
 
mShoaib
Old
(Last edited by mShoaib; 8th June 2011 at 06:51 PM.)
#16  
mShoaib's Avatar
Member
Thanks Meter 7
Posts: 91
Join Date: Apr 2011
ok so ive just tried Method 1 and followed every step... and the funny thing is that when I enter the following command in terminal emulator:
flash_image recovery /system/bin/recovery.img

.. it says
flash_image: not found

lol
now im downloading ultrajack

Update:
Ive tried Method 3:
and for 10 minutes now.. my command prompt is still showing this message:
< waiting for device >

:(
 
wachw
Old
#17  
Senior Member - OP
Thanks Meter 42
Posts: 182
Join Date: Feb 2011
Location: Nairobi
For method 3 try running the bat file first then when it shows you the waiting for device message turn on the phone in bootloader mode.
The Following User Says Thank You to wachw For This Useful Post: [ Click to Expand ]
 
mShoaib
Old
(Last edited by mShoaib; 9th June 2011 at 04:33 PM.)
#18  
mShoaib's Avatar
Member
Thanks Meter 7
Posts: 91
Join Date: Apr 2011
just did as you said, i turned off the phone.. ran the bat file, when it said waiting for device I plugged in the phone (battery charging started), then I pressed power while holding Red and Volume Down...
the result is the same..
(the same was the result when running ultrajack)

>im just wondering... do I need to install any kernel or something before doing this??
>also I noticed that the CWM's recovery.img that I got from this forum is 3.94MB, while the one I downloaded through the Rom Manager was 3.71MB (on both tries).

P.S. how do I completely remove CWM and its files? so i can start the process fresh. I read at some forum that there is some file related to this called update.zip... whats that?

(Sorry for being a bother and thnx for your help)

UPDATE !!!

Its done... its finally done. Yattaaaaa!!!

ok so here is is what I did....
>I deleted everything in the clockworkmod folder like you once mentioned before.
>You said that while flashing I shouldn't be getting a pop-up that asks me to either force close or wait.
>So I had a hunch that the popup that appeared during the flashing might have been caused due to the screen timeout set at 30 sec (i mean a clash of two processes)
>So, i set the screen timeout to 30 minutes (hehe) and pressed Flash ClockworkMod Recovery from the Rom Manager.
>It flashed without any pop-ups and it successfully booted into recovery mode (and the first thing I did was to backup my phone)

Once again thnx for your support wachw.
... and if you don't mind can you help me with one more thing (if it's convenient for you)... plz guide me how to install multitouch for my phone provided here (coz nobody at that thread has been generous enough to guide me ;_; )
http://forum.xda-developers.com/show....php?t=1014183
[i have downloaded the multitouch patch and the complied kernel, plz guide me on what to do next. thnx :) ]
The Following User Says Thank You to mShoaib For This Useful Post: [ Click to Expand ]
 
wachw
Old
#19  
Senior Member - OP
Thanks Meter 42
Posts: 182
Join Date: Feb 2011
Location: Nairobi
Sorry about the delay, been busy, but, if you send me the link to your provider's rom I can make a multitouch version for you. Why don't you want to install a custom rom?
 
mShoaib
Old
#20  
mShoaib's Avatar
Member
Thanks Meter 7
Posts: 91
Join Date: Apr 2011
here is the link to my provider's rom:
http://webftp.myppc.it/index.php?dir=Ideos/ROM/
direct link
http://webftp.myppc.it/index.php?dir...OM/&file=U8150 V100R001C230B828SP02(Pakistan Ufone ).rar

custom rom, hmm.. well ive heard about them but for now i want to see how much can the stock rom be modified xD
btw is it really possible to edit the rom and remove the simlock
someone here says so:
http://forum.xda-developers.com/show...=850110&page=5

The Following User Says Thank You to mShoaib For This Useful Post: [ Click to Expand ]
Tags
ideos, recovery, u8150
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes