5,598,657 Members 39,928 Now Online
XDA Developers Android and Mobile Development Forum

[Issue][5/16] Sound popping/crackling with small fix

Tip us?
 
Zacisblack
Old
(Last edited by Zacisblack; 16th May 2011 at 08:51 PM.)
#1  
Zacisblack's Avatar
Senior Member - OP
Thanks Meter 73
Posts: 514
Join Date: Dec 2010
Location: Austin, TX
Default [Issue][5/16] Sound popping/crackling with small fix

Since recent updates I've been getting popping in audio. This ONLY occurs when I touch the screen. For example when I have a song on and I swype I can hear popping as I move my finger across the screen. Is anyone else having this issue? Using voodoo control plus with version 8 driver.

EDIT: Emailed supercurio. He is working on a fix and I am testing it for him. The only tweak he said he found so far to improve this is using the command "echo 0 > /sys/module/printk/parameters/time" in adb shell. He said it should improve noise popping and he was exactly right. The popping is still noticeable but has much improved! He said he will consider integrating it in a future version.

EDIT (5/16): To be clear, Supercurio says this is a flaw in the Froyo kernel whether stock or not. I recently odined back to DL09 to do OTA to EB03 and still have some issues. Being on complete stock, the issue is not nearly as bad and doesn't occur when I interact with the screen. The issue of sound popping occurs about every 8-12 seconds when playing back audio of any kind. Here is one of his exact messages in our email conversation.

"François SIMOND - supercurio to me
show details Apr 28
Hi Zachary!

This is an issue with the [Froyo]* kernel itself, which is poorly implemented.
Gingerbread kernels are not affected anymore. Is it really bad in ED01 ?"

* Was added in for context.

Sent from my SCH-I500 using XDA Premium App
AT&T | Samsung Galaxy SIV SGH-I337
AT&T | Samsung Galaxy SIII SGH-i747
Verizon| Samsung Galaxy Nexus SCH-i515
Verizon| Samsung Galaxy S (Fascinate) SCH-i500
AT&T| Samsung Mythic SGH-a897
AT&T| Samsung Blackjack II SGH-i617
Cingular| Motorola Razr v3
T-Mobile| Samsung X495
 
Jrex
Old
#2  
Senior Member
Thanks Meter 8
Posts: 122
Join Date: Oct 2010
Location: Knoxvegas!
Quote:
Originally Posted by Zacisblack View Post
Since recent updates I've been getting popping in music. This ONLY occurs when I touch the screen. For example when I have a song on and I swype I can hear popping as I move my finger across the screen. Is anyone else having this issue? Using voodoo control plus with version 8 driver.

Sent from my SCH-I500 using XDA Premium App
Yeah, same here! I noticed it as soon as I got set up cause I use my fassy religiously as an mp3 player!
 
Zacisblack
Old
#3  
Zacisblack's Avatar
Senior Member - OP
Thanks Meter 73
Posts: 514
Join Date: Dec 2010
Location: Austin, TX
Quote:
Originally Posted by Jrex View Post
Yeah, same here! I noticed it as soon as I got set up cause I use my fassy religiously as an mp3 player!
Glad I'm not the only one!

Sent from my SCH-I500 using XDA Premium App
AT&T | Samsung Galaxy SIV SGH-I337
AT&T | Samsung Galaxy SIII SGH-i747
Verizon| Samsung Galaxy Nexus SCH-i515
Verizon| Samsung Galaxy S (Fascinate) SCH-i500
AT&T| Samsung Mythic SGH-a897
AT&T| Samsung Blackjack II SGH-i617
Cingular| Motorola Razr v3
T-Mobile| Samsung X495
 
keith.mcintyre26
Old
#4  
keith.mcintyre26's Avatar
Senior Member
Thanks Meter 464
Posts: 944
Join Date: Feb 2009
Location: Richmond
Quote:
Originally Posted by Zacisblack View Post
Since recent updates I've been getting popping in music. This ONLY occurs when I touch the screen. For example when I have a song on and I swype I can hear popping as I move my finger across the screen. Is anyone else having this issue? Using voodoo control plus with version 8 driver.

Sent from my SCH-I500 using XDA Premium App
What rom/kernel?

Sent from my SCH-I500 using XDA Premium App
"I've seen what happens to the wicked and proud when they decide to try to take on the throne for the crown."
 
Zacisblack
Old
#5  
Zacisblack's Avatar
Senior Member - OP
Thanks Meter 73
Posts: 514
Join Date: Dec 2010
Location: Austin, TX
Community Rom and the included rom by nemesis2all. I just reverted from jt's alpha gingerbread and it happened on that too. Dont think it's a ROM issue but rather a voodoo sound driver issue. Just seeing if it's just me or if others are also noticing.

Sent from my SCH-I500 using XDA Premium App
AT&T | Samsung Galaxy SIV SGH-I337
AT&T | Samsung Galaxy SIII SGH-i747
Verizon| Samsung Galaxy Nexus SCH-i515
Verizon| Samsung Galaxy S (Fascinate) SCH-i500
AT&T| Samsung Mythic SGH-a897
AT&T| Samsung Blackjack II SGH-i617
Cingular| Motorola Razr v3
T-Mobile| Samsung X495
 
keith.mcintyre26
Old
#6  
keith.mcintyre26's Avatar
Senior Member
Thanks Meter 464
Posts: 944
Join Date: Feb 2009
Location: Richmond
Yeah I'd revert back to the previous kernel with voodoo 7.

Sent from my SCH-I500 using XDA Premium App
"I've seen what happens to the wicked and proud when they decide to try to take on the throne for the crown."
 
Kamar234
Old
#7  
Senior Member
Thanks Meter 9
Posts: 284
Join Date: Nov 2009
Location: New York
I too am having the same problem and it's driving me nuts! It's not only when you touch the screen, but whenever the processor load ramps up, so it's pretty much whenever the phone does any thinking. Very annoying.
 
s44
Old
#8  
Senior Member
Thanks Meter 152
Posts: 1,003
Join Date: Sep 2010
Doesn't happen for me (imnuts -50). But I'm using MortPlayer, not the stock Samsung.

If you're on the nemesis kernel, try changing some of the enabled clockspeeds?
 
Zacisblack
Old
#9  
Zacisblack's Avatar
Senior Member - OP
Thanks Meter 73
Posts: 514
Join Date: Dec 2010
Location: Austin, TX
Doesnt help. This also happened when I was on CM7 when I wasnt on nemesis2all's kernel. I realized this didnt happen until voodoo driver version 8. I emailed project voodoo to see what they have to say.

Sent from my SCH-I500 using XDA Premium App
AT&T | Samsung Galaxy SIV SGH-I337
AT&T | Samsung Galaxy SIII SGH-i747
Verizon| Samsung Galaxy Nexus SCH-i515
Verizon| Samsung Galaxy S (Fascinate) SCH-i500
AT&T| Samsung Mythic SGH-a897
AT&T| Samsung Blackjack II SGH-i617
Cingular| Motorola Razr v3
T-Mobile| Samsung X495
 
bobloblaw1
Old
#10  
Senior Member
Thanks Meter 401
Posts: 1,197
Join Date: May 2010
Have you checked the scheduler you are using? It almost sounds like the phone is decreasing the priority devoted to decoding the mp3 too much or it is giving too much cpu to the ui. Drivers

Sent from my SCH-I500 using XDA Premium App

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Say Goodbye to Holo Blue Once and for All

When Google released Android 4.4 KitKat back in October of last year, they changed quite a bit … more

Sony Z Ultra Google Play Edition Receives Bluetooth Certification for Android 4.4.3

You may recall that a few days ago, Sprint jumped the gun … more

Easily Configure Xposed Module Projects in Eclipse

XDA Recognized Developer rovo89‘s innovative and versatile Xposed Framework allows … more

Android Control Center Becomes Quick Control Panel, Brings Host of New Features

You may recall that back in August of last year, we talked … more