Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,110 Members 42,089 Now Online
XDA Developers Android and Mobile Development Forum

[Q] SD card works but can not be opened by some apps. How can i fix it

Tip us?
 
Konusan Balta
Old
#1  
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Feb 2010
Location: Ankara
Question [Q] SD card works but can not be opened by some apps. How can i fix it

I apologize if this has been thoroughly discussed here, but I can't seem to find much in my own searches.

I don't know what happened but yesterday after i restarted my N1, most of my apps on SD Card couldn't seemed anymore! Apps are on the list, on the desktop and on the apps settings (without original icon). But my system doesn't connect apps on my sd card.

My sd card is working correctly, no problem is there. System is seeing sd card, can be mounted/unmounted.

I've tried to restart (ofcourse),
I've tried to launch different launcher,
I've tried to flash CM again.

But nothing works

How can i fix it without wiping? I would wipe but the backup app (mybackup pro) gives an error "Unable to open database file". So i don' wanna wipe without backing up.

Interestingly, some apps on SD works, but it says it can not see SD card. For example, Go SMS app can backup sms to sd card. But it can not see sd card.

Please help me...

Note: I'm using CM 7.0.2.1 (default kernel 2.6.37.4)
____________________________________
I love you Google Nexus One & CM team
 
habs25
Old
#2  
Member
Thanks Meter 2
Posts: 59
Join Date: Dec 2010
Location: Montreal
I had a similar problem recently...what fixed it for me running CHKDSK. Try mounting your sd card, right click on its properties, then go to tools and then error-checking. I checked off both options and ran it. That seems to have fixed my issue, I guess a file was corrupt. Good luck

edit-This is using windows
 
Konusan Balta
Old
#3  
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Feb 2010
Location: Ankara
Thumbs up SD Card was corrupted.

Hi again,

I understand that my SD card was corrupted. I ran chkdsk and it couldn't be completed. It gave an error. I formatted with SDFormatter. No bad sectors or damaged. Finally i had to reinstall all apps again. Not wiped rom.
____________________________________
I love you Google Nexus One & CM team
Tags
apps, error, open, sd card, unable
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes