FORUMS

Introducing Voices of XDA: Have Your Ideas Heard

By far the greatest assets we have at XDA-Developers are you, the developers, the eager … more

Unofficial Xposed For Lollipop Touchwiz With Flashable Zip

XDA Recognized Developer arter97 has released an unofficial build … more

YotaPhone 2 Pre-Order, Xperia Z1 Price Cut – XDA TV

Android Wear 5.1.1 OTA downloads are now available. That and much more news is … more

[FTF] Sony Xperia Z Lollipop Release

Sony rolled out a Lollipop update for Xperia Z just yesterday. If you still haven’t gotten … more
Post Reply Subscribe to Thread Email Thread

How to keep your media files from being deleted off of SDCards

1st May 2011, 11:37 PM |#1  
OP Member
Thanks Meter: 11
 
More
So I searched and searched and never found a definitive answer on how to keep your media files from being automatically deleted off of SDCards on reboots. There were guesses but no report back on what actually worked.

I noticed after it happened about 5 times. You copy files (m4v, mkv, others) to your SDCard and after you reboot they are gone. This happens on Vegan as well as others I had read.

TLDR:
To keep this from happening, in the root of your SDCards (For me /mnt/sdcard and /mnt/sdcard2), create a DIRECTORY called .nomedia You cannot use Windows to do this, you must do it on a linux/unix machine or from iFilemanager,Astro or another file manager type application.

I haven't had trouble since.
The Following User Says Thank You to snowzach For This Useful Post: [ View ]
 
 
2nd May 2011, 05:18 PM |#2  
brettdwagner's Avatar
Senior Member
Thanks Meter: 32
 
More
I have also had success with the .nomedia file placed in directories containing media. However if this .nomedia directory can ward off the indexing for my entire SD card that would be even better.

.nomedia feels like having to smear blood over the door frame so the the angel of death won't take my firstborn. Unleavened bread anyone?
2nd May 2011, 10:57 PM |#3  
OP Member
Thanks Meter: 11
 
More
Several reboots now and no issues.... thank goodness I was about to chuck it through the window...
3rd May 2011, 04:38 AM |#4  
nunjabusiness's Avatar
Senior Member
Thanks Meter: 78
 
More
I still don't understand why some people have this issue. Is it specific to a ROM?

I have a number of AVI files and many folders of MP3s that have been on my SD card since the day I got it (4 months+).
Never had anything delete itself from there. Running VEGAnTab since the 2nd day of ownership.
11th May 2011, 11:24 PM |#5  
Junior Member
Thanks Meter: 0
 
More
I dunno, but it happened to me last night (before I found this thread). Added the directory via eStrong, buried a potato under a stump and tied a chicken foot around my neck for good measure. We'll see what happens.
30th June 2011, 02:56 AM |#6  
Junior Member
Thanks Meter: 0
 
More
Thank you for posting. This solved a major frustration of mine, but it appears to be solved now.
4th July 2011, 05:31 PM |#7  
Junior Member
Flag Lees Summit, MO
Thanks Meter: 0
 
More
My media files went away for the forst time. (I was stock until yesterday.)

I added .nomedia and the files are safe, but my music players and photo viewers cannot find the files now.

Anyway to get them protected but viewable?
5th October 2011, 06:43 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by snowzach

So I searched and searched and never found a definitive answer on how to keep your media files from being automatically deleted off of SDCards on reboots. There were guesses but no report back on what actually worked.

I noticed after it happened about 5 times. You copy files (m4v, mkv, others) to your SDCard and after you reboot they are gone. This happens on Vegan as well as others I had read.

TLDR:
To keep this from happening, in the root of your SDCards (For me /mnt/sdcard and /mnt/sdcard2), create a DIRECTORY called .nomedia You cannot use Windows to do this, you must do it on a linux/unix machine or from iFilemanager,Astro or another file manager type application.

I haven't had trouble since.

How can I creat a DIRECTORY. I used Actro and ifilemanager. I don't know where to input .nomedia. Thanks for your help.

---------- Post added at 06:43 PM ---------- Previous post was at 06:05 PM ----------

It work and thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes