FORUMS

New Xposed for Lollipop 5.0 Update Fixes Major Bugs

Senior Recognized Developer rovo89 has patched Xposed for Lollipop 5.0 to … more

Download Sony’s new AOSP-like concept for Xperia Z3

Over in our forums, Recognized Contributor Jozinek has posted a very … more

OnePlus 2 vs Moto X Style: Which is The Better Flagship?

Two big industry names have announced their newest flagship phones within the … more

Making Your Own Xposed Modules Is Easier Than You Think

Close to the heart of XDA is the Xposed Framework by Rovo89. Most of … more

[Q] Command Prompt Issue When Trying To Exit ADB Shell?

3 posts
Thanks Meter: 0
 
By omgsufc, Junior Member on 2nd May 2011, 06:18 PM
Post Reply Subscribe to Thread Email Thread
Hi this is my first post on the site and i would appreciate it if anyone could help me with this problem. (I know your probably fed up of hearing about rooting problems but anyway!)

I have succesfully installed ADB and as far as i know it seems to be working properley as i can access the ADB shell on my device.

However when i get to a certain stage of the rooting process it all seems to go wrong.

wiki.cyanogenmod.com/index.php?title=HTC_Tattoo:_Full_Update_Guide

I have been using the above rooting guide (can't hyperlink first post!) and i cannot get past stage 7 of the process because the 'exit' command doesnt seem to work in Command Prompt (Windows 7) and it is stopping me from being able to exit the ADB Shell. I have tried other ways of exiting the shell such as ctrl+C but this kills ADB completely and i think that it is undoing the previous steps of the guide.

I do get the message:
uid=0(root) gid=1000(shell) groups=1003(graphics),1004(input),1007(log),1011(a db),1015(sdcard_rw),3001(net_bt_admin),3002(net_bt ),3003(inet)

so i think that i have successfully rooted the device but i cannot proceed to push the 'su' file to the device as i can't exit the adb shell, i just keep getting lists of text saying reboot (-n) (-p) and everytime i use the exit command nothing seems to happen and the flashing # symbol keeps coming back.

Has anybody else had this problem? or have any idea of how to stop the ADB Shell with any other commands other than 'exi't or Ctrl+C?

Cheers.
 
 
2nd May 2011, 09:03 PM |#2  
Senior Member
Thanks Meter: 239
 
More
If device is rooted, by writing in command prompt the command "adb shell", must appear the symbol #, if the symbol $ appears the device isn't rooted.
If you cannot use adb from pc, run on device a terminal emulator(you can find one on market) the above command to see if you're rooted. Then you can give the next commands from terminal emulator(maybe you need to copy the nessecary files on sd card and change the related paths to point to sd card)
2nd May 2011, 10:18 PM |#3  
Junior Member
Flag Funchal
Thanks Meter: 0
 
More
I'm having the exact same problem while rooting my HTC Tattoo (on Windows 7).
I have Android 1.6 (Donut), the baseband is 13.29a.55.13H_3.35.07.33, kernel is 2.6.29-gf922713 and build is 1.67.173.37.
Please help and thanks in advance . I really want to install CyanogenMod 7...
2nd May 2011, 11:12 PM |#4  
OP Junior Member
Thanks Meter: 0
 
More
more info
When i say i have rooted the device i mean temporarily by pushing and changing the 'm7' file, the problem is pushing the 'su' file to the device to make the root permanent.

I do get the # symbol when in ADB Shell but only after changing m7 on the device. As i cannot complete the whole rooting process the # is not there permanently and it returns to the $ symbol.

Thanks for the reply, i will try and do it using a terminal on the device. Do you not need root access to use a terminal app?
Last edited by omgsufc; 2nd May 2011 at 11:19 PM. Reason: typo
3rd May 2011, 04:12 PM |#5  
Junior Member
Thanks Meter: 0
 
More
I'm having the same issue. When I input exit it stucks into that loop and then I got to ctrl+c, and of course the root does not stick
From that point forward I can't do anything else...

If someone overcome the problem please post.
3rd May 2011, 08:57 PM |#6  
Senior Member
Thanks Meter: 239
 
More
I just used this app to root a zte blade with a new greek stock rom:
http://forum.xda-developers.com/showthread.php?t=803682
Seems to work for almost all devices and in first post have some info about root levels and links to a workaround for devices that have some lock which prevents the full rooting.
I didn't tried anythink cause the rooting process was successful, but you can try this app and if still have problems try to follow the instructions given.
Good luck.
3rd May 2011, 10:17 PM |#7  
Junior Member
Thanks Meter: 0
 
More
If you have your mobile rooted can you just use this commands:
cd /data/local/bin/
chmod 755 flash_image
flash_image recovery /sdcard/recovery-clockwork-x.x.x.x-click.img
to perform a recovery flash? Without using the su command?

I don't remember if I tried it, but, if it works I recommend using Androot for rooting the device, it worked for me(checked by Root Checker ).
I'm mentioning this just because you recommended the SuperOneClick app.
7th May 2011, 10:04 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Update:

For all trying to get thing done, follow the instructions on 1Click modified by tenis and flash the latest cyanogenmod.
It worked!!!
7th May 2011, 12:20 PM |#9  
OP Junior Member
Thanks Meter: 0
 
More
I got it to work using androot. Cm7 is awesome

Sent from my HTC click using XDA App
20th August 2011, 12:48 PM |#10  
Member
Flag Thimphu
Thanks Meter: 18
 
More
exit command in adb seems to lock up
like omgsufc, I also reach this stage and can see the message:

uid=0(root) gid=1000(shell) groups=1003(graphics),1004(input),1007(log),1011(a db),1015(sdcard_rw),3001(net_bt_admin),3002(net_bt ),3003(inet)

Again, like omgsufc, when I issue the command:

# exit

ADB shell seems to go into some kind of loop. Pressing ctrl-c or ctrl-d also give the same results. I thus can't go to the next stage. Any help or clues would be greatly appreciated.

I'm on Ubuntu 11.04.

TIA for any help.
26th August 2011, 06:11 AM |#11  
Member
Flag Thimphu
Thanks Meter: 18
 
More
Finally got it to work
No matter what I did, rooting using m7 just didn't work for me (Ubuntu 11.04). Running 'while ./m7 ; do : ; done' got me temporarily rooted as issuing 'id' shows me at 'uid=0(root)'. However, issuing 'exit' just left me in a long loop in the terminal from which it never recovers, and hence I could not complete the root process this way.

So I tried androot, which appeared to root me right away. Issuing 'su' in Android Terminal worked, and doing the same in ADB Shell also gets me to the # prompt. However, issuing the 'flash_image recovery' failed no matter what I did. I tried ROM Manager after this initial androot root: it gives me a success message after flashing ClockworkMod recovery, but when I reboot into recovery it just fails. Fastboot also failed consistently.

Finally, when I tried Terminal Emulator to get root access by issuing the command 'su', it says permission denied, even though Terminal Emulator gave me root access.

So... I unrooted Androot. Again trying to root using m7 I got the same problems as before.

I didn't bother trying flash_image or fastboot and instead tried rooting with androot. After doing so, this time Terminal Emulator allowed root access, which gave me some hope.

So I pulled out ROM Manager again, and woot! My Tattoo is on CyanogenMod 7 and am I a happy camper! I like what Cyanogen has given us: ADW Launcher is as good for me as Sense ever was... actually it's better. And finally I get to use all the new apps I've been wanting to use but wouldn't run on Android 1.6.

So thank you Cyanogen, thank you xda-developers, particularly KalimochoAz, thank you Koushik Dutta for ROM Manager, and thank you, whorever developed androot!
Last edited by kinleyd; 26th August 2011 at 11:16 AM.

Read More
Post Reply Subscribe to Thread

Tags
adb, command prompt, exit, root, shell
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes