Post Reply

[Q] How to Root the Samsung Galaxy Prevail?

OP chinniwhites

4th May 2011, 05:40 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2011
I am a c++ programmer by trade who is just now looking into android phones not only for communication but also for development. I picked up the Samsung Galaxy from Boost Mobile in order to first learn how to root, flash ROMs, and then get into dev.

My first goal is to root the phone so i can use it as a wifi hotspot. I first tried to download quick settings to see if i could get the wifi hopspot that way. I can see the hidden option for wifi hotspot but everytime I press it to turn it on, the phone disables the wifi totally. I then tried z4root, not root. I tried gingerbreak and it did not work. I would try to use superoneclick but cannot find usb drivers that will work with the galaxy prevail while its in usb debugging mode.

Any advice on how to get this phone rooted would great. Can you also list the prevail as one of the device supported on this site to spur development?
4th May 2011, 06:15 PM   |  #2  
Junior Member
Flag Valencia, Ca
Thanks Meter: 1
 
2 posts
Join Date:Joined: Apr 2011
Not sure if you've come across the Prevail source code, the file name is SPH-M820_OpenSource_Froyo.zip

I can not post an actual link because I'm new to this site, but you can find the file here:

opensource dot samsung dot com/reception/reception_main.do?method=reception_search&searchVa lue=m820

replace "dots" with a period
Last edited by dbwelch; 4th May 2011 at 07:32 PM. Reason: typo
The Following User Says Thank You to dbwelch For This Useful Post: [ View ]
6th May 2011, 05:57 AM   |  #3  
Junior Member
Thanks Meter: 6
 
20 posts
Join Date:Joined: Oct 2010
I have not been able to get mine rooted either, but I did find these drivers seem to work for the phone with win7 and xp.

http://dl.dropbox.com/u/12826399/SAM...Phones_x86.exe
The Following User Says Thank You to ibdilbert For This Useful Post: [ View ]
6th May 2011, 06:02 AM   |  #4  
mrkevo3000's Avatar
Senior Member
Flag Seattle
Thanks Meter: 65
 
358 posts
Join Date:Joined: Mar 2010
More
Try Z4root app I think this might work considering there arent any nam locks on this phone go to 4 shared and look for the apk files as this app is no longer available in the market! I have used this app on the following devices, htc hero, sprint zio, samsung moment, droid 1, droid 2, &droid global!
6th May 2011, 04:17 PM   |  #5  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2009
I tried Z4Root it did not work.
7th May 2011, 10:02 PM   |  #6  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Apr 2010
recovery mode
recovery mode is vol up + power

says

Android system recovery (3e)

E:PATH /data/update_sucess
E:Update logfile dose not exsist
#MANUAL MODE#

navigate with vol keys and camera button to select
7th May 2011, 10:10 PM   |  #7  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Apr 2010
z4 root and super one click
i tried z4 and the app closed at acquiring root shell

super one click also failed with psneuter and ginger break

fails at running psneuter and at running gingerbreak

also fail with shell root in same way
7th May 2011, 10:16 PM   |  #8  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Apr 2010
unrevoked
ps the unrevoked roots just do not detect the phone
7th May 2011, 10:30 PM   |  #9  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Apr 2010
odd recover style screen
if you hold down vol + and vol - and camera then tap power a screen comes up that starts with little kernel


vol - and camera makes the phne show "downloading..."


this is shown in windows as "samsung usb compsite device"

and "samsung mobile modem"
7th May 2011, 10:39 PM   |  #10  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Apr 2010
on linux
dmesg output of the "downloading..." screen

[ 77.031415] usb 1-1: USB disconnect, address 2
[ 84.590135] usb 1-1: new high speed USB device using ehci_hcd and address 3
[ 84.748548] cdc_acm 1-1:2.0: This device cannot do calls on its own. It is not a modem.
[ 84.748762] cdc_acm 1-1:2.0: ttyACM0: USB ACM device
********-laptop:~$

The Following User Says Thank You to themonkeymixer For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank