Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,422 Members 43,337 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia Play not recognised by computer via usb [solved]

Tip us?
 
jdz7t8
Old
(Last edited by jdz7t8; 10th May 2011 at 07:13 PM.)
#1  
Senior Member - OP
Thanks Meter 6
Posts: 337
Join Date: May 2011
Default [Q] Xperia Play not recognised by computer via usb [solved]

Could someone help me? I plug the usb in and it says driver not installed properly. The is the Xperia play. It is rooted with the latest gingerbreak.
Update: Solved
Looks like there was a problem with the driver, so I manually uninstalled the drivers via "Device and Printers" in the start menu, then I restarted my computer. Then I plugged in my phone and this time it said installing Xperia Play instead of what it was doing before, which was installing some other driver, I don't remember what it came up as initially, but it wasn't recognizing it as the Xperia Play. Now it is. That's it folks.
 
Dousan
Old
#2  
Dousan's Avatar
Senior Member
Thanks Meter 189
Posts: 676
Join Date: Aug 2010
Location: Copenhagen
Nice to hear mate Could you also update the thread tittle to solved and maybe say how you solved it, that might help others?

Regards Dousan...
Galaxy Note 3

What you give is what you receive
 
AndroHero
Old
#3  
AndroHero's Avatar
Senior Member
Thanks Meter 904
Posts: 6,472
Join Date: May 2010
Location: Manchester
If you solve somthing you should post your solution, so you can help other people with the same problem

Sent from my Xperia Play using Tapatalk
------------------------------------------------------------
My Device
HTC Sensation XL
Rom Version - 3 Musketeers Insanely Cool Sense v2.2.1
Baseband - 10.10.12_M
Kernel - 2.6.35.13



 
DeadlyDazza
Old
#4  
DeadlyDazza's Avatar
Senior Member
Thanks Meter 78
Posts: 624
Join Date: Jul 2010
He'll be back when the next thing goes wrong !
 
Strife182
Old
#5  
Member
Thanks Meter 7
Posts: 52
Join Date: Mar 2012
Sorry for the necro-bump but I'm having the same issue. Phone was working ok and was able to connect to pc but then I uninstalled a PSXperia game and rebooted the phone, after that the MTP driver no longer works, I'm only able to connect via MSC.
- Tried the solution above with no luck
- Tried connectin the phone in another PC and i get the same error.
- Downloaded the PC Companion app from Sony and selected the "How to connect" option. It tried to install the drivers but got a message saying "An error in the communication between your phone and computer was discovered"

Any help will be greatly appreciated.
 
dassub
Old
#6  
dassub's Avatar
Senior Member
Thanks Meter 14
Posts: 217
Join Date: May 2011
Location: Toronto
Usually mine takes a few minutes before it will connect in Media Transfer Mode. Yes, you heard it right, a few MINUTES! But eventually, if it's been too long, I unplug it and try again. It usually connects if you simply just wait (way too) long enough.
The Following User Says Thank You to dassub For This Useful Post: [ Click to Expand ]
 
Strife182
Old
#7  
Member
Thanks Meter 7
Posts: 52
Join Date: Mar 2012
Well I managed to get it working again by using the Sony companion software, it reinstalled everything back as it was when I got it. I made a backup but first I'm going to see if rooting the phone had something to do with it.

Sent from my R800a using XDA

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes