Post Reply

BackTrack 5 for Android Smartphones - VERY UNSTABLE

OP msullivan

15th May 2011, 09:15 AM   |  #1  
OP Senior Member
Iowa
Thanks Meter: 57
 
252 posts
Join Date:Joined: Aug 2008
More
WARNING: THIS IS NOT FOR THE FAINT OF HEART
UPDATE: My goal was to create a version of BackTrack 5 for ARM that was easy to use and install. As of this time, that IS NOT the case! The versions posted here are **probably not** going to work straight out of the box. If you know what you are doing in a Linux environment, you'll probably be able to get it working.

Because of this, the project is currently completely unsupported. You are free to dive in, but you are doing so with no support for me, and I'm not liable for any damage that might be done to your device's ROM.

I encourage you to pass this up unless you know what you are getting yourself into!



If you were referred here from the XDA-Developers.com article...
Hi there! Let's get one thing on the record here... this is *not* a native client! This is the chroot + VNC method that we'd been using to get Ubuntu running with Android for a while. The article makes it sound like that's the case, but sadly it's not. However, with the chroot + VNC method we can really run BackTrack 5 on an Android device, and it really does work. This takes some technical skills, and isn't for the non-Linux experienced user.

Requires a rooted device!

BackTrack 5 installation guides are making their way around this forum. I've tried to synthesize it all, but I've also added my own touches to help with usability and features, along with a workaround for the "ioctl LOOP_SET_FD failed" error message some people have been getting.

In theory this build is nearly universal, so if you have an Android device it should work. I've put it all in one zip file that you can download directly from my website, no hassles or wait timers.

If you are interested have a look, feel free to re-post. Credit goes to the BackTrack team and xda member anantshri (he's got skills, give him props guys), who built the base image file.

Information, download link, and installation guide at:
(SERVER OFFLINE, SEE BELOW)

If you like what you see help me out, hosting is expensive!
http://www.mattslifebytes.com/donate
(alternatively, you can show interest in the products and services featured on my website, if you know what I mean :P)

Quote:
Originally Posted by msullivan

If you don't know what BackTrack is, you probably don't want it

BackTrack is an operating system based on Ubuntu Linux that is used for security testing (aka hacking) and digital forensics. I'm a master's degree student in computer security, so I love this OS... it can do awesome things. Turn on your Wi-Fi and you can do advanced network scans and tests right from your phone, no laptop required. For me this is hella-useful.

But besides just being an OS for hacking ****, it's also fully Ubuntu-based, so you can run it like a desktop, including running Firefox and other Linux applications.

Well guys my server had hardware failure (lol, my luck), so here's the website's content:
Quote:
Originally Posted by msullivan

The Download

This installation of BackTrack 5 is available as a compressed file that will need to be extracted. I recommend downloading this using Chrome or Firefox. Internet Explorer often doesn’t play well with large HTTP downloads.

The root account’s password and the VNC server password are both set to ‘root’ by default!

Mirror 1


Mirror 2
Mirror 3 (Provided by shenshang)
Mirror 4 (Provided by brilldoctor)
Mirror 5 (Thanks for uploading, PIIcoding)
The Description

If you want to run BackTrack 5 on your Android-powered device, read on, you’re in the right place! So the big news is that BackTrack 5 runs on Android phones. We’ve been able to run Ubuntu on these devices for quite some time too, but admittedly BackTrack on a smartphone is just awesome.

Anyway, files for using BackTrack 5 on an Android phone have been running around the internet, but sadly it’s kind of a mish-mash of links saying, “go download this, then get this, to then this, blah blah blah”. Too confusing for my simple brain, so I’ve rounded it all up and posted it in one place… right here. The version posted here has everything you should need to run BackTrack 5 on your Android device. I’ve also added a lot of goodies to help with the user experience that the other offerings don’t include:
  • Works around the ioctl LOOP_SET_FD failed error that many people have been receiving on Galaxy S devices (and others)
  • Asks the user if they want a VNC session upon start-up
  • Starts the SSH service automatically and displays device IP on start-up
  • Enables the Ubuntu repositories to Aptitude, so you can do package installation
  • Adds vim. Really, what distribution doesn’t come with vim by default? Seriously…
  • Sets the screen resolution to 800×480 default (should be compatible with most smartphone devices)

SU
This requires root!
You must be able to "su" at terminal. This ability is usually provided by software for rooting your phone. To see if you have rooted your phone correctly and it's working, go to your terminal emulator and type "su" <enter>. If it is working, you'll probably get a prompt asking you if you want to allow your terminal emulator root access. Hit accept/yes. Now you'll be back in your terminal emulator. Type "whoami" <enter>. If it responds with "root" or "uid 0", then you are properly rooted.

Busybox
This requires Busybox!
I am no longer providing an installer for Busybox because of issues getting it to work universally, so instead YOU need to go get a working build and install it (I believe "Busybox Installer" will work, but not tested). If you want to know if you have Busybox and it's working, go to your terminal emulator and type "su" <enter>, then "busybox ls" <enter>. If you get a printout of all the files in your current directory, then your Busybox will likely work with BackTrack 5 just fine. If you get an error, "busybox: not found", that means you either do not have Busybox, or it is not properly installed.

WARNING FOR CyanogenMod USERS
Before doing ANYTHING, please test for ext2 support by running (as root, at terminal) --> "modprobe ext2" <enter>

If this fails probably your device lacks ext2 support and the whole thing will screw up if you try to run it! Support for ext2 in CM is being worked on.


The Installation Guide
  • Enable Wi-Fi and connect to a Wi-Fi access point (* not required, but BT5 cannot use your data plan for internet access)
  • Download the zip file, extract anywhere
  • After extraction you’ll have one folder “bt5″; copy this folder to the root of your phone’s SD Card
  • Put card back in phone and/or unplug from USB
  • In a terminal emulator, type “su” <enter>, “cd /sdcard/bt5″ <enter>
  • Now you are ready to rock and roll, so issue “sh bt” <enter> (in the future to start BT5 skip the line above and come straight to this command)
  • If all is well you’ll now be running BackTrack 5 on your Android device; you can SSH to it via Wi-Fi (password ‘root’), or access it from VNC if you said “Yes” to the prompt asking if you wanted a VNC session
  • To get a GUI for BackTrack on your smartphone’s screen, download a VNC viewer from the market (many are free), then connect to host “127.0.0.1″, port “5901″, password “root”

Enjoy, boys and girls.

The Credits

The BackTrack 5 Development Team
anantshri on xda-developers (his blog: http://blog.anantshri.info/) for creating the image file to fit FAT32 filesystems
anantshi's original thread where it all began: http://forum.xda-developers.com/show....php?t=1074169

Known Incompatibility
  • Voodoo lagfix kernel (possibly? reported, not confirmed)
Last edited by msullivan; 18th May 2011 at 09:56 PM.
The Following 45 Users Say Thank You to msullivan For This Useful Post: [ View ]
15th May 2011, 09:15 PM   |  #2  
Member
Thanks Meter: 4
 
95 posts
Join Date:Joined: Aug 2010
Hi thanks for the great work, I try it on my HTC WildFire with CyanogenMod7 2.3 CFW
this what i got when try it install it from the terminal:

Quote:

$ su
# id
uid=0(root) guid=0(root)
#
# cd /sdcard/bt5
# sh installbusybox
installbusybox: 14: Syntax error: end of file unexpected (expecting "fi")
#
# sh bt
bt: 36: Syntex error: end of file unexpected (expecting "then")
#

15th May 2011, 09:23 PM   |  #3  
OP Senior Member
Iowa
Thanks Meter: 57
 
252 posts
Join Date:Joined: Aug 2008
More
Which terminal emulator are you using?
15th May 2011, 09:27 PM   |  #4  
Member
Thanks Meter: 4
 
95 posts
Join Date:Joined: Aug 2010
Terminal emulator
15th May 2011, 09:35 PM   |  #5  
OP Senior Member
Iowa
Thanks Meter: 57
 
252 posts
Join Date:Joined: Aug 2008
More
Open up "installbusybox" in a text editor and axe the first two lines, then try again.
15th May 2011, 09:47 PM   |  #6  
OP Senior Member
Iowa
Thanks Meter: 57
 
252 posts
Join Date:Joined: Aug 2008
More
Hrm... I failed when packaging the version that got put up online (sorry). I'm fixing now, will update shortly.
15th May 2011, 09:55 PM   |  #7  
Member
Thanks Meter: 4
 
95 posts
Join Date:Joined: Aug 2010
ok i remove the first two lines, and i got:

Quote:

# sh installbusybox
BeginningBusyBox installation...
mount: mounting /dev/block/mtdbloc faild: No such file or directory
/sdcard/busybox: No such file or directory
cd:can't cd to /data/local
installbusybox: ./busybox: permission denied
cd:can't cd to /system/xbin
: No such file or directory
installbusybox: ./busybox: permission denied
If there were no error messages given above then installation was successfull
#

not sure why when i try to chmod 755 busybox nothing change!
15th May 2011, 09:56 PM   |  #8  
Member
Thanks Meter: 4
 
95 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by msullivan

Hrm... I failed when packaging the version that got put up online (sorry). I'm fixing now, will update shortly.

aha, ok thanks again
15th May 2011, 09:57 PM   |  #9  
Senior Member
Great country of Texas
Thanks Meter: 2,369
 
12,972 posts
Join Date:Joined: Nov 2009
More
Awesome.

Sent from a super smooth captivate running andromeda
15th May 2011, 11:10 PM   |  #10  
Old news...

Btw.. if you're having problems, migrate apps from SDCard to Internal memory.

edit: Just realized this came off kinda dick-like... So here http://forum.xda-developers.com/show...&postcount=109
Last edited by AdamOutler; 18th May 2011 at 10:25 PM.

The Following 2 Users Say Thank You to AdamOutler For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
back, backtrack, security, track, ubuntu
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes