5,599,842 Members 46,470 Now Online
XDA Developers Android and Mobile Development Forum

Guide Wifi Ad Hoc Working Samsung 10.1v

Tip us?
 
drnackers
Old
#1  
Junior Member - OP
Thanks Meter 7
Posts: 5
Join Date: Mar 2008
Default Guide Wifi Ad Hoc Working Samsung 10.1v

Hi Guys,

I have just gotten Wifi Ad Hoc connection working in the Samsung 10.1v (don't see why it won't work on the 10.1 either)

You need to have adb installed and your Tablet needs to be rooted.

I used 2 threads as reference for making this work:
http://forum.xda-developers.com/show....php?t=1069569

and
http://forum.xda-developers.com/show....php?t=1033314

As a newbie to this i will show you what i did, maybe someone can clean up the process with a simple approach:

You need to turn on Airplane mode to disable wifi, or you will get an error when trying to copy the wpa_supplicant file later on in the instructions...

I had trouble with the adb push command (shown in the above threads) so I did this instead.
Unzip and copy wpa_supplicant file (attached) to Tablet (I used downloads directory)

Get ES File Explorer from Market
Open ES File Explorer and in settings menu select Root options.
Set Root Explorer and use HiAPK
Then Tick Mount File System, then exit menu and navigate to /system/bin and copy wpa_supplicant to somewhere safe (I made backup directory in storage/ sd memory)
Now copy new wpa_supplicant file from where you saved it (downloads directory) to /system/bin

Now in windows command box type:
adb shell
# su
# mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
# chmod 755 /system/bin/wpa_supplicant
# chown system.wifi /data/misc/wifi/wpa_supplicant.conf
# exit

Now reboot and turn off airplane mode and enjoy.

Usual conditions if you follow this and something bad happens please don't blame me i used the above method (with trial and error) which worked for me (but maybe i just got lucky)
Also I want to acknowledge the hard working devs that pioneered the process and created the file - great work!!

Good luck...
Attached Files
File Type: zip wpa_supplicant_wifi_adhoc.zip - [Click for QR Code] (161.0 KB, 4334 views)
The Following 7 Users Say Thank You to drnackers For This Useful Post: [ Click to Expand ]
 
laoya
Old
#2  
Member
Thanks Meter 0
Posts: 38
Join Date: Mar 2011
Location: Zhengzhou
Quote:
Originally Posted by drnackers View Post
Hi Guys,

I have just gotten Wifi Ad Hoc connection working in the Samsung 10.1v (don't see why it won't work on the 10.1 either)

You need to have adb installed and your Tablet needs to be rooted.

I used 2 threads as reference for making this work:
http://forum.xda-developers.com/show....php?t=1069569

and
http://forum.xda-developers.com/show....php?t=1033314

As a newbie to this i will show you what i did, maybe someone can clean up the process with a simple approach:

You need to turn on Airplane mode to disable wifi, or you will get an error when trying to copy the wpa_supplicant file later on in the instructions...

I had trouble with the adb push command (shown in the above threads) so I did this instead.
Unzip and copy wpa_supplicant file (attached) to Tablet (I used downloads directory)

Get ES File Explorer from Market
Open ES File Explorer and in settings menu select Root options.
Set Root Explorer and use HiAPK
Then Tick Mount File System, then exit menu and navigate to /system/bin and copy wpa_supplicant to somewhere safe (I made backup directory in storage/ sd memory)
Now copy new wpa_supplicant file from where you saved it (downloads directory) to /system/bin

Now in windows command box type:
adb shell
# su
# mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
# chmod 755 /system/bin/wpa_supplicant
# chown system.wifi /data/misc/wifi/wpa_supplicant.conf
# exit

Now reboot and turn off airplane mode and enjoy.

Usual conditions if you follow this and something bad happens please don't blame me i used the above method (with trial and error) which worked for me (but maybe i just got lucky)
Also I want to acknowledge the hard working devs that pioneered the process and created the file - great work!!

Good luck...
what about the usage of battery after install that wpa_supplicant.conf

Because i used to transfer a similar file like wpa_supplicant.conf to help my samsung Galaxy S i9000 to connect the adhoc WIFI. The usage of battery is horrible, I charged my phone whole night and there is no more battery remaining next morning
 
drnackers
Old
#3  
Junior Member - OP
Thanks Meter 7
Posts: 5
Join Date: Mar 2008
I will keep you posted, but been using it on ad hoc for a couple of hours now and nothing out of the usual. Battery seems just same as on wifi.

I will leave it on overnight and report back tomorrow



Sent from my GT-P7100 using XDA App
 
drnackers
Old
#4  
Junior Member - OP
Thanks Meter 7
Posts: 5
Join Date: Mar 2008
OK well it has been connected all night to Xperia x10 running barnacle no issues downloading through swarm bittorrent client.

Battery was 78% now at 58% so I would see this as acceptable.

Only 1 issue I have noticed, every time you connect to ad hoc it asks for password and adds it as new connection, so you end up with a few in the list but hold on old connections and 'forget' works fine

Sent from my GT-P7100 using XDA App
 
laoya
Old
#5  
Member
Thanks Meter 0
Posts: 38
Join Date: Mar 2011
Location: Zhengzhou
Quote:
Originally Posted by drnackers View Post
OK well it has been connected all night to Xperia x10 running barnacle no issues downloading through swarm bittorrent client.

Battery was 78% now at 58% so I would see this as acceptable.

Only 1 issue I have noticed, every time you connect to ad hoc it asks for password and adds it as new connection, so you end up with a few in the list but hold on old connections and 'forget' works fine

Sent from my GT-P7100 using XDA App
woooo! Wonderful!

I had used the ad hoc wifi and knew that issue already. Anyway, thank you for remining!!

Maybe something should do with the usage of battery, because there is 20% drop during the whole night.........

well, in that case, my cellphone cannot tolerate it
 
chesterchen
Old
#6  
chesterchen's Avatar
Member
Thanks Meter 11
Posts: 97
Join Date: Feb 2005
just installed the JuiceDefender app on my 10.1v.

before that, the wifi/3G standby overnight will consume about 10% of battery.

after installing it, and the night more, it went down by 4%.

2nd day of using it and battery life SEEMS better.
 
rs125
Old
#7  
rs125's Avatar
Senior Member
Thanks Meter 297
Posts: 1,166
Join Date: Oct 2007
Location: Curinga, Calabria

 
DONATE TO ME
I created a zip flashabile on recovery, we'll post it and put it in the first thread?


Rs GingerX and PureGoogle for DHD

GingerBread 2.3.3 and Sense 2.1

Rs Xtreme Series ITA for Blackstone and Topaz
Rs GingerX, Sensation, PureGoogle and Sensation S for Desire DH
Rs HDBlog Galaxy Series fot Samsung Galaxy Tab 10.1v
 
DroidHam
Old
#8  
DroidHam's Avatar
Senior Member
Thanks Meter 150
Posts: 2,178
Join Date: Aug 2010
Location: Akron, OH
Anyone try this on 10.1?
 
rs125
Old
#9  
rs125's Avatar
Senior Member
Thanks Meter 297
Posts: 1,166
Join Date: Oct 2007
Location: Curinga, Calabria

 
DONATE TO ME
Quote:
Originally Posted by DroidHam View Post
Anyone try this on 10.1?
I haven't tried but it works


Rs GingerX and PureGoogle for DHD

GingerBread 2.3.3 and Sense 2.1

Rs Xtreme Series ITA for Blackstone and Topaz
Rs GingerX, Sensation, PureGoogle and Sensation S for Desire DH
Rs HDBlog Galaxy Series fot Samsung Galaxy Tab 10.1v
 
baggenismo
Old
#10  
Junior Member
Thanks Meter 0
Posts: 20
Join Date: Feb 2011
I cant seem to get it working right...
After following these steps my wifi drops every 10 seconds... It will see the adhoc though ;-D
I have to disable wifi and re-enable then it will auto join a network for another 10sec before it drops. any advice?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes