FORUMS

What Do You Think About Fingerprint Scanners?

More and more phones are featuring fingerprint scanners, and with many promising … more

What’s Next for Samsung and Its Flagships?

If we were to say that the Galaxy S6 was a leap of faith made by Samsung, we … more

The Ultimate Showcase of dBrand Skins

In the search for ways to protect, accessorize, and personalize; a user has many options. One … more

Huawei’s Rapid Rise to Third Place in the Smartphone Race

Huawei has quickly grown to become one of the world’s biggest … more

Guide Wifi Ad Hoc Working Samsung 10.1v

5 posts
Thanks Meter: 7
 
By drnackers, Junior Member on 17th May 2011, 12:14 PM
Post Reply Subscribe to Thread Email Thread
27th June 2011, 03:57 AM |#11  
Junior Member
Thanks Meter: 3
 
More
I used adb and it worked "MAKE SURE THAT YOU LOCK THE PERMISSION with CHMOD 755 or it will not work"

put the tablet in airplane mode
I download the file put into C:\ of desk top
I had backup my original by using adb pull /system/bin/wpa_supplicant
these are commands and responses

>adb shell
root@android:/ # su
su
root@android:/ # mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
root@android:/ # chmod 777 /system
chmod 777 /system
root@android:/ # chmod 777 /system/bin
chmod 777 /system/bin
root@android:/ # chmod 777 /system/bin/wpa_supplicant
chmod 777 /system/bin/wpa_supplicant
root@android:/ # exit
exit
root@android:/ # exit
exit

>adb push c:\wpa_supplicant /system/bin/wpa_supplicant
1267 KB/s (295964 bytes in 0.228s)

>adb shell
root@android:/ # su
su
root@android:/ # mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
root@android:/ # chmod 755 /system/bin/wpa_supplicant
chmod 755 /system/bin/wpa_supplicant
root@android:/ # chmod 755 /system/bin
chmod 755 /system/bin
root@android:/ # chmod 755 /system
chmod 755 /system
root@android:/ # exit
exit
root@android:/ # exit
exit
Last edited by nick7920; 27th June 2011 at 05:32 AM.
The Following 2 Users Say Thank You to nick7920 For This Useful Post: [ View ]
 
 
27th June 2011, 06:05 PM |#12  
makbil's Avatar
Senior Member
Flag Bodrum
Thanks Meter: 1,502
 
More
Tried the flashable zip using cwm 4.0.0.4 but I keep getting installation not successful message. The installation starts, file is opened but the result is unsuccessful. Any suggestions?
10.1v /unlocked / rooted / cwm 4.0.0.4

Edit: Just saw the manual push method above. It will just be so much easier if the flashable version would work.
Last edited by makbil; 27th June 2011 at 06:07 PM.
28th June 2011, 03:13 AM |#13  
Junior Member
Thanks Meter: 0
 
More
pushed to system/bin w/ root explorer and edited permissions with RE too.

works so far on my 10.1 retail rooted
29th June 2011, 03:15 PM |#14  
makbil's Avatar
Senior Member
Flag Bodrum
Thanks Meter: 1,502
 
More
Quote:
Originally Posted by nick7920

1267 KB/s (295964 bytes in 0.228s)


Works perfectly. The only thing different is the file size reported. Typo?
1762 KB/s (295964 bytes in 0.164s)
29th June 2011, 03:37 PM |#15  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by baggenismo

I cant seem to get it working right...
After following these steps my wifi drops every 10 seconds... It will see the adhoc though ;-D
I have to disable wifi and re-enable then it will auto join a network for another 10sec before it drops. any advice?

I have exactly the same issue. I did this same procedure on my galaxy tab (the original 7" one) and it worked great. Replacing the wpa_supplicant file on my galaxy tab 10.1 has the connections work for 10 seconds and then drop. Incidently, I find this is true for all connections (ad-hoc and regular). Switching back to the original file fixes this. I've played around with the config file in /data/mis/wifi/wpa_supplicant.conf and added ap_scan=1, but I've had no luck. I have the 16 GB retail version. My version also had a locked bootloader. Any suggestions would be most appreciated.

Thanks,

Ben
29th June 2011, 04:54 PM |#16  
makbil's Avatar
Senior Member
Flag Bodrum
Thanks Meter: 1,502
 
More
I don't seem to have this problem of wi-fi disconnecting on my 10.1v. So far working perfectly with Connectify, even when the device has screen off, connection seems to persist - I did select never switch to mobile data from settings. I don't know how long it will stay connected though, haven't done a time test yet.
29th June 2011, 05:20 PM |#17  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by makbil

I don't seem to have this problem of wi-fi disconnecting on my 10.1v. So far working perfectly with Connectify, even when the device has screen off, connection seems to persist - I did select never switch to mobile data from settings. I don't know how long it will stay connected though, haven't done a time test yet.

My tablet is wifi only. Perhaps this is the issue. Has anyone gotten this to work who has a wifi only tablet (retail edition)?
29th June 2011, 06:18 PM |#18  
Member
Flag Tokyo
Thanks Meter: 11
 
More
does not work...
29th June 2011, 06:59 PM |#19  
makbil's Avatar
Senior Member
Flag Bodrum
Thanks Meter: 1,502
 
More
Left the tablet aside for an hour. I unlocked the screen, and instantly opened the web browser. The connection was working. So maybe it does have something to do with 3G connection even though it is turned off. I am using Connectify (free version) on my notebook.
29th June 2011, 11:24 PM |#20  
Junior Member
Thanks Meter: 0
 
More
Just thought of something. I have juicedefender set to turn off 3g when my phones screen turns off. This could cut connectivity without dropping wifi signal. Will test theory tomorrow...

Sent from my Galaxy Tab 10.1 using Tapatalk.
30th June 2011, 01:39 AM |#21  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by mattXdezzi

Just thought of something. I have juicedefender set to turn off 3g when my phones screen turns off. This could cut connectivity without dropping wifi signal. Will test theory tomorrow...

I don't think so. I'm not running JuiceDefender or any other task killer/battery saver. Plus, this is the wifi only version so there isn't a 3g to kill.

I have tried looking at the details of the /dev/main log
cat /dev/log/main | grep wpa
but I don't see anything obvious. To me it looks like there is some type of failure that puts it back into scanning mode.

The original version of wpa_supplicant is version 0.6.10. I don't know if a new version of this must be patched to work right. If someone has a non-wifi only version of the system and can get the version number of their original wpa_supplicant file this might yield some information.

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes