FORUMS

CloudPlayer: DIY HiFi Music Streaming Solution

In our Helpful Guide to Music Streaming Services, we mentioned several different services … more

Optimize Battery Life with This Useful App

Battery life is an important aspect of your smartphone, especially if you use it for more … more

The OnePlus 2 & The Year of Smartphone Compromises

We are very close to entering the last third of 2015, and we have now seen many of … more

OnePlus 2 Teardown, Major Android Vulnerability – XDA TV

The OnePlus 2 has been officially released. That and much more news is … more

[GUIDE] Enable ad-hoc tethering on your Transformer (needs root!)

1,311 posts
Thanks Meter: 291
 
By qwer23, Senior Member on 24th May 2011, 08:35 AM
Thread Closed Subscribe to Thread Email Thread
Update: If you are using the official firmware 8.6.5.9 (and obviously above) or any custom ROM based on it, you don't have to do anythink described here, because ad-hoc works natively. Thankfully ASUS fixed Googles unintelligible inability to enable connection to ad-hoc networks.

This renders this thread pretty much obsolete, but I won't delete it, just in case anyone doesn't want to or cannot update his device for whatever reason



Quote:

Hi!

As there are only [Q]uestion threads about ad-hoc tethering by now, I thought I'd write a little guide how to enable it on our Transformer.


edit: If you are using Prime v1.5 (and above I guess), you don't have to do this. Roach2010 already included the modified wpa_supplicant, so you can already use ad-hoc tethering.




All credits and many thanks go to szym for the edited wpa_supplicant that makes ad-hoc possible for us!


!!! Always make a nandroid backup via recovery first! You can then reflash your backup if something fails !!!


I. Via root explorer (obviously requires root access):

If you bought root explorer from the market, you should be able to easily copy and replace the file.

1.) Go to /system/bin and copy the file „wpa_supplicant“ to your sd card as a backup.
2.) Then copy the „wpa_supplicant“ from the attached zip file and paste it into /system/bin.
3.) Long press the file and set permissions to rwxr-xr-x, like this:

User: read, write, execute
Group: read, execute
Others: read, execute

4.) Reboot

Finally tried it myself and works fine



II. Alternative method via adb (requires root access):

This is a forwarded guide from the Xoom section. I tried it myself and it works like a charm. You can find it here.


All credits for the following guide go to kelvie !

1.) Your Transformer has to be rooted! (you'll find a guide how to root here)
2.) Make a backup of your system/bin/wpa_supplicant first!
3.) Unpack the attached wpa_supplicant_xoom_wifi_adhoc.zip file to your adb folder. (if you don't know how to use adb, google for one of the many guides, or look below for another option via root explorer )
4.) push the file to system/bin/wpa_supplicant:

Code:
adb remount
adb push system/bin/wpa_supplicant /system/bin/wpa_supplicant
5.) Because zipfiles don't store permission, you have to make it executable as well:
Code:
adb shell chmod 755 /system/bin/wpa_supplicant
6.) You also have to change the permissions on /data/misc/wifi/wpa_supplicant.conf for some reason:
Code:
adb shell chown system.wifi /data/misc/wifi/wpa_supplicant.conf
7.) reboot


Again, many thanks to kelvie for the guide!


III. Easiest method (requires ClockWorkMod recovery and root):

1.)Download the attached CWM_adhoc_wpa_supplicant_TF101.zip to your sd-card. Make sure to copy it to /Removable/MicroSD, because /mnt/sdcard cannot be accessed from CWM
2.) Boot into CWM recovery.
3.) Hit "install zip from sdcard" --> "choose zip from sdcard", select the zip and confirm.
4.) Reboot

Done. You should now be able to tether your ad-hoc connection


This method doesn't seem to work because I missed an option and don't know right now how to fix it. So if somebody knows how to do this via edify script, please help me out:
Code:
chown system.wifi /data/misc/wifi/wpa_supplicant.conf

Use one of the methods above in the meantime, they works flawless.



__________________________________________________

Q&A

Q: Which app should I use for tethering on my phone? Do I need root access for tethering apps?

A: If your phone doesn't support native tethering, just search the Android Market for 'Wifi tether'. There are a lot of apps for that . I tested Barnacle Wifi Tether on my Sony Ericsson Xperia X10 with 2.3.4 MIUI ROM, which worked fine, but I guess all/most tether apps should work fine now. And yes, unless you have native tethering, your phone has to be rooted.

Q: Barnacle gives me the following error on the phone: "DHCP could not bind to DHCP port, address already in use", and my TF is stuck at "obtaining IP Address from barnacle". What should I do?

A: rpavich has found a solution for that. Thanks rpavich!
Quote:
Originally Posted by rpavich

1. Change SSID to whatever you want
2. Change Channel to 6
3. Custom Wifi Ad-hoc to none
4. Skip wpa_supplicant checked
5. Restart your phone (just to make sure...)

__________________________________________________


Regards
qwer23

Edit: I wasn't sure if this belongs in General or Android Dev section, so mods feel free to move it where it fits best.

Edit2: Attached original wpa_supplicant files for 3.0 and 3.1 (don't know if there's a difference, but I doubt it) if someone wants to reset to stock.




If you find this guide helpful, consider pressing the thanks button

Last edited by qwer23; 23rd August 2011 at 09:28 PM.
The Following 26 Users Say Thank You to qwer23 For This Useful Post: [ View ]
 
 
24th May 2011, 09:27 AM |#2  
Junior Member
Thanks Meter: 2
 
More
awesome. a few more working confirmation from the others and i wont have to kiss my nokia e71 goodbye
24th May 2011, 08:33 PM |#3  
qwer23's Avatar
OP Senior Member
Flag Realm of Württemberg
Thanks Meter: 291
 
More
Quote:
Originally Posted by philsuf

awesome. a few more working confirmation from the others and i wont have to kiss my nokia e71 goodbye

No need to wait, you could just try it. If you back up your original wpa_supplicant first, you can always undo your changes. I also added an easier way via root explorer that should be easier.
24th May 2011, 11:40 PM |#4  
Senior Member
Thanks Meter: 3
 
More
i just tried it, it connected to barnacle wifi but i couldnt get the internet to work. ill try again tomorrow, it may be my phone.
24th May 2011, 11:49 PM |#5  
qwer23's Avatar
OP Senior Member
Flag Realm of Württemberg
Thanks Meter: 291
 
More
Quote:
Originally Posted by Skeldave

i just tried it, it connected to barnacle wifi but i couldnt get the internet to work. ill try again tomorrow, it may be my phone.

Did your phone show the barnacle symbol in the notification bar and tell you that a device is connected?

Sent from my rooted X10i using awesome custom roms
24th May 2011, 11:54 PM |#6  
Senior Member
Thanks Meter: 13
 
More
I've done this last week and noticed when stopping my hotspot on the phone the connection on the transformer shows it is still connected. So you have to manual disconnect if you want to reconnect again for later use. This is on my Nokia N8 Phone using JoikuSpot.
25th May 2011, 12:12 PM |#7  
Senior Member
Thanks Meter: 56
 
More
I tried to do this via the root explorer and it said "you cannot paste here because the file system is read only"
25th May 2011, 12:25 PM |#8  
qwer23's Avatar
OP Senior Member
Flag Realm of Württemberg
Thanks Meter: 291
 
More
Quote:
Originally Posted by rpavich

I tried to do this via the root explorer and it said "you cannot paste here because the file system is read only"

On the top of your system directory in root explorer is a button, that says r/w. Push it and you'll get read/write mode.

Sent from my rooted X10i using awesome custom roms
25th May 2011, 12:53 PM |#9  
Senior Member
Thanks Meter: 56
 
More
thank you VERY much....I'll let you know how my tethering goes.
25th May 2011, 01:34 PM |#10  
Senior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by qwer23

Did your phone show the barnacle symbol in the notification bar and tell you that a device is connected?

Sent from my rooted X10i using awesome custom roms

Yes, the barnacle symbol was in the notification bar and my TF appeared on the 'client' tab, also the TF said that it was connected to barnacle wifi.

I'm going to try again now

EDIT: Worked perfectly this morning, thanks!

I did it via root explorer FYI
Last edited by Skeldave; 25th May 2011 at 01:39 PM.
25th May 2011, 01:54 PM |#11  
Senior Member
Thanks Meter: 11
 
More
This seems like a rather minor change to wpa_suppliant.conf; any clue if google will fix this in honeycomb? Not sure I understand why it isn't enabled by default...

Read More
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes