5,595,000 Members 39,000 Now Online
XDA Developers Android and Mobile Development Forum

[TUTORIAL]How to make your own boot animations (with sound if you want)

Tip us?
 
spotrevoc
Old
#831  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Sep 2013
Default does this work with desc.txt?

Does the bootsound method work with sounds set in desc.txt within bootanimation.zip?
 
despotovski01
Old
#832  
despotovski01's Avatar
Recognized Developer - OP
Thanks Meter 1765
Posts: 1,441
Join Date: Jan 2011
Quote:
Originally Posted by spotrevoc View Post
Does the bootsound method work with sounds set in desc.txt within bootanimation.zip?
I don't think so. I might be wrong though, so try it.

Sent from my Evo 3D GSM using Tapatalk 4
"If you think you can, therefore, you can." - Unknown
"A journey of a thousand miles begins with a single step." - Confucius
"Question everything." - Einstein

"Don't let anyone tell you what you can't do."

My work:
Android Ultimate Toolbox Pro Updated as of 4.5.2013
Boot Animation Factory Updated as of 1.6.2013
Boot Animation Creator Obsolete
Boot Animation Previewer Obsolete

Devices:
LG G2 D802 16GB: Android 4.2.2 Jellybean (stock)
HTC EVO 3D: CyanogenMod 11
 
spotrevoc
Old
(Last edited by spotrevoc; 25th September 2013 at 01:57 AM.) Reason: typo
#833  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Sep 2013
Default no boot sound with liquidsmooth

Quote:
Originally Posted by despotovski01 View Post
I don't think so. I might be wrong though, so try it.

Sent from my Evo 3D GSM using Tapatalk -
I'd rather not mess with init.rc if I don't have to.

For anyone interested, I tried replacing liquidsmooth's /system/bin/bootanimation binary with the stock android bootanimation binary but got some errors relating to missing libraries. Looks like liquidsmooth currently just doesn't have the ability to natively play boot sounds. Maybe in the future they will include support for boot sound in the ROM.
 
Nidhal AKA the king
Old
#834  
Nidhal AKA the king's Avatar
Senior Member
Thanks Meter 185
Posts: 325
Join Date: Apr 2013
Location: sousse

 
DONATE TO ME
hey!

i followed instructions carefully for the boot sound, and i got error, look at it the screenshot below!

can you figure this out and how i can solve it?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-09-25-16-54-42.jpg
Views:	273
Size:	71.4 KB
ID:	2282418  
Current Smartphone: Xperia Z C6602


Previous Smartphones


 
despotovski01
Old
#835  
despotovski01's Avatar
Recognized Developer - OP
Thanks Meter 1765
Posts: 1,441
Join Date: Jan 2011
Quote:
Originally Posted by Nidhal AKA the king View Post
hey!

i followed instructions carefully for the boot sound, and i got error, look at it the screenshot below!

can you figure this out and how i can solve it?
You need to mount the system as R/W before performing the operation.
"If you think you can, therefore, you can." - Unknown
"A journey of a thousand miles begins with a single step." - Confucius
"Question everything." - Einstein

"Don't let anyone tell you what you can't do."

My work:
Android Ultimate Toolbox Pro Updated as of 4.5.2013
Boot Animation Factory Updated as of 1.6.2013
Boot Animation Creator Obsolete
Boot Animation Previewer Obsolete

Devices:
LG G2 D802 16GB: Android 4.2.2 Jellybean (stock)
HTC EVO 3D: CyanogenMod 11
 
Nidhal AKA the king
Old
#836  
Nidhal AKA the king's Avatar
Senior Member
Thanks Meter 185
Posts: 325
Join Date: Apr 2013
Location: sousse

 
DONATE TO ME
Quote:
Originally Posted by despotovski01 View Post
You need to mount the system as R/W before performing the operation.
good answer, but i'm a bootanimation maker, so u don't think so that my system isn't mounted

in my threads i always insist on users to check ROOT and SYSTEM MOUNT before throwing the bootanim in media folder... anyway! so, it's not about system mount!

as u saw the screen error i got, what it could be else except than what u thought?


thanks for help
Current Smartphone: Xperia Z C6602


Previous Smartphones


 
Robsworth
Old
#837  
Robsworth's Avatar
Member
Thanks Meter 108
Posts: 79
Join Date: Mar 2013
Location: visakhapatnam
I always get a laggy boot animation . can anyone help
 
ganjar1989
Old
#838  
ganjar1989's Avatar
Senior Member
Thanks Meter 30
Posts: 237
Join Date: Sep 2010
Location: Tangerang
Default boot sound not working on jelly bean 4.3

is anyone can help me with boot sound on jelly bean 4.3?
i have try with anything but this is not working
my devices is tilapia
i have try with like this
720 1280 30
p 1 0 part0
p 0 0 part1
s bootanim.mp3
and rebuild with winrar and compression method is zip and store
only animation that's working but sound is not...
how to make it's work?
thanks
 
keifus.rahn
Old
#839  
keifus.rahn's Avatar
Senior Member
Thanks Meter 94
Posts: 305
Join Date: Jun 2013
Location: West.TX.

 
DONATE TO ME
Quote:
Originally Posted by ganjar1989 View Post
is anyone can help me with boot sound on jelly bean 4.3?
i have try with anything but this is not working
my devices is tilapia
i have try with like this
720 1280 30
p 1 0 part0
p 0 0 part1
s bootanim.mp3
and rebuild with winrar and compression method is zip and store
only animation that's working but sound is not...
how to make it's work?
thanks
*]Adding new boot animation using dsixda's Android Kitchen
1) Download and extract the bootanimation and samsungani file from Custom Booting.zip. http://www.mediafire.com/?giutirau5rkim51
2) Put them in the /system/bin folder and replace the existing files there
3) Now download any boot animation, and rename the bootanimation to “sanim.zip”.
4) Now, navigate to /system/media and replace the “ODEanim” with “sanim.zip”
You are done with the bootanimation change.
 
ganjar1989
Old
(Last edited by ganjar1989; 3rd November 2013 at 06:48 PM.)
#840  
ganjar1989's Avatar
Senior Member
Thanks Meter 30
Posts: 237
Join Date: Sep 2010
Location: Tangerang
Quote:
Originally Posted by keifus.rahn View Post
*]Adding new boot animation using dsixda's Android Kitchen
1) Download and extract the bootanimation and samsungani file from Custom Booting.zip. http://www.mediafire.com/?giutirau5rkim51
2) Put them in the /system/bin folder and replace the existing files there
3) Now download any boot animation, and rename the bootanimation to “sanim.zip”.
4) Now, navigate to /system/media and replace the “ODEanim” with “sanim.zip”
You are done with the bootanimation change.
Thanks Dude...
i will try it...
i will reported it back if this work or not...

Edited :
i have follow your instructions but my boot animation is blank screen and after that i'm going to home screen.
i have rename booanimation.zip to sanim.zip at system/media wiht permissions is rw-r-r, extract and moved samsungani and bootanimation to system/bin with permissions rw-rw-rw
if i'm run from terminal with samsungani, i got error found like this
CANNOT LINK EXECUTABLE: could not load library "libsurfaceflinger_client.so"
is anything else to try?
sorry for my bad english

Tags
android, boot animation, dead, despotovski01, optimus, theme
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes