FORUMS

Which IM Client on Android is best?

With so many different messengers to choose from, it can be tough to find the best one for you and … more

Android Factory Reset Security Flaw and More – XDA TV

Nvidia is releasing a 500Gb SHIELD TV Pro! That and much more news is … more

Android M Code Name: Macadamia Nut Cookie

While the official name for the latest iteration of Android has yet to be revealed, the code … more

XDA Recap: This Week In Android (May 17 – 23)

Another week, another recap. The Sunday tradition marches on this week with a fresh … more
Post Reply Subscribe to Thread Email Thread

CM7 APN problem FIXED!!! (hopefully)

11th June 2011, 06:31 PM |#1  
OP Member
Thanks Meter: 12
 
More
Hey guys, I've tried everything to get the cm7 APN problem fixed. No data connection sucks. Anyways, this is what I did-
1. Turn on WiFi and make sure you're connected.
2. Go into the Market, search "APN Backup".
3. Download the program called "APNsBU (ROOT)"
4. Open the program and click on the "Backup APNs" button.
5. After that's done, click on the "Restore APNs" button. It will prompt you to reboot your phone.
6. After the reboot, open the APNsBU program, click on the menu button on your phone and click "View APNs".
7. You should be able to see "Simple" and "T-Mobile US." Turn off your WiFi and you should be good to go!
The Following 8 Users Say Thank You to shinobix37 For This Useful Post: [ View ]
 
 
11th June 2011, 07:07 PM |#2  
Junior Member
Thanks Meter: 0
 
More
This worked for me.
12th June 2011, 09:13 PM |#3  
bls2633's Avatar
Senior Member
Baltimore
Thanks Meter: 12
 
More
Doesn't look like it worked for me.
13th June 2011, 01:04 AM |#4  
Junior Member
Thanks Meter: 1
 
More
Thanks!! Worked for me I was getting super frustrated.
15th June 2011, 03:20 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Thumbs up
This worked for me as well, with the CyanogenMod-7-061420111 Nightly build. Thanks!
17th June 2011, 10:20 PM |#6  
thienlang072's Avatar
Junior Member
Flag Garden Grove
Thanks Meter: 0
 
More
Hi, I had the same problem last night after I installed CM7. The APN disappeared and I could not connect through my data plan. What I did was I just pulled the battery out and put it back in and re-boot the phone. I just pulled the battery out when the phone was still on. I went back in APN and voila, I saw "Simple" and "T-Mobile US" again. After that I did a few more re-boot to my phone due to I flashed new Gapps, the APN problem didn't come back.
2nd July 2011, 12:09 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Great G2x APN CM7 Fix
Yes, this worked for me!! Thanks a lot for allyour help
2nd July 2011, 12:38 AM |#8  
Junior Member
Thanks Meter: 0
 
More
I can't say that I've tried this, but every time my APNs go missing, going into ROM Manager and running Fix Permissions and then rebooting makes them come back. Maybe that trick will work for others too.
2nd July 2011, 01:11 AM |#9  
Romanbb's Avatar
Recognized Developer
Thanks Meter: 7,034
 
Donate to Me
More
Hard reboot does the trick for me. Every time. Vol up + power.
14th August 2011, 08:46 AM |#10  
Junior Member
Flag San Diego
Thanks Meter: 2
 
More
Tried:
Hard Reset and battery pull, No success
APN backup trick, can't see any APNs
Rom Manager fix permissions.

Nothing works, APNs are gone for good, no data connection and can't add an APN, blank screen nothing happens.

:eek: Searched everyone on google and these forums i can't seem to find a fix :eek:

EDIT:
Had to wipe everything, reinstall latest nightly cm7, which worked but when i restored everything with titantium backup the problem came back so must have been some settings that were wrong. Only restored the apps i trusted with data, and everything is good now. What a pain
Last edited by dpaschall; 14th August 2011 at 09:38 AM. Reason: solution
Post Reply Subscribe to Thread

Tags
apn, cm7
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes