FORUMS

Enable Multi-Window Mode on M Developer Preview

What was not mentioned in yeterday’s keynote was Android M’s multi-window … more

I/O Summary: Google Cardboard Virtual Reality

One year ago, Google introduced cardboard. Amazingly enough, that was all it took to fire … more

Android M Preview Images – XDA TV

Android M preview images are available. That and much more news is covered by Jordan when he … more

I/O Summary: How Android M Handles Power And Charging

In the spirit of improving the core Android experience, Google is changing Android … more

[Q] Cifs unicode module for Android 3.1 (Prime 1.4)

Thanks Meter: 1
 
By XPNect, Junior Member on 17th June 2011, 03:10 PM
Post Reply Subscribe to Thread Email Thread
Hello,

Just got my new TF and thanks to XDA I've already rooted it and installed rom Prime 1.4 to get a rooted 3.1 android version.
Everything goes fine except for mapping network shares. Mounting network shares with cifs manager is ok except that I'm French so some directories in my network got unicode characters and I can't mount them.

Does anyone know how to bypass this limitation ?

On my understanding, I should install a cifs.ko module compiled for the TF and the 3.1 Android version in /system/lib/modules but I don't know where to find such module.

Thanks in advance
 
 
17th June 2011, 03:27 PM |#2  
david279's Avatar
Senior Member
Flag New Orleans
Thanks Meter: 1,807
 
Donate to Me
More
Try es strongs file explorer. It allows you to add network shares.

Sent from my Transformer TF101 using XDA Premium App
17th June 2011, 03:55 PM |#3  
OP Junior Member
Thanks Meter: 1
 
More
Thanks, but I've already done it without success.

The issue is not to map a share, this is working. The real issue is that share with unicode characters (like , , ...) are not working.

Thanks anyway
17th June 2011, 04:01 PM |#4  
Member
Thanks Meter: 36
 
More
Im also rooted with prime 1.4 buf cant get any shared volume to mount via cifs manager. What am i missing here?
17th June 2011, 04:25 PM |#5  
Retired Recognized Developer
Thanks Meter: 296
 
More
Have you tried adding 'iocharset=utf8' to the mount point options?
17th June 2011, 05:17 PM |#6  
OP Junior Member
Thanks Meter: 1
 
More
Don't know if this can help you or not, but my 1st mistake with cifs manager when I tried it fist time was that I haven't put anything on mount point.

What you need on the fields of cifs manager is:
Share Path: The path to your share ==> ex: 192.168.1.5/share (this is the shared dir on your server)
Mount point: The name of the "false" directory that will simulate that your share is on your tablet ==> ex: /sdcard/cifs/share (this is up to you but keep close to this)

Plus of course username and password (I thinks that anonymous connection is not allowed anyway)

Hope this help
17th June 2011, 05:34 PM |#7  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Tortel1210

Have you tried adding 'iocharset=utf8' to the mount point options?

I don't know how I can do that. Is it an argument to parse in a field of cifs manager ? If so how should I do that ?
Can you help me with this please.
The Following User Says Thank You to XPNect For This Useful Post: [ View ]
17th June 2011, 06:43 PM |#8  
Retired Recognized Developer
Thanks Meter: 296
 
More
Quote:
Originally Posted by XPNect

I don't know how I can do that. Is it an argument to parse in a field of cifs manager ? If so how should I do that ?
Can you help me with this please.

If you edit the settings for a mount point (Long press on it, then choose edit), there is an options text field at the bottom. Put it in there, save, and try mounting it.
The Following User Says Thank You to Tortel1210 For This Useful Post: [ View ]
17th June 2011, 07:04 PM |#9  
Member
Thanks Meter: 36
 
More
Quote:
Originally Posted by XPNect

Don't know if this can help you or not, but my 1st mistake with cifs manager when I tried it fist time was that I haven't put anything on mount point.

What you need on the fields of cifs manager is:
Share Path: The path to your share ==> ex: 192.168.1.5/share (this is the shared dir on your server)
Mount point: The name of the "false" directory that will simulate that your share is on your tablet ==> ex: /sdcard/cifs/share (this is up to you but keep close to this)

Plus of course username and password (I thinks that anonymous connection is not allowed anyway)

Hope this help

Thanks!!! Dont know how or why but now it works!
17th June 2011, 07:32 PM |#10  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Tortel1210

If you edit the settings for a mount point (Long press on it, then choose edit), there is an options text field at the bottom. Put it in there, save, and try mounting it.

It works fine a big thanks.

I've been abused by the comment and I was thinking that this box was only for a domain name... feel stupid sometime
Post Reply Subscribe to Thread

Tags
cifs, kernel, module, transformer
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes