Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,772,327 Members 44,384 Now Online
XDA Developers Android and Mobile Development Forum

[ROM][CWM]KhasMek Stock Deodexed plus! For Tab 10.1

Tip us?
 
Boushh
Old
(Last edited by Boushh; 22nd June 2011 at 03:05 AM.)
#1  
Boushh's Avatar
Retired Recognized Developer - OP
Thanks Meter 143
Posts: 390
Join Date: Mar 2008
Location: Portland, OR
Default [ROM][CWM]KhasMek Stock Deodexed plus! For Tab 10.1

As normal, it's not my fault if you fubar your tab by flashing this or if zombies come and speedhump your cat. You've been warned.

Well, hello there, some of you may know me from my vzwtab (7") work, but I'm sure most of you don't.

No matter, I just finished deodexing my framework and app folders, so I decided to share with you.

This isn't anything special, just you're stock system that's been deodexed, I did not remove any programs, there are really only three or so 'bloatware' apps on here, so I didn't bother.
If you would like to, just use root file explorer (or your preferred method) to remove them.

In addition to the stock items I have added pershoot's SU/Busybox/misc package (SOURCE) All credit goes to him for that.

If there's anything else, just let me know. I have tested this on my own rooted tab and everything seems to work fine and be stable.
If you notice any issues, please format/clear both Dalvik & normal Cache. It's probably the cause.

Features
  • Deodexed flashable system
  • Pershoot's SU/Busybox/misc pacakage (nano, VIM, all kinds of other goodies)

Changelog

06212011- r1 - Initial Release


Known Issues
  • You may have to go through and manually delete your odex's in /system/app/ and /system/framework/ but the apk's and jar's no longer call them. (I can't get the amend format command working right. if you want to tell me how, please!)

Installation
  • Reboot into CWM either via ROM Manager or via power off, volume down + power, volume down to CWM icon and volume up to select.
  • Select Install Zip from SD Card
  • Navigate to location of zip and select okay
  • Clear Cache and Dalvik Cache (in advanced)
  • Reboot
  • Make themes for me

Download
Lastly, if you like my work, donate to me so I can donate money to devs that make my world easier (and therefore yours).
[] Current Phone: Galaxy Nexus []
[] Current ROM: AOKP []
[}------------------------------------------------------------{]
[] Current Tab: Nexus 7 []
[] Current ROM: AOKP []
[}------------------------------------------------------------{]
[] Hack to learn []
[] NOT []
[] Learn to hack []
[}------------------------------------------------------------{]
The Following 8 Users Say Thank You to Boushh For This Useful Post: [ Click to Expand ]
 
camblue
Old
#2  
camblue's Avatar
Recognized Themer
Thanks Meter 1702
Posts: 2,470
Join Date: Jul 2010
Location: Reno, NV

 
DONATE TO ME
awesome finally someone to break ground for the Samsung Galaxy tab! Thanks will try it out!
 
bballer71418
Old
(Last edited by bballer71418; 22nd June 2011 at 05:42 AM.)
#3  
Senior Member
Thanks Meter 37
Posts: 637
Join Date: Jul 2010
Location: Houston
Not sure if it matters but is this for retail or I/o version? Does it matter since it is basically the same tab?

For any ideas: maybe you could include a way for hulu to work without any work arounds? And maybe some lag fixes. Although that may be solved with a custom kernel.

Sent from my PC36100 using XDA Premium App
 
danielsjam
Old
(Last edited by danielsjam; 22nd June 2011 at 05:47 PM.) Reason: corrected
#4  
Member
Thanks Meter 17
Posts: 88
Join Date: Nov 2010
Decided to test this on the retail version.

The only problem is that root is broken because there are two su binaries installed.

/system/bin/su - installed from file Samsung_Galaxy_Tab_10.1_root.zip when you rooted the device.

/system/xbin/su - installed when you added [Tools] – SU/BusyBox/Misc – Galaxy Tab 10.1 (Update: 6/18/11).

To fix:
http://forum.xda-developers.com/show...3&postcount=18
------
the /system/bin/su binary need to be removed.

Su does not work on the tablet with two su binaries installed.

Use adb to remove /system/bin/su
adb remount
adb shell
cd /system/bin
rm su
reboot

I tried running titanium backup prior to a reboot after removing /system/bin/su and it would not work. I uninstalled/reinstalled and it worked, but a reboot may have fixed the problem.

I manually deleted all the odex files - no problems so far. I will provide an update later if I have problems.

------------

You can remove /system/bin/su when you update the image again.

JD
The Following User Says Thank You to danielsjam For This Useful Post: [ Click to Expand ]
 
Boushh
Old
#5  
Boushh's Avatar
Retired Recognized Developer - OP
Thanks Meter 143
Posts: 390
Join Date: Mar 2008
Location: Portland, OR
Yeah, I just noticed that myself actually. Don't know why I didn't catch it before.

Anywho, I think I'll prolly push an update to this tomorrow after I write a script to remove the odex's. It was my initial thought, but I thought it would be easier to used the updater-script to do it, but looks like just writing an additional one will be best.

Glad the su thing didn't confuse you too much!
[] Current Phone: Galaxy Nexus []
[] Current ROM: AOKP []
[}------------------------------------------------------------{]
[] Current Tab: Nexus 7 []
[] Current ROM: AOKP []
[}------------------------------------------------------------{]
[] Hack to learn []
[] NOT []
[] Learn to hack []
[}------------------------------------------------------------{]
 
ericc191
Old
#6  
ericc191's Avatar
Senior Member
Thanks Meter 118
Posts: 1,988
Join Date: Jan 2007
Location: Davis, CA
Sweet thanks for this. Going to give it a whirl!
My Optimized Honeycomb Wallpaper Packs

Current: AT&T HTC One X (White)
Backup: Still Deciding
Last Resort: Samsung Slider
 
touchpro247
Old
#7  
touchpro247's Avatar
Senior Member
Thanks Meter 301
Posts: 1,237
Join Date: Apr 2009

 
DONATE TO ME
I flashed the Samsung_Galaxy_Tab_10.1_root.zip after flashing the Rom. Everying is working fine.

I didn't need to remove su from anywhere.

Thanks!

Sent from my GT-P7510 using XDA Premium App
 
dsh897
Old
#8  
dsh897's Avatar
Senior Member
Thanks Meter 19
Posts: 178
Join Date: Dec 2007
Same here

Sent from my GT-P7510 using XDA Premium App
 
anaphora68
Old
#9  
Member
Thanks Meter 4
Posts: 90
Join Date: Jul 2010
Any chance you can add a browser.apk that gives access to Google Labs?

Sent from my GT-P7510 using Tapatalk
 
danielsjam
Old
(Last edited by danielsjam; 22nd June 2011 at 04:33 PM.)
#10  
Member
Thanks Meter 17
Posts: 88
Join Date: Nov 2010
Quote:
Originally Posted by touchpro247 View Post
I flashed the Samsung_Galaxy_Tab_10.1_root.zip after flashing the Rom. Everying is working fine.

I didn't need to remove su from anywhere.

Thanks!

Sent from my GT-P7510 using XDA Premium App
You will only have problems when you try to run an app that requires root (Root Explorer, Titanium backup....).

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes