Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,022 Members 53,633 Now Online
XDA Developers Android and Mobile Development Forum

Can't send SMS using any third party app

Tip us?
 
jphenow
Old
(Last edited by jphenow; 1st July 2011 at 03:58 PM.)
#1  
Senior Member - OP
Thanks Meter 2
Posts: 196
Join Date: Jun 2010
Location: Minnesota
Exclamation Can't send SMS using any third party app

I keep trying to use a third party SMS app, because I'm hardly a fan of the stock! It seems, though, that I can't send a message from a third party app - I've tried both ChompSMS and GoSMSPro, but both will fail upon attempt. Almost instantly too. I have the logcat from Chomp here https://gist.github.com/1058515 if anyone's interested. I've been poking at it a little, but can only stare for so long when I don't know what I'm looking for really.

I searched briefly and didn't find much anywhere on this matter, perhaps I'm doing something wrong?

Thanks for any assistance

**EDIT** I sort of figured it out... They don't handle the +1<Phone number> That was tacked on the front for the country code. Not sure why that is or if there's any remedy without deleting all the +1s

**EDIT2** Handcent FTW, handles this all correctly, somehow better than others? Not sure what they could've done to screw it up for me specifically, never heard of this issue elsewhere and my old Droid Eris worked fine with all of these applications, besides being slow!
---
jPhenow
Droid Incredible 2
AlphaRevX Rooted
CM7 Beta1
 
nimdae
Old
#2  
nimdae's Avatar
Senior Member
Thanks Meter 62
Posts: 575
Join Date: Feb 2010
Location: Texas
Been using textsecure without fail so far.
Motorola DROID Mini
Running CM11 Nightly

Asus Transformer Book T100TA
Windows 8.1 until I can get Android working
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes