FORUMS

What Are the Best Looking Apps on Android?

As more developers are updating their apps with Material Design elements, we’re … more

Cyngn Explained: Who’s Cyanogen, What’s Cyanogen OS?

While Cyanogen, Inc has been the source of many headlines lately, there … more

Verizon Moto X 2014 Receives Root On Kitkat 4.4.4

The Verizon Moto X 2014 has finally received root, albeit only on Kitkat 4.4.4 … more

Android 5.1.1 Released, Google Cell Service – XDA TV

Android Lollipop 5.1.1 has been released. That and much more news is covered … more
Post Reply Subscribe to Thread Email Thread

[AlphaRevX] Public Beta 2 for Desire S

9th July 2011, 04:17 AM |#1  
OP Retired Recognized Developer
Thanks Meter: 1,761
 
Donate to Me
More
Hi guys,

The day has arrived:

AlphaRevX now includes support for the Desire S (HBOOT 0.98).

Hop on over to http://alpharev.nl/x/beta/

We'll use this as a support thread.

This version will also download and flash custom recovery if you want to, after getting S-OFF.

Note: the very first download missed some DLLs for the windows version, that should be included now.

Note2: There have been some reports (on dinc2) that the windows version might not always work like it should. Please report errors with that as descriptive as possible. The linux version should always work like it should.
The Following 27 Users Say Thank You to ieftm For This Useful Post: [ View ]
 
 
9th July 2011, 04:25 AM |#2  
ghuk's Avatar
Senior Member
Flag Angeles City
Thanks Meter: 8
 
More
great news! is there a guide for a noob like me on how to s-off my Desire S using this software? thanks
9th July 2011, 04:27 AM |#3  
Junior Member
Thanks Meter: 11
 
More
FAILED
Hi there,

I've just tried to S-OFF my european Desire S several times, following the instructions posted for the Incredible S. Alpharevx connects to my phone, reboots to fastboot, waits, reboots to fastboot (again), waits .. then says FAILED.

I wonder if I'm doing something wrong or there's a problem with the windows version as you reported.

Thanks for the effort any way


EDIT: Downloaded the Linux version and it worked. I am now S-OFF
Last edited by kkma1869; 10th July 2011 at 04:33 AM. Reason: update
9th July 2011, 05:52 AM |#4  
Junior Member
Thanks Meter: 4
 
More
Hi, AlphaRevX didn't work for me on Windows either, but it succeeded on Linux (Ubuntu 11.04). Anyway, thanks a lot for your effort, AlphaRev team
9th July 2011, 05:55 AM |#5  
Senior Member
Thanks Meter: 382
 
Donate to Me
More
@taipan_snake - Could you please guide me on How To S-OFF it on Linux ? I also have a Ubuntu installed. Thanks !
9th July 2011, 06:09 AM |#6  
Junior Member
Thanks Meter: 4
 
More
@badeaioan:

Well basically these are the steps that worked for me:

1. Download the Android SDK from here: http://developer.android.com/sdk/index.html
2. Unzip and go into the folder you just downloaded
3. Run the 'android' application within the 'Tools' folder
4. Select 'Available Packages', and select 'Android SDK Platform-tools' and 'Android Compatibility package', and install these.
5. Make sure ADB can see your device by cd-ing into the SDK folder, and then the 'platform-tools' folder, and running './adb devices'. Your device should show up (mine had a string of question marks, but it should work as long as it is there)
6. Download AlphaRevX and get your beta key
7. Run AlphaRevX as root, and follow the instructions, and you should have S-OFF

Hope this helps
The Following 3 Users Say Thank You to taipan_snake For This Useful Post: [ View ]
9th July 2011, 06:22 AM |#7  
.sh4d0w.'s Avatar
Senior Member
Bucuresti
Thanks Meter: 35
 
More
Sad windows version under review
-I tried the incredible version(long time ago ),(no SDK used) and it said my phone not suported bla bla, but the fact is that it was detected (with usb debuging on and phone conected in charge only)
one question: Do i need to get temp root for this to work?
Last edited by .sh4d0w.; 9th July 2011 at 06:27 AM.
9th July 2011, 06:24 AM |#8  
shrome99's Avatar
Recognized Contributor
Flag Chandigarh
Thanks Meter: 1,532
 
More
Finally !!!!! AlpharevX - a software s-off. This is awesome, for s-on guys for obvious reasons, and for s-off guys too. This is surely gonna increase dovelopment here !!!!!
9th July 2011, 06:24 AM |#9  
Senior Member
Thanks Meter: 382
 
Donate to Me
More
Thank you for your response.

The problem starts on running AlphaRevX.

When I open gksu and try to open it, nothing happens. Am I doing something wrong ?
9th July 2011, 06:31 AM |#10  
Junior Member
Thanks Meter: 4
 
More
@badeaioan:

I just used Terminal, cd-ed into the directory, and ran 'sudo ./alpharevx', and it worked for me...

EDIT: I think I now know what you mean... it's only a command-line app, so it would only run from terminal...
Last edited by taipan_snake; 9th July 2011 at 06:33 AM.
The Following User Says Thank You to taipan_snake For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Desire S Android Development by ThreadRank