Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,466 Members 50,608 Now Online
XDA Developers Android and Mobile Development Forum
View Poll Results: Was this guide Helpful
Worked 27 65.85%
Did not Work 14 34.15%
Voters: 41. You may not vote on this poll

[GUIDE] Reverse Tethering Wildfire --> Internet Pass Through

Tip us?
 
rahuliyer95
Old
(Last edited by rahuliyer95; 17th July 2011 at 05:39 AM.)
#1  
rahuliyer95's Avatar
Member - OP
Thanks Meter 85
Posts: 59
Join Date: May 2011
Location: Thane
Post [GUIDE] Reverse Tethering Wildfire --> Internet Pass Through

My First Guide. Hope it Helps..

HOW TO REVERSE TETHER YOUR PHONE / INTERNET PASS THROUGH


Reverse Tethering / Internet Pass through is the method in which you can make your android phone use the internet connection of your computer without a WIFI and by using a usb cable. It is helpful for those people who don’t have a WIFI at their place and for those who don’t have a good internet plan for their mobile.

BASIC REQUIREMENTS
  • Rooted Phone With S-OFF
  • SuperUser [QR Code]
  • BusyBox [QR Code]
  • Terminal Emulator [QR Code]
  • Windows O.S. [I am using Win-7]
  • USB Cable for your phone


THE PROCESS


Connect Your Android Phone to your PC. Make sure you are rooted and have terminal emulator installed. Turn on USB Tethering from


SETTINGS -> WIRELESS AND NETWOKRS -> TETHERING AND PORTABLE HOTSPOT -> USB TETHERING.

Screen


Next you will get a new connection in your PC. Open Networking and Sharing Center from

CONTROL PANEL -> NETWORK AND SHARING CENTER


You get a scene in a similar manner.
Screen

Now There will be one connection which will be your Main Net Connection and the Other one will be your Android Phone’s Created Connection for tethering. Click on your main net connection i.e. the one you use for Connecting to net Local Area Connection(in my case).
You will get the following screen.


Screen

Now click on Properties.After this click on sharing and tick on Allow other network users to connect through this computer’s internet connection and click ok for any dialog box shown and click ok to come back to the main networking screen.
Screen

Now click on the new connection made by the android phone Local Area Connection 2 (in my case)
You will get the following screen

Screen

Click on properties. Then go to Internet Protocol version 4(TCP/IPv4) and click on properties.
Screen

Now You need to enter 192.168.2.1 in IP address and enter 255.255.255.0 in Subnet mask and keep remaining things empty.
Screen

PART ON THE PHONE

NOTE:- ALL CODES HAVE TO BE WRITTEN WITHOUT QUOTES

Open Android Terminal on the Phone and type "su". Provide it superuser permissions.
Screen

Now type “ifconfig usb0 192.168.2.2 netmask 255.255.255.0”
Screen

“busybox route delete default”
Screen

You may get an error here but it does not matter.

Now type “iptables –F –t nat”(* -F in caps is must)

Then type “busybox route add default gw 192.168.2.1”

Screen

“setprop net.dns1 8.8.8.8”
Next (setprop “net.gprs.http-proxy” “” ) [*Note :- here the code is written in bracket to avoid confusion.. The quotes(“”) are required.

Screen

CONGRATS.... YOU ARE DONE!!

RESULTS

  • Works on Android Browser.(FOR ME)
  • Works on Opera & Opera Mini.
  • Works on XDA Premium App.
  • DOES NOT Work on Android Market.(Finding a Solution... if anyone gets it working please tell)
  • You may need to repeat this process each time you connect the phone to PC.
  • Works even without a SIM inserted.
The Following 9 Users Say Thank You to rahuliyer95 For This Useful Post: [ Click to Expand ]
 
meknb
Old
#2  
Senior Member
Thanks Meter 11
Posts: 266
Join Date: Nov 2008
Location: Merseyside
Nice guide
To enable the market click settings under the sharing tab and add a new service called market with the port number 5228.
The Following User Says Thank You to meknb For This Useful Post: [ Click to Expand ]
 
omegfa
Old
#3  
omegfa's Avatar
Member
Thanks Meter 5
Posts: 68
Join Date: Oct 2010
how use other app for internet
 
akazi1
Old
#4  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Jul 2009
Default No resolution

currently m using a wildfire and cannot switch on USB tethering until mobile network is connected followed all the steps but no luck
 
biteyou
Old
#5  
Junior Member
Thanks Meter 1
Posts: 9
Join Date: Aug 2011
I am also a wildfire user. I did so many searching for reverse usb tethering, what I searched for were similar to the script of this thread. I follow all the steps but also not success.

I did do some searching, I just GUESS the main problem is the router at my home. My computer access the modem via router, maybe the router cannot give my WF a IP so my WF cannot access the internet? I dunno.

I didn't try access the internet with my computer connecting directly via modem without router since my home wire connection is so so so so complicated, but I believe that it will success. Would somebody try it and share your experience?
 
core1024
Old
#6  
Member
Thanks Meter 5
Posts: 45
Join Date: Dec 2010
Location: Ruse
I think you can write a batch file for this. Using netsh and adb it would be easily done just from PC
 
jesseuy
Old
#7  
Junior Member
Thanks Meter 4
Posts: 16
Join Date: Jul 2011
thanks for the guide worked for me.

Problem though is that after i turned off the tethering and disconnected my phone from the pc then reconnect it again just to check if it works the 2nd time, if found that usb tethering is having an error and does not turn on.

question is how to disable this or how i disconnect my phone from pc the right way? well after restarting, tethering is again ok and
 
core1024
Old
#8  
Member
Thanks Meter 5
Posts: 45
Join Date: Dec 2010
Location: Ruse
I did it on linux!
The configuration on the PC is next:
Code:
echo 1 > /proc/sys/net/ipv4/ip_forward
ifconfig usb0 192.168.2.1 netmask 255.255.255.0
iptables -A POSTROUTING -t nat -s 192.168.2.1/24 -o wlan0 -j MASQUERADE
On the phone same az you did, but I had to edit

Code:
setprop net.dns1 8.8.8.8
to match my DNS server i.e.
Code:
setprop net.dns1 87.120.131.2
 
simmer14
Old
#9  
simmer14's Avatar
Senior Member
Thanks Meter 82
Posts: 413
Join Date: Jul 2011
worked !!!!!!!!!!!!!
 
rahulparekh
Old
#10  
Member
Thanks Meter 1
Posts: 31
Join Date: Nov 2011
Location: Mumbai

 
DONATE TO ME
After about two months of searching I finally found this guide which makes it work. Thanks a lot! Surfing everything is fine but downloads just don't start (market or browser) I'm using G2x by the way so I guess this should work for most people.

Quote:
Originally Posted by meknb View Post
Nice guide
To enable the market click settings under the sharing tab and add a new service called market with the port number 5228.
I did this which enabled me to browse the market. It won't download anything. I even forwarded the port on my broadband modem and the downloads don't start. Just keep saying "Starting downloading..."

Tags
guide, internet passthrough, reverse tethering, wildfire
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes