Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[i9003] Odin stuck on "setup connection"...

OP OrbitalDroid

27th July 2011, 08:13 PM   |  #1  
OrbitalDroid's Avatar
OP Senior Member
Flag Toulouse
Thanks Meter: 31
 
178 posts
Join Date:Joined: Jul 2011
More
Hi !

This is my problem : my current rom is a i9003XXKP9 and it's laggy, 3G is slow, 90% of apps won't run, battery drains fast, camera doesn't work... so I want to go back to a FroYo version (i9003XXKB3) but Odin (1.82) gets stuck at "setup connection". My i9003 is connected in Download mode, I removed SIM and SDCard, changed USB port (7 out of 7 actually...) but still stuck at the first step of the flash... This fills me with despair... Oh and I also have my drivers up to date

Please help me, I never had a problem flashing all my WM phones...

Thank you
The Following User Says Thank You to OrbitalDroid For This Useful Post: [ View ]
28th July 2011, 08:03 AM   |  #2  
Senior Member
Flag Vancouver and area
Thanks Meter: 38
 
224 posts
Join Date:Joined: Jan 2011
More
Well I don't have a 9003 but make sure you do not wait too long to start the flash after connection to the computer. It will still show as connected but it seems the i9000 at least stops looking for the download after a little while.

Also try another version of Odin. I had one that just never worked.
The Following 9 Users Say Thank You to gfacer For This Useful Post: [ View ]
28th July 2011, 12:11 PM   |  #3  
Junior Member
Flag Prilep
Thanks Meter: 0
 
24 posts
Join Date:Joined: Oct 2010
Try move the sd card...
28th July 2011, 02:12 PM   |  #4  
Einride's Avatar
Senior Member
Thanks Meter: 110
 
347 posts
Join Date:Joined: Sep 2010
Donate to Me
I've had that before, usually solved by removing the battery for a couple of minutes and then booting into download mode again.

Also, start Odin (as administrator to be sure) before you plug in the phone. It's sometimes very picky about that it seems.
The Following 5 Users Say Thank You to Einride For This Useful Post: [ View ]
15th October 2011, 10:31 AM   |  #5  
Junior Member
Flag Chennai
Thanks Meter: 6
 
19 posts
Join Date:Joined: Jun 2011
More
Thumbs up I am able to get past Odin "setup connection" issue for I9003
Hi!

I had this issue for more than a week and now I managed to find a solution for this. Previously I was working with Windows 7 and had no issues while using Odin for flashing the ROMs. But when I shifted to my old machine having WinXP I had the issue in Odin which get stuck on "setup connection".

Yes, I tried re-installing the drivers, made sure that Kies is not running in task manager, searched in google for solutions and followed all methods suggested, but still no luck whatever I did. Then finally I tried this and it worked...

After putting my phone in the download mode, I first tried to flash with Odin3 v1.82. Once it got stuck on "setup connection", I simply closed Odin3 v1.82 and opened Odin3 v1.83 and tried flashing again. Now it worked... I didn't disconnect the phone during this process of changing the Odin. I tried many times today and this method worked for me all the time. You can first try with any version of Odin. If that version doesn't work, simply close it and try with the other version.

Hope this helps someone who has this issue...
The Following 3 Users Say Thank You to Giri.R For This Useful Post: [ View ]
4th December 2011, 08:45 AM   |  #6  
Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Jan 2011
Turn off antivirus Did the trick for me.
The Following User Says Thank You to aroekene For This Useful Post: [ View ]
25th December 2011, 10:44 PM   |  #7  
Senior Member
Thanks Meter: 87
 
425 posts
Join Date:Joined: Jul 2010
Donate to Me
More
Quote:
Originally Posted by gfacer

Well I don't have a 9003 but make sure you do not wait too long to start the flash after connection to the computer. It will still show as connected but it seems the i9000 at least stops looking for the download after a little while.

This fixed the problem for me!
Didn't know you had to be real quick.
Thanks!
23rd January 2012, 02:46 PM   |  #8  
devilrulz4ever's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 82
 
336 posts
Join Date:Joined: Oct 2011
More
removing the sdcard and sim worked for me
The Following User Says Thank You to devilrulz4ever For This Useful Post: [ View ]
23rd January 2012, 04:39 PM   |  #9  
Lucasred's Avatar
Member
Flag Santiago del Estero
Thanks Meter: 11
 
76 posts
Join Date:Joined: Sep 2011
More
My case with this kind of problems
Let me tell u about a problem i have all the time, on my first flashes with Odin i always got stuck on the setup connection, but it was a problem with my USB ports, it turns out that not all ports are 2.0, which is the recommended for doing this kind of things.....
When i found out this, i tried on all of my 8 ports 'till i found the right one
Another issue, at least with my device, is that the USB cable doesn't "grab" well and it happened to me that at least 5 times the flashing was interrupted by this kind of problem.

I use Windows 7 Enterprise and Windows 7 Ultimate in my desktop PC and in my laptop respectively......
2nd February 2012, 07:41 AM   |  #10  
Junior Member
Thanks Meter: 3
 
7 posts
Join Date:Joined: Feb 2012
Quote:
Originally Posted by gfacer

Well I don't have a 9003 but make sure you do not wait too long to start the flash after connection to the computer. It will still show as connected but it seems the i9000 at least stops looking for the download after a little while.

Also try another version of Odin. I had one that just never worked.

I have an i9000 as well, and I can confirm this did the trick. Fire up odin as soon as you get the phone into download mode!

The Following 3 Users Say Thank You to jschatte For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
i9003, setup connection
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes