Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[FIRMWARE][4.0.A.2.368][Mini][ST15i][Smultron] Official Firmware + ROOT solution

OP DooMLoRD

20th August 2011, 05:29 PM   |  #1  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,108
 
13,127 posts
Join Date:Joined: Jul 2010
[ info ]

ok guys this is a FLASHTOOL compatible firmware package for
stock SE FW:4.0.A.2.368
android OS version: 2.3.3
device: Xperia Mini
Model no: ST15i
Model code: Smultron


[ screenshot ]




THANKS TO Jozinek FOR PROVIDING FILES & UPLOADING FINAL FTF AND TESTING IT ON HIS DEVICE

Thank you Flays for ur kind donation!


[ download link ]

ST15i_4.0.A.2.368__GENERIC_(1244-2098).ftf

mirrors:
deposit files
hotfile
uploading.com
FileSonic


[ how to use FlashTool ]

FLASHTOOL GUIDE - HOW TO for n00bies
this was posted in X10 section but is even relevant for Arc/Play/Neo users


[ rooting instructions ]

check post #2


Detailed/Step-by-step instructions as posted by droxperia FOR MINI PRO (u can follow those instructions just use the corresponding files from this thread)
Last edited by DooMLoRD; 13th October 2011 at 07:42 PM.
The Following 6 Users Say Thank You to DooMLoRD For This Useful Post: [ View ]
20th August 2011, 05:29 PM   |  #2  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,108
 
13,127 posts
Join Date:Joined: Jul 2010
[ rooting instructions ]

before u proceed... make sure that u have read this:
[How-To] Safely test custom kernels / custom ROMs and get back to stock SE 2.3 ROM (we are interested only in custom boot.img section)
AT LEAST TWICE!


How to use FastBoot:

[Newbie Guide] adb/fastboot/bootloader/android 101


[ requirements ]
  • phone is on stock firmware: 4.0.A.2.368
  • bootloader is unlocked
  • boot.img from this post
  • fastboot files
  • SuperOneClick PC app (i recommend SuperOneClickv1.7-ShortFuse) OR Flashtool


[ how to root ur Xperia Mini Pro ]
  1. make sure u are on stock firmware: 4.0.A.2.368

  2. download the boot.img provided below and save it in same folder as fastboot.exe

  3. power down phone

  4. connect phone in fastboot mode (connect device via USB cable to PC)

  5. flash the boot.img using:

    Code:
    fastboot flash boot boot.img
  6. verify that u get [ OK ] at end of flashing

  7. disconnect USB cable

  8. power on phone

  9. when the OS boots up make sure that "Unknown sources" & "USB Debugging" is enabled

  10. connect device via USB cable to PC

  11. start SuperOneClick app on PC, click on Root (OR u can even start FLASHTOOL and then click ROOT)

  12. device might reboot

  13. when u get back in android OS, check app drawer u will see Superuser app

  14. congrats ur device is now ROOTED



[ download link ]

Mini FW 4.0.A.2.368 insecure kernel ( mirror )
[ MD5HASH: 89ba0c69db09401c97043e59e335baaf ]
(this is based on stock kernel only ramdisk is changed)
Last edited by DooMLoRD; 13th October 2011 at 06:58 PM.
The Following 4 Users Say Thank You to DooMLoRD For This Useful Post: [ View ]
24th August 2011, 11:11 AM   |  #3  
Junior Member
Thanks Meter: 5
 
9 posts
Join Date:Joined: Feb 2008
Below link is my rooted system image (img format).

www(dot)multiupload(dot)com/AF56GU8XDT


Just use below command to flash it: (of couse you must unlock you phone first)

fastboot.exe -i 0x0fce flash system rootsys.img

Below link is the guide how to re-lock Xperia mini:

www(dot)theandroidsoul(dot)com/guide-how-to-relock-boot-loader-on-xperia-arc


it worked for my xperia mini st15i,I already tried it.but DRM (Digital rights management) and trackid can't work.
24th August 2011, 11:41 PM   |  #4  
Senior Member
Thanks Meter: 7
 
265 posts
Join Date:Joined: Aug 2010
My build number is 4.0.A.2.364
How do I bring this up to 4.0.A.2.368?
Thanks
25th August 2011, 09:46 AM   |  #5  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,108
 
13,127 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by jean001luc

My build number is 4.0.A.2.364
How do I bring this up to 4.0.A.2.368?
Thanks

flash the FTF from the first post
The Following User Says Thank You to DooMLoRD For This Useful Post: [ View ]
25th August 2011, 01:33 PM   |  #6  
Senior Member
Thanks Meter: 7
 
265 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by DooMLoRD

flash the FTF from the first post

DoomLord
Thanks for the quick reponse but I am even more confused now. I thought in order to flash the fimware I had to be on build 4.0.A.2.368.
Is that not the case?
Thanks
25th August 2011, 01:39 PM   |  #7  
Senior Member
Thanks Meter: 7
 
265 posts
Join Date:Joined: Aug 2010
Are the rooting instructins (and unlocking bootloader) ONLY for Mini Pro or will they also work on Mini?
25th August 2011, 03:10 PM   |  #8  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,108
 
13,127 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by jean001luc

DoomLord
Thanks for the quick reponse but I am even more confused now. I thought in order to flash the fimware I had to be on build 4.0.A.2.368.
Is that not the case?
Thanks

if u are already on that FW then u DO NOT NEED TO FLASH FTF...

u need to flash FTF ONLY IF u are on OLD FW...



Quote:
Originally Posted by jean001luc

Are the rooting instructins (and unlocking bootloader) ONLY for Mini Pro or will they also work on Mini?

there are two seperate threads for these two devices...

the boot.img is the only this which is different...
25th August 2011, 03:58 PM   |  #9  
Senior Member
Thanks Meter: 7
 
265 posts
Join Date:Joined: Aug 2010
DoomLorD
I think i may have casued too much confusion.
Let me start at the begining.

I am on build 4.0.A.2.364.

According to the posts at start, if I want to use the ROM then I need to be on 4.0.A.2.368.

Questions;
1) Do I need to be on 4.0.A.2.368 to use the aforementioned ROM?
2) If yes then how do I get to 4.0.A.2.368 as the first article says I need to be on 4.0.A.2.368 to use the firmware. If this is the firmware that gets me to 4.0.A.2.368 then Im going round and round in circle - e.g. im not on 4.0.A.2.368 but cant get to it as I need to be on it in order to flash the firmware

Hope that makes sense
25th August 2011, 04:02 PM   |  #10  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,108
 
13,127 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by jean001luc

DoomLorD
I think i may have casued too much confusion.
Let me start at the begining.

I am on build 4.0.A.2.364.

According to the posts at start, if I want to use the ROM then I need to be on 4.0.A.2.368.

Questions;
1) Do I need to be on 4.0.A.2.368 to use the aforementioned ROM?
2) If yes then how do I get to 4.0.A.2.368 as the first article says I need to be on 4.0.A.2.368 to use the firmware. If this is the firmware that gets me to 4.0.A.2.368 then Im going round and round in circle - e.g. im not on 4.0.A.2.368 but cant get to it as I need to be on it in order to flash the firmware

Hope that makes sense

ok somethign to clear up confusion:

1) this is not a ROM
2) this is a Original (untouched) SE Firmware (FW)
3) this thread gives u 2 options
- (a) update/flash to newest FW (no requirements other than FLASHTOOL)
- (b) if u want u can root this FW (using boot.img provided)

to get to latest FW u need to flash the FTF (link in 1st post) using FLASHTOOL...

The Following User Says Thank You to DooMLoRD For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes