Thread Closed

Power Button Issue

OP Master&Slave™

26th August 2011, 03:55 AM   |  #1  
Master&Slave™'s Avatar
OP Recognized Developer
Flag Philadelphia
Thanks Meter: 2,838
 
3,162 posts
Join Date:Joined: Feb 2011
Donate to Me
More
I have been having odd power button issues since updating to 2.3.4. It is almost like it is getting stuck or something.

Sometimes when I hit the power button to turn off the screen, the screen goes off for half a second then comes back on. This also happens when going from off to on (i.e. flicker on then back off), but it seems rarer.

Sometimes when I hit the home button (and just the home button), it takes a screenshot like I am hitting the button as well even though I am not.

All of this is fixed by just hitting the power button a few times.

Needless to say it is annoying. I thought it might be something mechanical, but I took the case off the back and the issue still occurred. It also seems like the button is clicking then unclicking (i.e. not getting stuck). I had no issues prior to updating to 2.3.4.

Anyone else had this happen or know a fix or workaround?
26th August 2011, 09:47 AM   |  #2  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2011
Yes! I have the same exact problem after the update!!
Glad to see I'm not the only one.

It's very annoying.

My backlight turns on by itself randomly and often if you press the power button to turn the screen off, it goes off then comes back on or flickers on and off. The power button doesnt always turn the screen back on either.

It also gets stuck where I press the home screen and it keeps taking pictures.


HTC better fix this!
26th August 2011, 10:28 AM   |  #3  
Senior Member
Thanks Meter: 7
 
114 posts
Join Date:Joined: Nov 2006
More
Quote:
Originally Posted by Master&Slave™

I have been having odd power button issues since updating to 2.3.4. It is almost like it is getting stuck or something.

Sometimes when I hit the power button to turn off the screen, the screen goes off for half a second then comes back on. This also happens when going from off to on (i.e. flicker on then back off), but it seems rarer.

Sometimes when I hit the home button (and just the home button), it takes a screenshot like I am hitting the button as well even though I am not.

All of this is fixed by just hitting the power button a few times.

Needless to say it is annoying. I thought it might be something mechanical, but I took the case off the back and the issue still occurred. It also seems like the button is clicking then unclicking (i.e. not getting stuck). I had no issues prior to updating to 2.3.4.

Anyone else had this happen or know a fix or workaround?

I have the exact same problem too since upgrading! I have disabled the screenshot function in build.prop but that only stops the repeated screenshots part of the problem. The main problem with the power button still persists.
The Following User Says Thank You to f3nd3r For This Useful Post: [ View ]
26th August 2011, 12:13 PM   |  #4  
Junior Member
Flag Nottingham
Thanks Meter: 1
 
10 posts
Join Date:Joined: May 2011
More
I'm having this too, its come and gone to different extents - pretty sure it was happening a bit before the update though.
I'm worried it is mechanical, I couldn't get it to happen with the back cover off but it could have just been coincidence. I can live with having to press the button again every so often but the screenshot thing annoys the hell out of me!
26th August 2011, 12:26 PM   |  #5  
Member
Flag Hampton Roads
Thanks Meter: 4
 
70 posts
Join Date:Joined: Aug 2011
More
Since the update I've experienced an issue with my power button as well. Sometimes when I hit the button to turn the screen on, nothing happens. At first I thought it was just me but it happens at least a couple of times a day and never happened before the update.
I don't normally turn my screen off by pressing the power button so I can't report on that. Guess I should count my blessing that the screen shot function is not acting up.

Thanks for posting cause was beginning to think it was just me.
26th August 2011, 01:49 PM   |  #6  
Master&Slave™'s Avatar
OP Recognized Developer
Flag Philadelphia
Thanks Meter: 2,838
 
3,162 posts
Join Date:Joined: Feb 2011
Donate to Me
More
FIX!
I found a fix for this, in your build.prop remove the framework line for screen shots and then go in recovery and whipe cache partition twice as well as dalvic twice!

Cheers!
26th August 2011, 02:34 PM   |  #7  
Senior Member
Thanks Meter: 7
 
114 posts
Join Date:Joined: Nov 2006
More
Quote:
Originally Posted by Master&Slave™

I found a fix for this, in your build.prop remove the framework line for screen shots and then go in recovery and whipe cache partition twice as well as dalvic twice!

Cheers!

I've just tried this twice but the problem still persists. Sure the screenshot issue is gone but the powering on and off the display is still intermittent.



Sent from my HTC Sensation Z710e using XDA App
26th August 2011, 02:46 PM   |  #8  
HigherSensation's Avatar
Senior Member
Flag New York
Thanks Meter: 51
 
167 posts
Join Date:Joined: Aug 2011
More
I was having the same problem with the power button and was thinking it was hardware thanks for the heads up..
26th August 2011, 03:43 PM   |  #9  
Member
Thanks Meter: 8
 
88 posts
Join Date:Joined: Jul 2011
More
am I like the only one without this problem >.< lol. lucky me
26th August 2011, 05:28 PM   |  #10  
Member
Flag San Jose, CA
Thanks Meter: 4
 
93 posts
Join Date:Joined: Dec 2007
More
I have this same problem too, I believe its connected to the screenshots but i don't know how to turn it off easily (how do I get into build prop?)

This is definitely after the update, I had absolutely no problems with the power button prior to the update.

Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes