Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[HOW-TO]UNLOCK bootloader for X10

OP 9Lukas5

26th April 2012, 12:25 PM   |  #771  
9Lukas5's Avatar
OP Senior Member
Flag near Stuttgart
Thanks Meter: 1,270
 
2,759 posts
Join Date:Joined: Dec 2010
Donate to Me
More
Quote:
Originally Posted by patmacca

Hi Guys can anyone confirm that it is safe to unlock my BL without resetting my simlock? Has anyone tried?

The phone was originally locked to orange and I used qUnlockTool.exe to unlock it...

Thanks

it's not for 100% safe, you should check as described in op with s1tool, or simply (also as written in first-line of op) use flashtool and unlock with that. If flashtool doesn't unlock, it's because it has tested it before, if you can do it safely.

Quote:
Originally Posted by lucaoldb

No, it is not sure at all. You can use this method if you have never simunlocked at all or if you have simunlocked by settool2. That's all.

it's possible that other simunlock tools are also compatible with the bl unlock, but we don't know which or if there are any, so simply always test it, then you can be sure.

L
29th April 2012, 11:45 AM   |  #772  
Senior Member
Thanks Meter: 35
 
487 posts
Join Date:Joined: Sep 2008
Some of the links in the first post are down, e.g. the kernel downgrade/upgrade links. I believe that flashtool can now be used to unlock the bootloader but I cannot get it to recognise the phone in flash mode even with the correct drivers installed. Is there another way to unlock the bootloader?
6th May 2012, 01:55 PM   |  #773  
botski's Avatar
Senior Member
Thanks Meter: 55
 
1,175 posts
Join Date:Joined: May 2010
More
mate, please help me. i dont know where to start.
6th May 2012, 05:13 PM   |  #774  
Junior Member
Flag Uberlandia
Thanks Meter: 0
 
26 posts
Join Date:Joined: Oct 2010
More
I'm getting.

Running S1_EROM VER "R8033"
SOFTWARE AID: 0001
LOADER AID: 0001
can't get S1 comma
nd header
LOADER NOT RESPONDING
Elapsed: 60 secs.


What does it mean?
When i try flashing anything in flashtool i get stuck at Flashing Loader
6th May 2012, 06:40 PM   |  #775  
9Lukas5's Avatar
OP Senior Member
Flag near Stuttgart
Thanks Meter: 1,270
 
2,759 posts
Join Date:Joined: Dec 2010
Donate to Me
More
Quote:
Originally Posted by almomdegal

I'm getting.

Running S1_EROM VER "R8033"
SOFTWARE AID: 0001
LOADER AID: 0001
can't get S1 comma
nd header
LOADER NOT RESPONDING
Elapsed: 60 secs.


What does it mean?
When i try flashing anything in flashtool i get stuck at Flashing Loader

try to flash the stock 2.3.3 and then boot up and try to run the bootloader unlock plugin from flashtool, after that you should see in the s1output a lower_case r in the erom version.

L
6th May 2012, 11:58 PM   |  #776  
Junior Member
Flag Uberlandia
Thanks Meter: 0
 
26 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by 9Lukas5

try to flash the stock 2.3.3 and then boot up and try to run the bootloader unlock plugin from flashtool, after that you should see in the s1output a lower_case r in the erom version.

L

the thing is.
I can't.
Whenever i try flashing another rom or kernel like stock 2.3.3 the phone flashtool gives me
Flashing Loader and i get stuck there like 4ever

And i get this from flashtool get a look on the time i wait and it doesn't get out from 0%


06/002/2012 14:02:26 - INFO - <- This level is successfully initialized
06/002/2012 14:02:27 - INFO - Flashtool Version 0.7.1.0 built on 2012-05-01 22:07:23
06/002/2012 14:02:27 - INFO - You can drag and drop ftf files here to start flashing them
06/002/2012 14:02:34 - INFO - Device disconnected
06/002/2012 14:02:47 - INFO - Selected X10i_3.0.1.G.0.75_1241-1846.ftf
06/002/2012 14:02:47 - INFO - Preparing files for flashing
06/002/2012 14:02:53 - INFO - Please connect your device into flashmode.
06/003/2012 14:03:11 - INFO - Device connected in flash mode
06/003/2012 14:03:11 - INFO - Opening device for R/W
06/003/2012 14:03:11 - INFO - Reading device information
06/003/2012 14:03:11 - INFO - Phone ready for flashmode operations.
06/003/2012 14:03:11 - INFO - Start Flashing
06/003/2012 14:03:11 - INFO - Flashing loader
06/047/2012 14:47:28 - INFO - Ending flash session
06/047/2012 14:47:28 - ERROR - Read error :31 : Um dispositivo conectado ao sistema não está funcionando.
06/047/2012 14:47:28 - ERROR - Error flashing. Aborted
06/047/2012 14:47:28 - INFO - Device disconnected
Last edited by almomdegal; 7th May 2012 at 12:02 AM.
8th May 2012, 09:24 PM   |  #777  
Senior Member
Flag Rio Claro
Thanks Meter: 27
 
202 posts
Join Date:Joined: Apr 2012
More
I need to say thank you so much to creators of thread/files, that's made possible unlock my bootloader. I could post many replies asking what to do, but reading and trying i made it!
9th May 2012, 05:11 AM   |  #778  
hovensy's Avatar
Member
Flag Caloocan
Thanks Meter: 5
 
73 posts
Join Date:Joined: Jan 2009
hi there guys, I've been trying to search in forums but haven't find the correct answers.
I have followed the steps properly but my X10 ended up dead...

flash the azuzu kernel downgrade ftf with flashtool --done OK
disconnect usb cable, press power button until phone vibrates shortly and immidiatly --done OK
connect the usb cable again (it is supposed to be stuck at SE logo) --done OK
start the batch file for unlocking bootloader, cause it says press any button before it starts, it won't start unlocking until you press any button
now wait until flashtool recognizes your x10 (if flashtool doesn't do anything, check third post please! thx) --done OK
close flashtool and then press any button in the cmd window that the unlocking process starts (please close flashtool, instead the bl unlock cmd and flashtool are constantly killing and restarting adb!!)--done OK... results SUCESS
after unlocking is finish you have to flash azuzu kernel upgrade--this is where my phone stops.. vibrates but still remain blank... need HELP please

now flashtool has error

ERROR - ERR_SEVERITY="MAJOR";ERR_CLASS="SECURITY_CLASS";ER R_DYNAMIC="SIN header verification failed
Last edited by hovensy; 9th May 2012 at 06:13 AM.
24th May 2012, 07:17 AM   |  #779  
Senior Member
Thanks Meter: 5
 
385 posts
Join Date:Joined: Jul 2010
More
I never unlocked bootloader of my x10i ..
I just simunlocked my phone from a local shop ..

But on S1tool it shows like this ..


Welcome to S1 tool.


RUNNING S1_EROM VER "r8A033"
SOFTWARE AID: 0001
LOADER AID: 0001
FLASH ID: "002C/00B3"
LOADER VERSION: "r4A024"
MODEL (from GDFS): X10i
SOFTWARE VERSION: 1227-4612_2.1.B.0.1
CUSTOM VERSION: 1235-7836_R9B
FILESYSTEM VERSION: WORLD-1-4-8_2.1.B.0.1

NOT RECOGNIZED SIMLOCK CERTIFICATE
MAYBE YOU SHOULD UNLOCK PHONE BY SETOOL2 ?
Elapsed:7 secs.

Why is it showing small "r" , if i have not unlocked bootloader?
25th May 2012, 11:36 PM   |  #780  
Taosaur's Avatar
Senior Member
Flag Ohiopolis
Thanks Meter: 186
 
813 posts
Join Date:Joined: May 2011
Well, this thread is looking pretty abandoned I got as far as re-upgrading my kernel, and my phone works fine, but now I can't flash anything in Flashtool. I get the same error as hovensy:

Quote:
Originally Posted by hovensy

ERROR - ERR_SEVERITY="MAJOR";ERR_CLASS="SECURITY_CLASS";ER R_DYNAMIC="SIN header verification failed

I tried a couple of Doomkernels and Azuzu's downgrade to try and start over (I didn't see for sure if the unlocker was successful before hitting a key and closing the window), but they all kick out the same error. The s1tool tells me the same as when I started, SEMC simlock certificate.

So, am I just stuck with the ROM I've got forever, or what? I'll try to uninstall then reinstall Flashtool, then maybe try restoring the phone backup I made before I started. Any other ideas?

ETA: ROM was (and still is) TEAM ROM, Gingerbread. My PC is Win7x64. Also have xRecovery on my X10
Last edited by Taosaur; 25th May 2012 at 11:46 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes