FORUMS

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

Droid Turbo Lollipop OTA, 2015 Moto G Leaked – XDA TV

Android Lollipop for the Droid Turbo has been released. That and much more … more

EVLeaks Shows Off Possible BlackBerry Android Phone

It wasn’t too long ago that we received reports of BlackBerry planning to use … more

Defy Not Charging - Question Mark?

107 posts
Thanks Meter: 2
 
By indyjonesUK, Senior Member on 15th September 2011, 08:58 AM
Post Reply Subscribe to Thread Email Thread
Hi all,

Hi hoping someone could help, a guy at work has handed me his Defy as its not charging. Plugged it in and after the M splash screen it goes to the battery charging screen. Only problem is that just shows a massive question mark ? Anyone know what that means please? My ony thought is its not a a genuine battery so the phone is having diffaculty reading the charge level or something ?

Cheers
 
 
15th September 2011, 12:50 PM |#2  
Member
Thanks Meter: 3
 
More
I can think of three reasons why the battery why the battery wont charge:
  1. You are not using the original charger
  2. You don't have the right battery
  3. The battery is defect
It is easy to test point one: Just plug your phone in an USB-port of a running PC.

Otherwise you could buy an original battery, or if you know someone else with a defy, swap batteries and test...
15th September 2011, 02:13 PM |#3  
Junior Member
Thanks Meter: 2
 
More
I too had same issue, used universal battery charger for charging the battery for some time and then on its working fine.

Sent from my MB525 using XDA Premium App
15th September 2011, 03:11 PM |#4  
Member
Thanks Meter: 7
 
More
And you can charge it with an USB cable and a PC?
15th September 2011, 06:26 PM |#5  
bobbyphoenix's Avatar
Senior Member
Flag Orlando, FL
Thanks Meter: 390
 
More
It just happened to me two days ago. A battery pull and put back solved it. There must be something with the connections. Got me. Only happened that one time.
5th December 2012, 07:10 PM |#6  
Junior Member
Thanks Meter: 0
 
More
I too had same issue,how did you solve !?
5th December 2012, 08:07 PM |#7  
jalal-jap's Avatar
Senior Member
Flag Tehran
Thanks Meter: 31
 
More
Unhappy
I too had same issue in 7 mounts
10th January 2013, 10:53 AM |#8  
matrix866's Avatar
Member
Flag Bari
Thanks Meter: 9
 
More
I have the same problem. If I connect my defy to a pc the white LED of charging turn ON but it doesn't charge. It can boot but it turn off after the boot because have no charge!
11th January 2013, 01:08 AM |#9  
Senior Member
Thanks Meter: 54
 
More
you could also have a wrong battd!
11th January 2013, 01:20 PM |#10  
desertmod1's Avatar
Senior Member
Thanks Meter: 21
 
More
I have one charger that charge some android phones ( old xperia and samsung) but doesn't charge my defy or a newer samsung.
Anyway, I use an original samsung charger (don't buy those cheap $1 ones) and it can charge any phone.
It's strange because the voltage written written on both is the same and so is the mini usb plug (the amps are higher on the original though).
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes