Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,110 Members 40,659 Now Online
XDA Developers Android and Mobile Development Forum

Erratic battery reporting on 2.3.4 update

Tip us?
 
nateohio
Old
#1  
Member - OP
Thanks Meter 13
Posts: 96
Join Date: Jan 2011
Default Erratic battery reporting on 2.3.4 update

I flashed the newest update (2.3.4) this last weekend and although its been great with battery life, I cant seem to get the actual reporting to settle in.

When I take it off the charger its reporting 100%, and throughout
the day it obviously drains the battery. The problem is when I reboot the phone, it starts back up reporting 10-20% higher battery life then when I shut it down. So in reality, I have more battery life left then whats being reported.

I charged to 100% and wiped battery stats using bootstrap. Then drained the battery all the way, and charged all the way back to a full charge.

Can you guys think of anything else that may fix this issue?


Sent from my DROID X2 using xda premium
 
buddyfriendo
Old
#2  
buddyfriendo's Avatar
Senior Member
Thanks Meter 37
Posts: 177
Join Date: Apr 2011
Location: Massachusetts
I noticed this as well, I thought it was my Mugen Power battery giving false reports but it looks like it isn't the case..

I just don't reboot as often now, can't say I've noticed any problems other than that. My battery life has been excellent!
 
ilovesoad
Old
#3  
ilovesoad's Avatar
Senior Member
Thanks Meter 47
Posts: 512
Join Date: May 2011
Location: Plano, TX
Quote:
Originally Posted by cheesebeard View Post
I noticed this as well, I thought it was my Mugen Power battery giving false reports but it looks like it isn't the case..

I just don't reboot as often now, can't say I've noticed any problems other than that. My battery life has been excellent!
I normally can go about 14 hours or so off the charger. This past cycle, I went 36 hours, with normal use

Sent from my DROID X2 using Tapatalk
Nexus4 AOKP 4.2.2 with FrancoKernel
B&N Nook HD+ Hybrid SD CM10
 
K33pw1shen
Old
#4  
K33pw1shen's Avatar
Senior Member
Thanks Meter 2
Posts: 100
Join Date: Jul 2011
Location: Orangeville PA
Same thing here I had 80% rebooted and had 100 so I wiped battery stats this morning and I'm working on killing it now lol ......so far 8 hours and 70% left

X2gingerfuncked
 
ashclepdia
Old
#5  
ashclepdia's Avatar
Senior Member
Thanks Meter 1,524
Posts: 4,384
Join Date: Aug 2011
Location: under philadelphia above Delaware, beer heaven

 
DONATE TO ME
Quote:
Originally Posted by ilovesoad View Post
I normally can go about 14 hours or so off the charger. This past cycle, I went 36 hours, with normal use

Sent from my DROID X2 using Tapatalk
Standard battery? Wow

I have never seen a number higher than 14hrs for me. But then again I am CONSTANTLY on my phone.
I want an extended battery but I like my otterbox to much. So I just carry a spare in my wallet.
Off topic gone??? Mods got you down??? Visit motcher41's
Google+ Droid Friends & General Help Community
Anyone and virtually anything welcome there!
My GALAXY NEXUS(huzzah!) is running

Don't get left in the dark!
 
ilovesoad
Old
#6  
ilovesoad's Avatar
Senior Member
Thanks Meter 47
Posts: 512
Join Date: May 2011
Location: Plano, TX
Quote:
Originally Posted by ashclepdia View Post
Standard battery? Wow

I have never seen a number higher than 14hrs for me. But then again I am CONSTANTLY on my phone.
I want an extended battery but I like my otterbox to much. So I just carry a spare in my wallet.
Must have been a fluke. Today isn't the same story.

Sent from my DROID X2 using Tapatalk
Nexus4 AOKP 4.2.2 with FrancoKernel
B&N Nook HD+ Hybrid SD CM10
 
stick1300
Old
#7  
stick1300's Avatar
Senior Member
Thanks Meter 101
Posts: 480
Join Date: Jun 2010
I've noticed the same thing, since flashing Eclipse v1.0
 
hapyman
Old
#8  
Member
Thanks Meter 4
Posts: 49
Join Date: Jul 2011
Seems to be a bug in the SBC file. Hopefully we have a fix after the soak test. Or maybe nitro will take a stab at it.

Sent from my DROID X2 using XDA App
 
Raw Dodge
Old
#9  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jan 2011
Mine is doing it too.
 
X0dus
Old
#10  
X0dus's Avatar
Senior Member
Thanks Meter 127
Posts: 690
Join Date: Apr 2011
Location: Cornvoy
This is a very annoying bug. I went back to 2.3.3 until it's fixed.

Sent from my DROID X2 using XDA App
What you're entitled to as a member of XDA
VZW Samsung Fascinate - CM7 and OTB oc/uv kernel
VZW Moto Droix X2 - Liberty ROM w/ locked bootloader
VZW SGSII Stock - Wife's Phone
AT&T LG NitroHD - HO!NO! Full Throttle v9 1512Mhz; -75uv 192Mhz to 1512Mhz; GPU OC

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes