APKTool Updated with Android Lollipop Support

One of the beauties of Android is the level of flexibility we have over our devices. Whether … more

Lollipop Leak for Sprint Galaxy S5, TWRP for Micromax Canvas Magnus – XDA TV

Android 5.0 Lollipop has been leaked for the Sprint … more

Velocity is Like OpenTable on Steroids

We all enjoy a night out with friends or our significant other from time to time. However, there is … more

Android Lollipop Lands for the Sony Xperia Z Ultra

The undisputed king of the beasts–at least in Sony’s current stable,is the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Copying su to /system... fail! help?

OP Flipnotix

7th October 2011, 05:23 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Oct 2011
I am fairly new with using android phones, and I am encountering that error when I am attempting to update Superuser. I'm using a Samsung Admire SCH-R720 Android 2.3.4 and I rooted it with the One Click root. I've downloaded titanium backup, Root Checker, and terminal emulator to make sure I am really rooted. I've tried uninstall/reinstalling superuser, installing the superuser update fixer(which said signatures matched), and clicking on automatic update. Current version of SU Binary is 2.3.1-ef and everything in the update is fine until it gets to "Copying su to /system... fail!". Superuser does request for rights when it asks to gain root access which I click on Allow. I am also not sure if busybox installed correctly or not, but the Root Checker program I installed said busybox was installed.

Code:
Downloading manifest... okay!
Parsing manifest... okay!
Latest Version = 3.0
Checking installed version = 2.3.1-ef
Fixing Database... okay!
Downloading custom busybox... okay!
Checking md5sum... okay!
Checking current install path... /system/bin/su
Downloading new binary... okay!
Checking md5sum... okay!
Gaining root access... okay!
Remounting /system as rw... okay!
Copying su to /system... fail!
7th October 2011, 07:25 AM   |  #2  
Junior Member
Thanks Meter: 1
 
2 posts
Join Date:Joined: Feb 2011
I got the same problem with my Galaxy S. Then I opened BusyBox Installer and it said that I have multiple busybox installed. I found busybox in /system/xbin and /sbin but the file size of the one in /sbin seemed abnormal, just 402 bytes. So I reinstalled busybox to /sbin. And rerun the superuser update after that. The fail has gone.
The Following User Says Thank You to chorshan For This Useful Post: [ View ]
7th October 2011, 07:45 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Oct 2011
What program did you use to explore your system files?
7th October 2011, 08:47 AM   |  #4  
Junior Member
Thanks Meter: 1
 
2 posts
Join Date:Joined: Feb 2011
Astro file manager
8th October 2011, 05:04 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Oct 2011
I only have busybox in system/xbin. I tried reinstalling busybox and i still get the same error when trying to update Super user. How can I uninstall Busybox? Please give a step by step if possible since I have no clue what the hell I am doing lol.

Edit 2: Er... I tried installing it also in system/bin, and it SEEMS like its working. Seems it's installed in 3 places, on my sd, bin, and xbin. It works now, so I won't touch it lol. Thanks for the help.
Last edited by Flipnotix; 8th October 2011 at 05:21 AM.
17th July 2012, 12:11 PM   |  #6  
Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: Jul 2012
Hi everyone,
Same problem for me too.
after installed busybox in system/xbin using busybox installer downloaded from android market, the problem with superuser update was fixed.
I used in samsung galaxy s2..


Thank u
Post Reply Subscribe to Thread

Tags
admire, binary, samsung, superuser, update
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes